当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : IBM T43_6cu 8.04 使用tp_smapi
帖子发表于 : 2008-05-08 22:59 

注册: 2007-04-01 9:50
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
前两天使用从7.10换到8.04。发现tp_smapi-0.37,不能使用了。总是提示路径了版本不对。记得在论坛里面有人也问过这样的问题。花了一个晚上的时间研究了一下tp_smapi的makefile 。修改了一些设置,现在已经能在我的机器上面用了。
步骤:
1. 查看linux 内核版本,现在内核source ,解压
2. 安装tp_smapi:
sudo apt-get install tp-smapi-source
3. 进入 tp-smapi-source安装路径,解压。备份Makefile
cp Makefile Makefile.bak
4. 打开Makefile
sudo vim Makefile
按照自己机器上的路径修改
X:=$(shell false)
KVER := $(shell uname -r)
KBASE := /lib/modules/$(KVER)
#KSRC ?=$(PWD)
#-KSRC := $(KBASE)/source
KSRC := /usr/src/linux-source-2.6.24.-16-generic/ ####linux-source-2.6.24.-16-generic是内核文件的文件夹。
####个人根据自己的情况来改写
KBUILD := $(KBASE)/build
MOD_DIR := $(KBASE)/kernel
PWD := $(shell pwd)
主要改写的就是KSRC,上面没有提到但Makefile里面有的就不要动了。
5. 保存退出。
6. sudo make load HDAPS=1
可以看见提示成功了。
以后要装什么gnome-hdaps- apple的就自己去google一下了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译