联想天逸F41 A T5550声音耳机输出完美解决!!!

笔记本/超便携移动PC软硬件相关支持,包括硬件、安装和驱动等
sczlin
帖子: 97
注册时间: 2006-04-06 11:23
送出感谢: 0
接收感谢: 0

联想天逸F41 A T5550声音耳机输出完美解决!!!

#1

帖子 sczlin » 2008-06-29 13:11

参见我的博客:

http://blog.scylzx.net/doc.php?action=doclist

耳机正常输出声音,插上耳机,自动关闭内置音箱声音,拔下耳机后,自动切换到内置扬声器输出,嘿嘿,算是完美了哈!!
icSarge
帖子: 135
注册时间: 2007-07-08 19:36
系统: Chakra
送出感谢: 0
接收感谢: 0

#2

帖子 icSarge » 2008-06-29 19:00

超赞!解决了老问题
虽然我不是F41的用户
bbmmzz
帖子: 8
注册时间: 2008-05-30 10:21
送出感谢: 0
接收感谢: 0

#3

帖子 bbmmzz » 2008-06-29 22:59

请问怎么卸载原来的驱动??能不能详细说一下
不再执意欢喜反倒让人欢喜
sczlin
帖子: 97
注册时间: 2006-04-06 11:23
送出感谢: 0
接收感谢: 0

#4

帖子 sczlin » 2008-06-29 23:04

bbmmzz 写了:请问怎么卸载原来的驱动??能不能详细说一下



最简单用新立得吧,在新立得里,搜索alsa,在驱动里,只保留alsa-base,编译的时候好像要依赖它的。
其实这个都不是必须的,最关键的是要替换掉linux内核里的ubuntu模块里的alsa驱动里的snd-hda-intel模块。
安装ubuntu时,一般都自动装上了 linux-ubuntu-modules-2.6.24-19-generic 这个哈,这个里包括了alsa驱动,替换也是替换它里面的驱动模块。


zhang@ubuntu:~/downloads$ ls -l /lib/modules/2.6.24-19-generic/ubuntu/sound/alsa-driver/pci/hda/
总用量 2632
-rw-r--r-- 1 root root 2230482 2008-06-29 11:59 snd-hda-intel.ko #编译出来的新模块
-rw-r--r-- 1 root root 450788 2008-06-19 02:50 snd-hda-intel.ko-bak #怕出问题,将原模块备份了,嘿嘿
zhang@ubuntu:~/downloads$

看到了吧,新编译出的模块比原来的文件大了好多呢~


头像
异域追梦者
帖子: 424
注册时间: 2008-02-18 0:25
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 异域追梦者 » 2008-06-29 23:49

我除了alsa-utils没有编译成功 其它步骤完全相同 重启后连声卡都识别不了了 囧

代码: 全选

-rw-r--r-- 1 root root 2230142 2008-06-29 22:38 snd-hda-intel.ko
图片
sczlin
帖子: 97
注册时间: 2006-04-06 11:23
送出感谢: 0
接收感谢: 0

#6

帖子 sczlin » 2008-06-30 7:06

异域追梦者 写了:我除了alsa-utils没有编译成功 其它步骤完全相同 重启后连声卡都识别不了了 囧

代码: 全选

-rw-r--r-- 1 root root 2230142 2008-06-29 22:38 snd-hda-intel.ko


重新编译alsa-utils,可能是某些库没安装全,所以没编译成功,编译成功后,用sudo alsaconf配置一下声卡吧!!
头像
异域追梦者
帖子: 424
注册时间: 2008-02-18 0:25
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 异域追梦者 » 2008-06-30 13:18

谢谢, 我再去试试.
图片
头像
异域追梦者
帖子: 424
注册时间: 2008-02-18 0:25
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 异域追梦者 » 2008-07-01 1:02

还是不行, alsaconf都能找到声卡, 但音量控制就是打不开.
图片
maybeloveu
帖子: 31
注册时间: 2008-02-05 16:27
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 maybeloveu » 2008-07-16 14:22

我的也是音量控制打不开
老ben
帖子: 2
注册时间: 2008-07-16 14:47
送出感谢: 0
接收感谢: 0

#10

帖子 老ben » 2008-07-16 14:49

菜鸟菜问题

5、还原/etc/modprobe.d/alsa-base

具体怎么个操作法?谢谢
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#11

帖子 dogfox » 2008-07-16 14:53

全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
sczlin
帖子: 97
注册时间: 2006-04-06 11:23
送出感谢: 0
接收感谢: 0

#12

帖子 sczlin » 2008-07-17 9:43

老ben 写了:菜鸟菜问题

5、还原/etc/modprobe.d/alsa-base

具体怎么个操作法?谢谢



也就是把alsa-base文件内容修改了的部分,重新改回到未修改以前的那样就可以了。
zissan
帖子: 5
注册时间: 2007-04-25 19:00
送出感谢: 0
接收感谢: 0

#13

帖子 zissan » 2008-07-17 21:26

我的三个建议,供F41的用户参考。
1.必须从选择从http://ftp.kernel.org/pub/linux/kernel/people/tiwai/alsa/下载最新的alsa驱动,同样的版本从alsa官网下载编译之后就是无法使用。我不知道为什么,但是我的经历就是如此。
2.编译之后将/lib/modules/YOUR-KERNEL-VERSION/kernel/sound/目录下的acore和pci文件夹复制到/lib/modules/YOUR-KERNEL-VERSION/ubuntu/sound/alsa-driver/目录下。
3./etc/modprobe.d/alsa-base 文件最后一行改成

代码: 全选

options snd-hda-intel model=lenovo-3000
maybeloveu
帖子: 31
注册时间: 2008-02-05 16:27
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 maybeloveu » 2008-07-18 15:02

zissan 写了:我的三个建议,供F41的用户参考。
1.必须从选择从http://ftp.kernel.org/pub/linux/kernel/people/tiwai/alsa/下载最新的alsa驱动,同样的版本从alsa官网下载编译之后就是无法使用。我不知道为什么,但是我的经历就是如此。
2.编译之后将/lib/modules/YOUR-KERNEL-VERSION/kernel/sound/目录下的acore和pci文件夹复制到/lib/modules/YOUR-KERNEL-VERSION/ubuntu/sound/alsa-driver/目录下。
3./etc/modprobe.d/alsa-base 文件最后一行改成

代码: 全选

options snd-hda-intel model=lenovo-3000




谢谢你的方法,我成功了。
589677
帖子: 84
注册时间: 2008-06-01 0:16
送出感谢: 1 次
接收感谢: 0
联系:

#15

帖子 589677 » 2008-07-21 22:09

成功了,终于有耳机了!!!!!哈哈哈
回复

回到 “笔记本、UMPC支持”