当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]有人在SIS板的笔记本上成功设置分辨率否?
帖子发表于 : 2008-07-24 9:27 

注册: 2008-07-12 23:51
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
一直没有成功。
最近拿到了一据说是支持SIS的2D驱动,编译出错,最后替换Xorg.conf也没用了。
好不容易挽救回来了日志,高手兄弟帮忙看看。
-----
(WW) Failed to open protocol names file /etc/X11/xserver/protocol.txt
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.4.99.905 (1.5.0 RC 5)
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux Ubuntu (xorg-server 2:1.4.99.905-0ubuntu4)
Current Operating System: Linux administrator-laptop 2.6.24-19-generic #1 SMP Wed Jun 18 14:43:41 UTC 2008 i686
Build Date: 16 July 2008 03:37:29PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 24 08:42:30 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Configured Monitor"
(**) | |-->Device "Configured Video Device"
(**) |-->Input Device "Synaptics Touchpad"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) No FontPath specified. Using compiled-in default.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) ModulePath set to "/usr/lib/xorg/modules"
(==) |-->Input Device "Configured Mouse"
(==) |-->Input Device "Generic Keyboard"
(==) The core pointer device wasn't specified explicitly in the layout.
Using the first core pointer device.
(==) The core keyboard device wasn't specified explicitly in the layout.
Using the first keyboard device.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Loader magic: 0x81d5a40
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 4.1
X.Org XInput driver : 2.1
X.Org Server Extension : 1.1
X.Org Font Renderer : 0.6
(II) Loader running on linux
(--) using VT number 9

(--) PCI:*(0@1:0:0) Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter rev 16, Mem @ 0xc0000000/0, 0xb0000000/0, I/O @ 0x00009000/0
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(==) AIGLX enabled
(==) Exporting typical set of GLX visuals
(II) Loading extension GLX
(II) LoadModule: "v4l"

(II) Loading /usr/lib/xorg/modules/drivers//v4l_drv.so
(II) Module v4l: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 0.1.1
ABI class: X.Org Video Driver, version 4.1
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.4.99.905, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"

(WW) Warning, couldn't open module dri2
(II) UnloadModule: "dri2"
(EE) Failed to load module "dri2" (module does not exist, 0)
(II) LoadModule: "sis"

(II) Loading /usr/lib/xorg/modules/drivers//sis_drv.so
(II) Module sis: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 0.10.0
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 4.1
(II) LoadModule: "synaptics"

(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
compiled for 4.3.99.902, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.1
(II) LoadModule: "mouse"

(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 1.3.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.1
(II) LoadModule: "kbd"

(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 1.3.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.1
(II) v4l driver for Video4Linux
(II) SIS: driver for SiS chipsets: SIS5597/5598, SIS530/620,
SIS6326/AGP/DVD, SIS300/305, SIS630/730, SIS540, SIS315, SIS315H,
SIS315PRO/E, SIS550, SIS650/M650/651/740, SIS330(Xabre),
SIS660/[M]661[F|M]X/[M]670/[M]741[GX]/[M]760[GX]/[M]761[GX]/[M]770[GX],
SIS340
(II) SIS: driver for XGI chipsets: Volari Z7 (XG20),
Volari V3XT/V5/V8/Duo (XG40)
(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for v4l
(WW) Falling back to old probe method for sis
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:0:0) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:1:0) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:2:0) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:2:5) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:3:0) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:3:1) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:3:3) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:4:0) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:5:0) found
(WW) SIS: No matching Device section for instance (BusID PCI:0@0:15:0) found
(EE) No devices detected.

Fatal server error:
no screens found


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-24 10:50 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
老老实实用vesa驱动吧


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-24 10:54 

注册: 2008-07-12 23:51
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
现在用什么也没用了。
我把Xorg.conf换成原先的,也起不了啦。
是不是要用你给的那个命令:dpkg-reconfigure?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-24 10:56 

注册: 2008-07-12 23:51
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
http://blog.chinaunix.net/u/15722/showart_654410.html
这位网友成功了,我按他的步骤来的,并且按给的英文链接从国外朋友的附件中补充了Sis_drv.so和Sis_drv.la.
感觉他的步骤似乎不可逆,现在想恢复原来的情况,已来不及了~


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-24 11:03 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
这个没有什么不可逆这样的事吧,试试

代码:
sudo dpkg-reconfigure xserver-xorg


或者直接用

代码:
sudo displayconfig-gtk


选用vesa驱动就是了,那个链接电脑跟我以前一样是q550s,不过没有试过编译那个


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-24 11:22 

注册: 2008-07-12 23:51
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
这个没有什么不可逆这样的事吧,试试

代码:
sudo dpkg-reconfigure xserver-xorg


或者直接用

代码:
sudo displayconfig-gtk


选用vesa驱动就是了,那个链接电脑跟我以前一样是q550s,不过没有试过编译那个

我试去了,回来报告结果。谢谢先。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-24 11:57 

注册: 2008-07-12 23:51
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
这个没有什么不可逆这样的事吧,试试

代码:
sudo dpkg-reconfigure xserver-xorg


或者直接用

代码:
sudo displayconfig-gtk


选用vesa驱动就是了,那个链接电脑跟我以前一样是q550s,不过没有试过编译那个

反馈:未成功。
1,第一条命令执行后有个类似图形界面出来,但里面的内容全是小三角,不知道是什么东东。直接敲确定到最后,就死到最后不动了。不知道怎么办。我重启一个界面登录进去,又说这个程序还在执行中……
2,用第二条命令,提示我用APT-GET安装相关的内容(似乎还提示与KDE有关,我现在用的GNOME),不管了,就按提示安装相关配置包,到中途提示联网时失败,因为文本下不能直接连网。
我又无计可施了……汗!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-24 12:03 

注册: 2008-07-12 23:51
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
到处都有人说,2.6.25内核支持sis集成显卡。
可是应该如何使用最新的内核?
我现在用Linux纯粹是想用它办公,而不是学习程序哎,浪费时间过多的话,会有些因小失大哎。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-07-24 12:32 

注册: 2008-07-12 23:51
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
等一下回复,若没有回复,就不试了。准备重装系统了。
错误的日志在这里附上。


附件:
文件注释: 最后收集的日志内容Xorg.0.log
Xorg.0.rar [4.3 KiB]
被下载 20 次
页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-07-24 14:37 

注册: 2008-07-12 23:51
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
OK.既然如此,还是重装了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译