当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题] NND,usb只能用到10分钟! ubuntu 804 hardy的新bug?<<已确认是BUG
帖子发表于 : 2008-08-11 20:31 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
经这两天的观查,确定问题状态,usb只能使用约10分钟左右。
具体规纳为IRQ自动关闭,
用各种手段,得知信息如下:

代码:
 dmesg | tail -4
[ 1024.249162]  =======================
[ 1024.249165] handlers:
[ 1024.249168] [<f8894b80>] (usb_hcd_irq+0x0/0x60 [usbcore])
[ 1024.249204] Disabling IRQ #21


代码:
grep 21 /proc/interrupts
21:     118736      81265   IO-APIC-fasteoi   ehci_hcd:usb4
215:       2440       1784   PCI-MSI-edge      eth0
216:      72340      73903   PCI-MSI-edge      iwl4965
217:      17697      18196   PCI-MSI-edge      ahci
RES:    1321906    1332966   Rescheduling interrupts


代码:
grep ehci_hcd /proc/interrupts
 19:          1          3   IO-APIC-fasteoi   ehci_hcd:usb3
 21:     118736      81265   IO-APIC-fasteoi   ehci_hcd:usb4


google了一下此问题,发现前人也遇到过,但一直没有找到解决办法。


最后由 kelen 编辑于 2008-08-12 9:25,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-11 21:37 

注册: 2005-10-04 19:38
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
这么高深的问题,闻所未闻


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-12 8:09 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
找到一个之前国内遇到类似问题的朋友。。。 :cry:
http://forum.ubuntu.org.cn/viewtopic.ph ... 18d3969c00


最后由 kelen 编辑于 2008-08-12 9:39,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-12 9:39 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
找到一个治标,不治本的方法。先凑合着,即删除已挂载的驱动模块ehci_hcd, 让其自再动加载一次
代码:
sudo modprobe -r --force ehci_hcd


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-12 19:32 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
jpwt


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-12 19:34 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
jpwt
:ema1

啥意思?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-12 19:34 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
极品问题?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-27 22:15 

注册: 2008-06-05 16:41
帖子: 184
送出感谢: 0 次
接收感谢: 0 次
从未听说过。

这种问题不要说是软件bug,去找硬件厂商提交bug


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-08-30 1:31 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
gaby 写道:
从未听说过。

这种问题不要说是软件bug,去找硬件厂商提交bug


既然是没有听说过,你何以建议提交bug到硬件厂商? :em40


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-08-30 3:35 
头像

注册: 2007-10-29 22:12
帖子: 5353
地址: 江苏南京
系统: OSX 10.9 + Ub 1304
送出感谢: 0 次
接收感谢: 5
老e都说了,是 机品 问题 不是 人品 问题 也不是 U品 问题

硬件兼容性问题


_________________
佛经说,人有八苦: 生、老、病、死、求不得、怨憎、爱别离、五阴盛 故我苦!
圣经说,人有七罪: 饕餮、贪婪、懒惰、淫欲、傲慢、嫉妒和暴怒  故我有罪!

我这篇帖子里面没有任何攻击我们伟大的中华人民共和国政府和任劳任怨的人民公仆(和本论坛高素质的版主)的文字和含义;

特此声明!

有些事,我们明知道是错的,也要去坚持,因为不甘心;有些人,我们明知道是爱的,也要去放弃,因为没结局;有时候,我们明知道没路了,却还在前行,因为习惯了。

欢迎来我的新浪微博@me


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-08-30 22:57 

注册: 2006-10-15 14:20
帖子: 97
送出感谢: 0 次
接收感谢: 0 次
貌似dell的装机ubuntu盘能解决。


_________________
联想 启天M245E
Celeron D 335
768M DDR
40G
Linux mint8


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-09-01 18:39 

注册: 2008-08-28 15:11
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
有感觉,usb传东西的时候标着的速度很快,但是就是数据传输量不动


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译