求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

笔记本/超便携移动PC软硬件相关支持,包括硬件、安装和驱动等
回复
头像
C.MyDogs
帖子: 284
注册时间: 2008-08-01 16:03
来自: 宁波
送出感谢: 0
接收感谢: 0

求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

#1

帖子 C.MyDogs » 2008-09-24 10:14

大概上周开始,用着用着会突然黑屏,屏幕像关掉了一样。什么反应都没有。
按Ctrl+Alt+f1~f6都没反应,屏幕就是黑掉。
显卡:Ati 7500
起初怀疑显卡和xorg.conf的配置问题。重新提交配置,网上也找了同型号的配置。但还是一样的情况。
后来想想可能是无线网卡的问题。
无线是:Athores 2414 Ubuntu8.04起初刚安装好系统的时候,认的出来,也可以用,但是使用开源驱动。在硬件驱动里都有显示。
后来发现信号不好,换了windows下的驱动。
过了几天发现黑屏问题。
网卡现在把windows下的驱动删除掉的话,就认不出来。

怎么回事啊?
怎么会突然黑屏幕的。

在黑屏后,使用过 Ctrl+Alt+F1 然后登陆,su 后 poweroff 或者 reboot 都没反应。
硬盘灯也不闪。
:em20
T400S ,SP9400, 64G SSD+500G HDD, 2G+4G ROM,1440*900 LED, GOBI1000 WWAN
头像
C.MyDogs
帖子: 284
注册时间: 2008-08-01 16:03
来自: 宁波
送出感谢: 0
接收感谢: 0

Re: 求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

#2

帖子 C.MyDogs » 2008-09-24 10:22

xorg.conf 的配置:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "EmulateWheel" "on"
Option "EmulateWheelButton" "2"
Option "YAxisMapping" "4 5"
Option "XAxisMapping" "6 7"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "SHMConfig" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
Identifier "ATi"
Driver "radeon"
Option "RenderAccel" "true"
Option "AGPMode" "4"
Option "EnablePageFlip" "true"
Option "XaaNoOffscreenPixmaps"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Common Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATi"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Modes "1024*768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
EndSection
头像
C.MyDogs
帖子: 284
注册时间: 2008-08-01 16:03
来自: 宁波
送出感谢: 0
接收感谢: 0

Re: 求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

#3

帖子 C.MyDogs » 2008-09-25 17:21

:em06 顶上,没人知道吗?
头像
C.MyDogs
帖子: 284
注册时间: 2008-08-01 16:03
来自: 宁波
送出感谢: 0
接收感谢: 0

Re: 求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

#4

帖子 C.MyDogs » 2008-09-26 10:49

:em20 还是有问题啊
怎么没人回答。
昨天开机后,登陆后,没操作,过了一会,把屏幕角度换了一下,又黑掉,汗····
T400S ,SP9400, 64G SSD+500G HDD, 2G+4G ROM,1440*900 LED, GOBI1000 WWAN
zigzed
帖子: 267
注册时间: 2006-02-27 10:32
送出感谢: 0
接收感谢: 0

Re: 求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

#5

帖子 zigzed » 2008-09-26 15:45

是否显示器到电脑的接线有问题?
头像
C.MyDogs
帖子: 284
注册时间: 2008-08-01 16:03
来自: 宁波
送出感谢: 0
接收感谢: 0

Re: 求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

#6

帖子 C.MyDogs » 2008-09-26 16:39

难道是屏线的问题,但是在WIN下是没问题的,随便摆动屏幕都没关系。
想不通是什么原因。
晚上再把无线驱动装一下 。
T400S ,SP9400, 64G SSD+500G HDD, 2G+4G ROM,1440*900 LED, GOBI1000 WWAN
头像
C.MyDogs
帖子: 284
注册时间: 2008-08-01 16:03
来自: 宁波
送出感谢: 0
接收感谢: 0

Re: 求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

#7

帖子 C.MyDogs » 2008-10-28 13:35

:em20 问题继续
请各位帮忙。
T400S ,SP9400, 64G SSD+500G HDD, 2G+4G ROM,1440*900 LED, GOBI1000 WWAN
actioin
帖子: 28
注册时间: 2007-08-17 11:32
送出感谢: 0
接收感谢: 0

Re: 求助,IBM T40 Ubuntu8.04 启动后黑屏幕问题。

#8

帖子 actioin » 2008-11-21 21:57

我也是t40,还没有遇到你所说的情况。

我的xorg.conf,看看有用没...

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "CoreKeyboard"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ImPS/2"
# Option "ZAxisMapping" "4 5"
# Option "Emulate3Buttons" "true"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizScrollDelta" "0"
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Driver "wacom"
# Identifier "stylus"
# Option "Device" "/dev/input/wacom"
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# Option "Device" "/dev/input/wacom"
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

# commented out by update-manager, HAL is now used
#Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# Option "Device" "/dev/input/wacom"
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# commented out by update-manager, HAL is now used
# InputDevice "Generic Keyboard"
# commented out by update-manager, HAL is now used
# InputDevice "Configured Mouse"
# commented out by update-manager, HAL is now used
# InputDevice "stylus" "SendCoreEvents"
# commented out by update-manager, HAL is now used
# InputDevice "cursor" "SendCoreEvents"
# commented out by update-manager, HAL is now used
# InputDevice "eraser" "SendCoreEvents"
# commented out by update-manager, HAL is now used
# InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection
回复

回到 “笔记本、UMPC支持”