当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享]刚搞定了treo用蓝牙跟evolution (gpilot/Gnome-pilot)同步的问题....
帖子发表于 : 2009-05-15 21:45 

注册: 2008-12-03 16:46
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
搜到的treo与ubuntu同步的帖子都是用jpilot和treo蓝牙同步,好像大家已经结论性的认为treo用蓝牙没有办法跟evolution同步...
一年前刚改用ubuntu那段时间,在无数个不眠之夜里,试过无数种办法也没有成功,最后只好放弃,一直将就着用usb线同步evolution,但这个该死的usb又总是“接触不良”....今天心血来潮又试了一下,居然一次成功,让我激动不已。

0。编辑~/.profile加入:export PILOT_CHARSET=GBK,这个可以解决,中文乱码的问题

1。用sudo gedit /etc/default/bluetooth,修改bluetooth,在里面加入以下两行:
DUND_ENABLED=1
DUND_OPTIONS="--listen --persist --msdun call treo"

2。编辑/etc/ppp/peers/treo
$ sudo gedit /etc/ppp/peers/treo
内容如下:
115200
10.1.1.1:10.1.1.2
local
ms-dns 127.0.0.1
noauth
debug

3。把treo和你的ubuntu进行蓝牙配对,并执行以下命令:这个是关键,以前不成功就是少了这个!!!!
$ sudo dund -s call treo

4。剩下就是在treo上的动作:创建连接,创建网络,配置hotsync这并部分很多地方都有介绍。


最后由 lee_yudong 编辑于 2009-05-15 23:24,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: [分享]刚搞定了treo用蓝牙跟evolution (gpilot/Gnome-pilot)同步的问题....
帖子发表于 : 2009-05-15 23:01 

注册: 2008-12-03 16:46
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
treo上面Hotsync设置
1。创建连接
>Prefs
>Connection > New
>Enter Name, Connect to PC, via bt
>Select device, select your pc, ok
>Click details, set speed to 115,200 , leave flow ctl at automatic
>Ok, Ok

2。创建网络
>Prefs
>Network
>Menu > Service > New
>Enter a Name
>Enter Connection, don't set username or password
>Select details > Idle timeout to 3 mins.
>Ok
>Connect

Hotsync设置
>Hotsync
>Options > Modem sync prefs > Network
>Options > LANSync Prefs > LANSync
>Options > Primary PC Setup screen
>Enter pc address (10.1.1.1)
>Leave primary pc name blank
>Options > Connection setup screen
>select bt connection that was created
>Select modem
>Click on select service, choose the service you made

另外注意:在ubuntu的“系统”->“PalmOS设备”里面选择网络同步方式,如果同步时没有反应,还可以先在终端里运行gpilotd,不要关闭窗口再试同步


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [分享]刚搞定了treo用蓝牙跟evolution (gpilot/Gnome-pilot)同步的问题....
帖子发表于 : 2009-05-19 23:33 

注册: 2006-03-19 10:57
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
超级感谢,我还在用USB同步treo呢。顺便问一下,你是treo 650还是680,680的nvflash貌似不支持从linux安装文件


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [分享]刚搞定了treo用蓝牙跟evolution (gpilot/Gnome-pilot)同步的问题....
帖子发表于 : 2009-05-22 13:51 

注册: 2008-12-03 16:46
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
danosong 写道:
超级感谢,我还在用USB同步treo呢。顺便问一下,你是treo 650还是680,680的nvflash貌似不支持从linux安装文件


总算看到有人回复了,我还以为用ubuntu的没有用treo的呢......我是用treo650
我主要是同步通讯录等个人信息,这个蓝牙同步比windows里面快得的多呢


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [分享]刚搞定了treo用蓝牙跟evolution (gpilot/Gnome-pilot)同步的问题....
帖子发表于 : 2009-06-09 21:52 

注册: 2006-06-25 16:31
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
刚入二手680的穷人打酱油路过


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [分享]刚搞定了treo用蓝牙跟evolution (gpilot/Gnome-pilot)同步的问题....
帖子发表于 : 2009-06-18 22:23 

注册: 2009-06-18 22:17
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
看了楼主的文章,刚刚跟我的centro同步成功,谢谢楼主。

不过有一个问题,evolution里面的联系人字段跟palm的不一致,我很多联系人都是用“主要”这个字段的电话,同步进去evolution后就没有这个电话了,这个该怎么解决?同步到jpilot就没这个问题。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [分享]刚搞定了treo用蓝牙跟evolution (gpilot/Gnome-pilot)同步的问题....
帖子发表于 : 2009-08-19 15:44 

注册: 2008-12-03 16:46
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
我的电话就是商务和手机比较多,没有LS的问题...


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译