当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu在工人舍Kohjinsha SA1的安装和使用
帖子发表于 : 2009-07-17 10:40 

注册: 2006-03-18 12:06
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
去年在香港买了一台工人舍SA1F0(黑) UMPC,AMD Geode LX800/ 512M/ 40G/ 7英寸触控LED旋转屏/ wifi /蓝牙,系统自带的XP跑得还算流畅,无奈CPU确实太慢,放avi尚可,放rm/rmvb就一卡卡的,所以尝试装ubuntu看能不能最大挖掘它的潜力。

ubuntu 8.10/9.04 在这部机子上最大的问题就是显卡/显示屏驱动。ubuntu能识别它的显卡,默认用xserver-xorg-video-geode这个驱动,无论是livecd还是安装系统后,启动Xwindow都会黑屏,但可以听到登陆界面那几下打鼓的声音。这时如果插一个外接显示器到VGA口,就可以看到图形界面了,说明是显示屏不能正确启动的问题。在网上找到有人在 ubuntu 7.10 下,用 xserver-xorg-video-amd (后来改名为xserver-xorg-video-geode) 驱动并修改xorg.conf 的 Modeline 为 800x480 就可以驱动显示屏,但此法在 8.10/9.04 下都行不通,不知道为什么,可能高版本的geode驱动去掉了某些硬件支持吧。

后来发现,在xorg.conf里面强制使用vesa驱动就可以正常启动显示屏了,非常高兴,而且用vesa和geode跑glxgears都是30FPS(可怜啊~~~)。声卡网卡触摸板音量调节都没问题,有一个版本的ubuntu还可以正常使用触摸屏(好象是lpia版),但wifi只能在9.10里才能驱动。遗憾的是,即使在Xwindow里面播放rmvb还是卡卡的,还没达到我的终极目标。

无意中想起mplayer可以用framebuffer在字符界面下播放视频,于是继续探索。奇怪的是,如果我在grub启动时加入vga=314的话,启动后就看不到字符界面显示了,解决办法是先随便写一个无效的数值,例如vga=111,启动时它会提示无效并要你重新输入,这个时候再输入314就可以正常启动framebuffer了。进入字符界面,再跑mplayer:
sudo mplayer -vo fbdev xxx.rmvb (如果不加sudo会提示没权限打开fbdev,当然网上可以搜索到其他解决方法)
就可以流畅播放一般的rmvb了,linux 果然强大,哇哈哈~~~


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu在工人舍Kohjinsha SA1的安装和使用
帖子发表于 : 2009-07-17 18:37 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
vga=ask

可以弹出选择列表,选择你要的。


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu在工人舍Kohjinsha SA1的安装和使用
帖子发表于 : 2009-12-05 11:02 

注册: 2009-12-05 10:33
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也是这款机型,可以帮帮我么


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu在工人舍Kohjinsha SA1的安装和使用
帖子发表于 : 2010-06-19 22:24 

注册: 2009-08-29 21:58
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
楼主能不能把xorg.conf拿出来共享一下,我GUI出来了,但是800X480的分辨率出不来啊 ,我看了好多modeline的文章还是不行~


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu在工人舍Kohjinsha SA1的安装和使用
帖子发表于 : 2010-06-24 10:03 
头像

注册: 2007-04-14 11:17
帖子: 1035
送出感谢: 0 次
接收感谢: 2
工人舍Kohjinsha SA1 == HOW MUCH ?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu在工人舍Kohjinsha SA1的安装和使用
帖子发表于 : 2010-10-14 0:55 
头像

注册: 2010-10-08 23:22
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
同样的问题了~~我装的是10.04,还只能用文字界面安装。用了geode驱动后就黑屏~~而用了vesa驱动虽然能显示,但是不能设置800x480的分辨率

还有声卡、无线网卡的问题,都没不能自动设置好~~

但是机器二手买回来很便宜,能够把问题都解决好的话就超值了

PS. 尝试编译内核,大概花了12个小时才能完成


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu在工人舍Kohjinsha SA1的安装和使用
帖子发表于 : 2010-11-05 12:41 
头像

注册: 2010-10-08 23:22
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
xiaoxiaflash 写道:
楼主能不能把xorg.conf拿出来共享一下,我GUI出来了,但是800X480的分辨率出不来啊 ,我看了好多modeline的文章还是不行~



参考以下帖子:http://forum.ubuntu.org.cn/viewtopic.php?f=126&t=298473


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译