当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : txt乱码啊,怎么解决
帖子发表于 : 2010-08-12 17:19 

注册: 2010-08-12 16:59
帖子: 61
送出感谢: 0 次
接收感谢: 0 次
系统版本是10.4,64位的,打开txt文档全是乱码


页首
 用户资料  
 
2 楼 
 文章标题 : Re: txt乱码啊,怎么解决
帖子发表于 : 2010-08-12 20:35 
头像

注册: 2009-01-24 23:07
帖子: 1230
送出感谢: 0 次
接收感谢: 0 次
换个编码看看~


_________________
学生仅此而已……


页首
 用户资料  
 
3 楼 
 文章标题 : Re: txt乱码啊,怎么解决
帖子发表于 : 2010-08-12 21:25 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
WINDOWS下保存的TXT中文乱码:

在终端打:
gconf-editor //调出gconf-edit
然后依次点开:
apps->gedit-2->preferences->encodings
双击encodings中的auto-detected
在弹开的对话框中加入
GB18030,GBK,GB2312
再将GB18030,GB2312移到上面
p.s:一定要让UTF-8保持在最上面,不然的话会出现gedit不能打开空文件(一打开就关闭)的情况
http://www.ubuntusoft.com/ubuntu-garble ... flash-rar/


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
4 楼 
 文章标题 : Re: txt乱码啊,怎么解决
帖子发表于 : 2010-08-12 21:26 
头像

注册: 2008-03-25 15:49
帖子: 25877
地址: 谁知道?
送出感谢: 8
接收感谢: 10
为啥我的都没这现象


页首
 用户资料  
 
5 楼 
 文章标题 : Re: txt乱码啊,怎么解决
帖子发表于 : 2010-08-13 0:44 
头像

注册: 2007-11-25 13:29
帖子: 7159
地址: 新疆博乐
系统: 14.04/16.04/Fedroa22
送出感谢: 35
接收感谢: 98
在编辑器里用“打开”命令,在打开对话框右下角的编码里找gbk,没有就添加


_________________
===新手请看===
Ubuntu 安装 | Ubuntu12.04/14.04/16.04 桌面操作指南
··Ubuntu16.04 安装图文教程(超简单)
····有时间就静下心来——折腾:)


页首
 用户资料  
 
6 楼 
 文章标题 : Re: txt乱码啊,怎么解决
帖子发表于 : 2010-08-13 9:27 

注册: 2010-08-12 16:59
帖子: 61
送出感谢: 0 次
接收感谢: 0 次
阿依帝 写道:
WINDOWS下保存的TXT中文乱码:

在终端打:
gconf-editor //调出gconf-edit
然后依次点开:
apps->gedit-2->preferences->encodings
双击encodings中的auto-detected
在弹开的对话框中加入
GB18030,GBK,GB2312
再将GB18030,GB2312移到上面
p.s:一定要让UTF-8保持在最上面,不然的话会出现gedit不能打开空文件(一打开就关闭)的情况
http://www.ubuntusoft.com/ubuntu-garble ... flash-rar/



哎呀妈呀,太崇拜了,你太厉害了 :em11


页首
 用户资料  
 
7 楼 
 文章标题 : Re: txt乱码啊,怎么解决
帖子发表于 : 2010-10-16 14:54 
头像

注册: 2008-10-30 10:40
帖子: 406
送出感谢: 0 次
接收感谢: 5
:em01


_________________
Namas Amitabha
南无阿弥陀佛
一切有为法,如梦幻泡影,
如露亦如电,应作如是观。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: txt乱码啊,怎么解决
帖子发表于 : 2010-10-22 19:37 

注册: 2010-10-16 21:54
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
meguxing 写道:
阿依帝 写道:
WINDOWS下保存的TXT中文乱码:

在终端打:
gconf-editor //调出gconf-edit
然后依次点开:
apps->gedit-2->preferences->encodings
双击encodings中的auto-detected
在弹开的对话框中加入
GB18030,GBK,GB2312
再将GB18030,GB2312移到上面
p.s:一定要让UTF-8保持在最上面,不然的话会出现gedit不能打开空文件(一打开就关闭)的情况
http://www.ubuntusoft.com/ubuntu-garble ... flash-rar/



哎呀妈呀,太崇拜了,你太厉害了 :em11


The Kid 我也是很崇拜阿!!! :em11 :em11


页首
 用户资料  
 
9 楼 
 文章标题 : Re: txt乱码啊,怎么解决
帖子发表于 : 2012-06-21 17:07 

注册: 2012-03-03 20:13
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
阿依帝 写道:
WINDOWS下保存的TXT中文乱码:

在终端打:
gconf-editor //调出gconf-edit
然后依次点开:
apps->gedit-2->preferences->encodings
双击encodings中的auto-detected
在弹开的对话框中加入
GB18030,GBK,GB2312
再将GB18030,GB2312移到上面
p.s:一定要让UTF-8保持在最上面,不然的话会出现gedit不能打开空文件(一打开就关闭)的情况
http://www.ubuntusoft.com/ubuntu-garble ... flash-rar/



要是preferences下没有encodings该怎么办?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译