当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 10.4.1 登录后,触摸板不能用?!
帖子发表于 : 2010-08-26 23:41 
头像

注册: 2009-09-22 14:26
帖子: 52
送出感谢: 0 次
接收感谢: 1
如题故障。
1、sudo cat /dev/input/mouse2时触摸板输入一些内容,是乱码。
2、登录日志
(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event10)
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
compiled for 1.7.6, module version = 1.2.2
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 7.0
(II) Synaptics touchpad driver version 1.2.2
(**) Option "Device" "/dev/input/event10"
(II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(II) SynPS/2 Synaptics TouchPad: buttons: left right middle
(--) SynPS/2 Synaptics TouchPad: touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 0
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
(--) SynPS/2 Synaptics TouchPad: touchpad found
(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse2)
(**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
(II) Synaptics touchpad driver version 1.2.2
SynPS/2 Synaptics TouchPad no synaptics event device found
(**) Option "Device" "/dev/input/mouse2"
Query no Synaptics: 6003C8
(--) SynPS/2 Synaptics TouchPad: no supported touchpad found
(EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"
(II) UnloadModule: "synaptics"
(II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/event4)
(**) Macintosh mouse button emulation: Applying InputClass "evdev pointer catchall"
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event4"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found relative axes
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(II) Macintosh mouse button emulation: initialized for relative axes.
(II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/mouse0)
(II) No input driver/identifier specified (ignoring)

3、xorg.conf

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
EndSection

4、安装gsynaptics,在首选项里设置也没有用。。。

求达人指点迷津。 :em06


_________________
日出而作,日落而栖。境界!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 10.4.1 登录后,触摸板不能用?!
帖子发表于 : 2010-08-27 12:36 
头像

注册: 2009-09-22 14:26
帖子: 52
送出感谢: 0 次
接收感谢: 1
自己顶一下!
顺便报告一下各位:新增加的用户登录后触摸板可以用! :em01


_________________
日出而作,日落而栖。境界!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 10.4.1 登录后,触摸板不能用?!
帖子发表于 : 2010-09-03 23:43 

注册: 2010-03-07 22:17
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
遇上同样的问题,google了一圈之后终于解决:
代码:
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps


经过这两步之后我的触摸板就正常了。接下来是创建文件:

代码:
sudo gedit  /etc/modprobe.d/options


在其中写入如下一行:
options psmouse proto=imps

就ok.
(参见http://alucinogenado.wordpress.com/2009/04/05/elantech-etps2-touchpad-and-xorg-160/)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 10.4.1 登录后,触摸板不能用?!
帖子发表于 : 2010-09-09 9:36 

注册: 2010-04-02 9:49
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我也有相同的问题,楼上的方法我也google到了,能用但是不舒服

因为用了这个配置以后触摸板就不支持多点触摸不能用双指滚动了,只能识别右侧的滚动,也不支持横向滚动了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 10.4.1 登录后,触摸板不能用?!
帖子发表于 : 2013-04-15 18:21 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
我的ACER TravelMate x483用着个方法弄好了,谢谢!!!
后来重新启动又出现同样的问题了,郁闷ing
我发现,未登录前是可以正常使用的,这是为什么呢?

fox5945 写道:
遇上同样的问题,google了一圈之后终于解决:
代码:
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps


经过这两步之后我的触摸板就正常了。接下来是创建文件:

代码:
sudo gedit  /etc/modprobe.d/options


在其中写入如下一行:
options psmouse proto=imps

就ok.
(参见http://alucinogenado.wordpress.com/2009/04/05/elantech-etps2-touchpad-and-xorg-160/)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译