经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

笔记本/超便携移动PC软硬件相关支持,包括硬件、安装和驱动等
altman0habb
帖子: 38
注册时间: 2008-10-19 11:35
送出感谢: 0
接收感谢: 0
联系:

经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#1

帖子 altman0habb » 2011-01-02 19:16

网上有太多的方法,均无法完美解决
在笔记本电脑上打字,总是不小心碰到触摸板,导致光标乱飞,这种情况如何解决呢?以下是禁用触摸板的方法。
sudo gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled false
如果要开启,只要把false 改成true就行了
sudo gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled true
caucyclist
帖子: 24
注册时间: 2007-02-04 0:40
送出感谢: 0
接收感谢: 0

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#2

帖子 caucyclist » 2011-01-03 1:51

失败了,运行命令,触摸板还是启动中 。。
头像
yoyo837
帖子: 79
注册时间: 2009-05-02 12:11
送出感谢: 0
接收感谢: 0

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#3

帖子 yoyo837 » 2011-01-03 21:58

thinkpad e50 安装touchpad-indicator设置一下可行
头像
yoursaf
帖子: 233
注册时间: 2010-04-01 0:58
送出感谢: 0
接收感谢: 3 次

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#4

帖子 yoursaf » 2011-01-04 23:24

给你个最简单的禁用触摸板的命令:
sudo rmmod psmouse 这个是禁用的
sudo modprobe psmouse 这个是启用的。
我以前在用9.10的时候,把这两个命令做了alias,(大宝)挺好的,我们一直在用它。
不过现在升级到10.10以后这东西用不着了,10.10支持我本上的触摸板开关。
我用的是Dell 灵越 1464-138

代码: 全选

if ( 信春哥=true )
  {
    得永生;
    不挂科;
    赚大钱;
    不怕磕;
  }
 else
   {
     去死吧;
   }
e21
帖子: 641
注册时间: 2008-01-24 9:47
送出感谢: 0
接收感谢: 4 次

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#5

帖子 e21 » 2011-01-05 3:09

我的笔记本触摸板上有个开关,正常打开/关闭是没有问题的。
当我在windows关闭了,再转到ubuntu,开关就对应不上了,按一下系统软件提示关闭而硬件指示灯打开,再按一下软件打开而硬件关闭。这时该怎么办?
altman0habb
帖子: 38
注册时间: 2008-10-19 11:35
送出感谢: 0
接收感谢: 0
联系:

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#6

帖子 altman0habb » 2011-02-27 20:41

我的电脑是DELL1440的,可以用这个命令啊
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#8

帖子 eexpress » 2011-02-28 8:37

都是奇怪的方法。
都没人说synclient
● 鸣学
xep007
帖子: 870
注册时间: 2006-01-03 20:44
送出感谢: 0
接收感谢: 6 次

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#9

帖子 xep007 » 2011-02-28 10:43

从来只用触摸板,不用鼠标的走过。
LET19890305
帖子: 1
注册时间: 2010-12-18 13:26
送出感谢: 0
接收感谢: 0

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#10

帖子 LET19890305 » 2011-02-28 20:10

yoursaf 写了:给你个最简单的禁用触摸板的命令:
sudo rmmod psmouse 这个是禁用的
sudo modprobe psmouse 这个是启用的。
我以前在用9.10的时候,把这两个命令做了alias,(大宝)挺好的,我们一直在用它。
不过现在升级到10.10以后这东西用不着了,10.10支持我本上的触摸板开关。
我用的是Dell 灵越 1464-138


这个我看行
altman0habb
帖子: 38
注册时间: 2008-10-19 11:35
送出感谢: 0
接收感谢: 0
联系:

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#11

帖子 altman0habb » 2011-04-09 0:41

对不起了,各位,的确是没有用的,下次不乱发了
头像
spectater
帖子: 665
注册时间: 2008-02-03 18:53
送出感谢: 0
接收感谢: 1 次

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#12

帖子 spectater » 2011-04-09 7:13

带sudo 的办法, 都不是好办法, 神在8楼的办法最好:

代码: 全选

synclient TouchpadOff=1

代码: 全选

 synclient TouchpadOff=0


还有一个:

代码: 全选

xinput list | grep -i touchpad
用以上命令获取设备id号, 我的为13

代码: 全选

xinput set-prop 13  "Device Enabled" 0

代码: 全选

xinput set-prop 13  "Device Enabled" 1

图形界面的办法是安装Touchpad-Indicator


还有一个办法是加一个规则脚本, 插上usb鼠标时自动关闭触摸板. 此方法在此略去.
这些用户感谢了作者 spectater 于这个帖子:
bsx1990 (2011-09-18 23:01)
评价: 3.7%
头像
adam8157
帖子: 2794
注册时间: 2009-03-05 16:31
送出感谢: 0
接收感谢: 8 次
联系:

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#13

帖子 adam8157 » 2011-04-09 10:35

代码: 全选

#touchpad
synclient TapButton1=1
syndaemon -i 1 -k -d &
faguosate
帖子: 54
注册时间: 2010-12-08 17:35
送出感谢: 0
接收感谢: 2 次

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#14

帖子 faguosate » 2011-04-14 22:01

eexpress 写了:都是奇怪的方法。
都没人说synclient
有些笔记本中,触摸板用的是psmouse的驱动,而不是synaptics的驱动,
如果用synclient,就会出现这样的错误:Couldn't find synaptics properties. No synaptics driver loaded?

例如我的华硕笔记本中,触摸板被识别为:
↳ ImPS/2 Logitech Wheel Mouse id=12 [slave pointer (2)]

这种情况下,用

代码: 全选

sudo modprobe psmouse
启用,

代码: 全选

sudo modprobe -r psmouse
禁用,

或者不用sudo,改用xinput

代码: 全选

xinput set-button-map "ImPS/2 Logitech Wheel Mouse" 0 0 0 0 0 0 0
feng8899
帖子: 700
注册时间: 2008-10-31 3:18
送出感谢: 8 次
接收感谢: 2 次
联系:

Re: 经过多次尝试,终于找到完全解决笔记本触摸板禁用与开启的问题

#15

帖子 feng8899 » 2011-04-16 13:10

这个给力http://forum.ubuntu.org.cn/viewtopic.php?f=95&t=317028
Ubuntu 桌面培训
Duo T6400 GeForce 9300MGS 4G win7 Lubuntu16.04 64bit奔跑中
P3 667 512M GeForce MX200 Lbuntu10.04
从零开始学游泳 萨顶顶
回复

回到 “笔记本、UMPC支持”