当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-03-31 20:48 

注册: 2007-11-03 9:19
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
新买的笔记本,装上ubuntu 10.10 notebook ,一切顺利,进入Gnome桌面,装openoffice.org3.3,没问题,上网看了下,有新内核很强大,装上 2.6.38(deb包),看了下显卡驱动,官方有,下载(11.2),然后就开始杯具了,看着网上的教程,打补丁,生成DEB包,然后DPKG,没问题,然后 aticonfig ,提示找不到驱动,管理器也提示找不到驱动,重启还是一样,删了,再来一遍,还是一样,然后在英文网站发一个11.3的驱动,按照那个贴子(英文,看着累)装了一遍,一切正常,就是最后一步找不到驱动

代码:
root@shaniu-HP-G42-Notebook-PC:/home/shaniu/下载# sudo aticonfig --initial
aticonfig: No supported adapters detected


贴止安装过程:
1. 从AMD官网下载ATI for Linux的11.2驱动

2. 下载2.6.38的显卡补丁,即catalyst-generator,解压,我们需要里面的2.6.38.patch
#给驱动加上执行权限
chmod +x ./ati-driver-installer-11-2-x86.x86_64.run
#把驱动解开
./ati-driver-installer-11-2-x86.x86_64.run --extract fglrx-install.11-2/
#解压补丁
tar xvf catalyst-generator.tar.gz
#把补丁复制到驱动的目录
cp catalyst-generator/2.6.38_console.patch fglrx-install.11-2/
#切换到驱动目录
cd fglrx-install.11-2
#给显卡驱动打上2.6.38补丁
patch -p1 < 2.6.38_console.patch
3. 生成显卡驱动安装包,针对操作系统Ubuntu 10.10(maverick)

./ati-installer.sh 8.821 --buildpkg Ubuntu/maverick
4. 切记先卸载现有的fglrx,不然会出问题-,-

sudo aptitude purge fglrx fglrx-dev fglrx-amdcccle fglrx-modaliases
5. 在上一层目录4个安装包,分别是fglrx,fglrx-amdcccle,fglrx-dev,fglrx-modaliases,


sudo dpkg -i ./fglrx*.deb
6. 重新生成一下xorg.conf配置

sudo aticonfig --initial


有哪位大侠ATI 6370安装成功的么?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-03-31 21:05 

注册: 2011-03-29 10:39
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我也是啊 装不上


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-03-31 21:22 

注册: 2007-11-03 9:19
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
qq545854863 写道:
我也是啊 装不上


哎,怎么回事呢,开源驱动搞死不更新,官方驱动装不上,还让不让人活了啊


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-03-31 21:35 

注册: 2007-11-03 9:19
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
会不会是下面那几行警告有关????

代码:
正在解压缩 fglrx (从 fglrx_8.831-0ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 fglrx-amdcccle。
正在解压缩 fglrx-amdcccle (从 fglrx-amdcccle_8.831-0ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 fglrx-dev。
正在解压缩 fglrx-dev (从 fglrx-dev_8.831-0ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 fglrx-modaliases。
正在解压缩 fglrx-modaliases (从 fglrx-modaliases_8.831-0ubuntu1_i386.deb) ...
正在设置 fglrx (2:8.831-0ubuntu1) ...
update-alternatives: 使用 /usr/lib/fglrx/ld.so.conf 来提供 /etc/ld.so.conf.d/GL.conf (gl_conf),于 自动模式 中。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalcl.so 因为所关联文件 /usr/lib32/fglrx/libaticalcl.so (位于链接组 gl_conf)不存在。
update-alternatives: 警告: 跳过创建 /usr/lib32/libaticalrt.so 因为所关联文件 /usr/lib32/fglrx/libaticalrt.so (位于链接组 gl_conf)不存在。
update-initramfs: deferring update (trigger activated)
Loading new fglrx-8.831 DKMS files...
Building only for 2.6.38-020638-generic
Building for architecture i686
Building initial module for 2.6.38-020638-generic
Done.

fglrx.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/2.6.38-020638-generic/updates/dkms/

depmod....


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-03-31 22:01 
头像

注册: 2008-12-06 10:38
帖子: 4566
送出感谢: 23
接收感谢: 31
直接双击安装好了嘛还生成deb干吗那套麻烦


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-03-31 22:17 

注册: 2007-11-03 9:19
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
灰色小狼 写道:
直接双击安装好了嘛还生成deb干吗那套麻烦



那样也是不行的,我都试过了,再说了,ATI的驱动好像都是生成DEB包安装的吧,没见谁直接运行 sudo ./ati******.run 这个的啊


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-04-01 15:04 

注册: 2007-11-03 9:19
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
今天实在是没脾气了,一气之下直接全新安装11.04了,哎,你还别说,显卡驱动直接都不用自己装,系统直接搞定,不过显存大小好像不对。

代码:

shaniu@shaniu-HP-G42-Notebook-PC:~$ lspci -v


01:00.0 VGA compatible controller: ATI Technologies Inc Robson CE [AMD Radeon HD 6300 Series] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device 1426
   Flags: bus master, fast devsel, latency 0, IRQ 43
   Memory at c0000000 (64-bit, prefetchable) [size=256M]
   Memory at d4000000 (64-bit, non-prefetchable) [size=128K]
   I/O ports at 4000 [size=256]
   Expansion ROM at d4040000 [disabled] [size=128K]
   Capabilities: <access denied>
   Kernel driver in use: radeon
   Kernel modules: radeon




页首
 用户资料  
 
8 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-04-02 11:17 

注册: 2007-01-08 10:48
帖子: 426
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
换11.04版吧。我也是A卡6370,在装11.04之前我也遇到了LZ相同的问题,不过当时我的解决办法是装系统自带的驱动,虽然可以用但屏幕左下角有一个很讨厌的AMD的标。装11.04版后也是安装系统自带的驱动,还不错。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-04-02 21:53 

注册: 2010-06-03 22:51
帖子: 452
送出感谢: 1
接收感谢: 0 次
我在生成显卡安装包那一步失败了 看来得回来原来的旧核了


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-04-03 0:32 
头像

注册: 2007-08-03 19:59
帖子: 211
送出感谢: 1
接收感谢: 0 次
再等下个版本的新内核吧


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-04-14 17:06 

注册: 2011-04-14 12:36
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我也是ATI HD 6370 mobility, Y的,死活3D不能完全全驱动起来。
貌似官方在吹大牛:)


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-04-14 21:12 

注册: 2010-12-08 17:35
帖子: 54
送出感谢: 0 次
接收感谢: 2
其实是可以的,开源的和闭源的都可以。
我的是ATI 6470 M,都能用,
闭源的话直接 sudo sh ati-driver-installer-11-3-x86.x86_64.run
不要用ati config,但是需要自己编辑一个xorg.conf,里面只需要有一项,为xorg 指定fglrx驱动,

开源的话需要2.6.38或2.6.39 内核,自己编译内核,为内核指定下面三个文件:/lib/firmware/radeon/CAICOS_mc.bin
/lib/firmware/radeon/CAICOS_me.bin /lib/firmware/radeon/CAICOS_pfp.bin,然后更新xf86-dirvers-ati,再把xorg-drivers xorg-server升级到最新,一切OK,KMS也没问题了。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-10-11 18:44 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
sudo sh ./ati.run


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 迷茫了,ati 6370显卡驱动就是装不上?
帖子发表于 : 2011-12-20 1:02 

注册: 2009-04-01 10:52
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
先删除老驱动
删的系统信息,图形,里头最好是空的
然后直接无脑双击run
闭源,能认出来HD6300.
开源没试


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译