当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 45 篇帖子 ]  前往页数 1, 2, 3  下一页
作者 内容
1 楼 
 文章标题 : [分享]联想天逸F41笔记本声卡驱动完美解决!
帖子发表于 : 2007-10-21 16:37 
头像

注册: 2006-04-29 1:43
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
我的声卡是 Azalia CODEC,识别出来是 Realtek ALC262。
更新
ALSA驱动4月3日的更新已经加入了联想天逸F41笔记本声卡的驱动支持。
可以去ftp://ftp.suse.com/pub/projects/alsa/snapshot/driver/下载 最新的驱动包来安装。
安装步骤参考下面的。
安装之后修改/etc/modprobe.d/alsa-base,加入或者改成下面这样。
代码:
#options snd-hda-intel probe_mask=1
options snd-hda-intel index=0
options snd-hda-intel model=lenovo-3000


改完保存,重启,耳机也能顺利发声了。
ubuntu 8.04可能编译安装了还不能顺利顺利发生。
你需要把 /lib/modules/2.6.24-16-generic/kernel/sound/ 下的两个目录(acore,pci)复制覆盖到 /lib/modules/2.6.24-16-generic/ubuntu/sound/alsa-driver/ 。
遇到其他问题请参考下文,或者跟帖。

注:说完美其实也并不完美,发现不能录音,不知道是我设置的问题还是驱动的问题。但至少能正常的像笔记本那样发声了。

以下内容是针对1.0.15的驱动写的,目前最新版是1.0.16 。要让F41的耳机发声,需要最新的,可在ftp://ftp.suse.com/pub/projects/alsa/snapshot/ 找到最新的开发版本。
<--------------------------------分割线------------------------------------>
首先,我参考了fifawqm的文章,先表示感谢。
http://forum.ubuntu.org.cn/viewtopic.php?t=50865
根据这里的文章,编译安装了alsa的驱动。
https://help.ubuntu.com/community/HdaIntelSoundHowto

首先是下载需要的驱动源文件
ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.15.tar.bz2
ftp://ftp.alsa-project.org/pub/lib/alsa-lib-1.0.15.tar.bz2
ftp://ftp.alsa-project.org/pub/utils/alsa-utils-1.0.15.tar.bz2

进入到压缩包所在的目录,解压这几个包
代码:
tar xjf ×××.tar.bz2


编译安装 alsa-driver
代码:
cd alsa-driver-1.0.15
sudo ./configure --with-cards=hda-intel
sudo make
sudo make install


编译安装alsa-lib
代码:
cd ../alsa-lib-1.0.15
sudo ./configure
sudo make
sudo make install


编译安装 alsa-utils
代码:
cd ../alsa-utils-1.0.15
sudo ./configure
sudo make
sudo make install


完成后先不要重启系统。
然后修改/etc/modprobe.d/alsa-base
代码:
sudo gedit /etc/modprobe.d/alsa-base

向文件中适当位置加入如下三行内容
代码:
#options snd-hda-intel probe_mask=1
options snd-hda-intel index=0
options snd-hda-intel model=fujitsu


保存,重启。
如果重启后还是没有声音,则查看dmesg 的输出信息,
如果发现出现这样的信息"azx_get_response timeout", 那么请将前面的所加三行内容中第一行取消注释。
到这一步后应该都是能够有声音了的,我自己重装过两遍,两种情况都遇到过。

如果遇到 /etc/modprobe.d/alsa-base 这个文件不存在,那么你可能需要
代码:
sudo apt-get install alsa-base


如果还是没有效果,那么我也不知道怎么办了,不过大家可以讨论讨论。


_________________
http://forum.ubuntu.org.cn/viewtopic.php?t=82672
联想天逸F41声卡完美解决


最后由 reshine 编辑于 2008-05-11 9:25,总共编辑了 13 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-21 17:45 

注册: 2007-01-10 23:56
帖子: 144
送出感谢: 0 次
接收感谢: 0 次
你这样子能让内置扬声器发出声音来吗?谢谢


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-21 22:10 
头像

注册: 2006-04-29 1:43
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
恩 扬声器能发出正常的声音,耳机不行


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-22 18:49 

注册: 2007-07-30 4:21
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
为什么我照做反倒找不到声卡驱动了?音量那直接是个叉了。难道F41还有几种版本。。。。。。

刚又试了一下,最后那两句不加也识别不了,就是说装alsa1.0.15反倒认不出来了,原本1.0.14还至少能认出来。

想让机子发个声真是难啊。。。。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-22 21:45 
头像

注册: 2006-04-29 1:43
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
…… 抱歉,不知道那是什么原因。 :oops:


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-23 13:09 
头像

注册: 2006-04-29 1:43
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
今天凌晨又试了下,把fujitsu改掉后我再改回来我的声卡也没声音了。
看了篇文章最下面讲的,我的“dmesg”确实也有"azx_get_response timeout" 信息出现。
https://help.ubuntu.com/community/HdaIntelSoundHowto

于是又在/etc/modprobe.d/alsa-base 文件里加上了一行。
代码:
options snd-hda-intel probe_mask=1


这样以后我的声卡又能出声了,耳机依然不行。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-20 19:17 

注册: 2007-12-20 14:20
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我的F41总算有声音了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-02-04 19:37 

注册: 2007-04-05 21:30
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
请问下编译alsa的时候要不要把原先的alsa驱动删掉??
我没删编译了下,但是还是没声音!!!!
我的也是联想F41的


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-02-29 15:16 
头像

注册: 2006-04-29 1:43
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
要删的。在新立得里卸载就可以了,但是记得要留下一个 base的。后面的配置文件就是这个包里咩的。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-02-29 20:27 
头像

注册: 2007-11-28 14:56
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
难不成。HD的声卡都发不出声音来??在本本里。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-03-02 14:14 
头像

注册: 2006-04-29 1:43
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
可以的啊,只不多很多HD的声卡都经过制造商的定制,ALSA驱动起来就有困难了。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-04-24 15:47 
头像

注册: 2006-04-29 1:43
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
有必要顶起了


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-04-25 11:57 

注册: 2007-10-04 10:07
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
按你的最新方法装完后,为什么关机时会有很大的“卡”一声?


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-04-25 13:07 
头像

注册: 2006-04-29 1:43
帖子: 91
送出感谢: 0 次
接收感谢: 0 次
这个我也不是很清楚,我有时候关机也有那个爆音,大部分时间没有。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-05-01 3:51 

注册: 2008-04-29 15:02
帖子: 122
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
菜鸟求助:

我下载了你的驱动包,如何安装?能教教我吗?


_________________
墙上芦苇头重脚轻根基浅,山间竹笋嘴尘皮厚腹中空


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 45 篇帖子 ]  前往页数 1, 2, 3  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译