[问题]为什么我的笔记本装了ubuntu 7.10,网卡无法正常工作?

笔记本/超便携移动PC软硬件相关支持,包括硬件、安装和驱动等
回复
iericzhu
帖子: 6
注册时间: 2007-10-27 20:50
送出感谢: 0
接收感谢: 0

[问题]为什么我的笔记本装了ubuntu 7.10,网卡无法正常工作?

#1

帖子 iericzhu » 2007-11-10 21:08

我的笔记本是华硕A3Vc的,网卡是8139,可是装完Ubuntu 7.10后,网卡起不来,连网卡的路由器的端口显示没有连接。
但是在ubuntu里面网络管理里面都是显示UP,可就是不通。
我还有Intel的2200B无线网卡,同样也是无法连接到无线路由器上。

网络管理里面已经都能识别出是什么网卡了,所以驱动应该是没什么问题的。



请教各位大虾这到底是怎么回事?
PS:已经确认网卡都是正常的。
iericzhu
帖子: 6
注册时间: 2007-10-27 20:50
送出感谢: 0
接收感谢: 0

#2

帖子 iericzhu » 2007-11-10 21:23

刚才浏览了一下,发现有很多人的问题跟我的一样。
就是Realtek 8139网卡在windows里面正常使用,在Ubuntu里能够识别,但是插上网线就是不亮!

请版主关注一下这个问题啊!
steventree
帖子: 133
注册时间: 2007-11-05 21:58
来自: CH
送出感谢: 0
接收感谢: 0

#3

帖子 steventree » 2007-11-12 21:31

双网卡是吧。
如果确定IP没问题,DHCP已经识别到了分配给你的IP的话。
查一下是否是DNS的问题,我的是这样解决的,
需要在DNS里面把除路由器外的DNS全部去掉,再开一次浏览器就好了。
如果有路由器,可以在路由器端看一下链接是否有问题。
多一点信息会比较容易帮你。
neixian
帖子: 23
注册时间: 2007-12-14 8:51
送出感谢: 0
接收感谢: 0

#4

帖子 neixian » 2007-12-16 18:21

我也是一样。网卡模块已经加载,为eth1,但是就是灯不亮,dmesg 显示link down。
flyex
帖子: 3
注册时间: 2007-09-20 21:54
送出感谢: 0
接收感谢: 0

#5

帖子 flyex » 2007-12-18 14:32

同样问题,求解决
搞了两天,编了两种内核 都没搞定,
不行的话只有买个外置的网卡了
dmesg输出为

[ 31.896715] [drm] Initialized i915 1.6.0 20060119 on minor 0
[ 32.532824] NET: Registered protocol family 10
[ 32.532905] lo: Disabled Privacy Extensions
[ 33.844851] NETDEV WATCHDOG: eth0: transmit timed out
[ 34.338039] eth0: no IPv6 routers present
[ 34.425558] eth0: Transmit timeout, status 0d 0000 c07f media d0.
[ 34.425564] eth0: Tx queue start entry 4 dirty entry 0.
[ 34.425568] eth0: Tx descriptor 0 is 00082156. (queue head)
[ 34.425571] eth0: Tx descriptor 1 is 00082156.
[ 34.425574] eth0: Tx descriptor 2 is 0008205a.
[ 34.425577] eth0: Tx descriptor 3 is 0008204e.
[ 34.425592] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[ 39.816072] NETDEV WATCHDOG: eth0: transmit timed out
[ 40.273356] eth0: Transmit timeout, status 0d 0000 c07f media d0.
[ 40.273363] eth0: Tx queue start entry 4 dirty entry 0.
[ 40.273367] eth0: Tx descriptor 0 is 00082046. (queue head)
[ 40.273370] eth0: Tx descriptor 1 is 00082046.
[ 40.273373] eth0: Tx descriptor 2 is 0008205a.
[ 40.273376] eth0: Tx descriptor 3 is 00082046.
[ 40.273391] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[ 41.230474] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[ 41.431896] eth0: no IPv6 routers present
[ 41.440201] NETDEV WATCHDOG: eth0: transmit timed out
[ 41.457255] eth0: Transmit timeout, status 0d 0000 c07f media d0.
[ 41.457259] eth0: Tx queue start entry 4 dirty entry 0.
[ 41.457263] eth0: Tx descriptor 0 is 0008205a. (queue head)
[ 41.457266] eth0: Tx descriptor 1 is 0008204e.
[ 41.457269] eth0: Tx descriptor 2 is 00082046.
[ 41.457272] eth0: Tx descriptor 3 is 00082156.
[ 41.457287] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[ 41.682133] NETDEV WATCHDOG: eth0: transmit timed out
[ 41.757548] eth0: Transmit timeout, status 0d 0000 c07f media d0.
[ 41.757555] eth0: Tx queue start entry 4 dirty entry 0.
[ 41.757559] eth0: Tx descriptor 0 is 00082046. (queue head)
[ 41.757562] eth0: Tx descriptor 1 is 00082156.
[ 41.757565] eth0: Tx descriptor 2 is 00082046.
[ 41.757567] eth0: Tx descriptor 3 is 0008205a.
[ 41.757583] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
flyex
帖子: 3
注册时间: 2007-09-20 21:54
送出感谢: 0
接收感谢: 0

#6

帖子 flyex » 2007-12-18 23:32

解决了,万恶的windows,
在windows下,我驱动选项的"wake up " enable即可,
不这样的话windows每次关机时会向网卡写入数据,导致在linux下用不了
anxiaonong
帖子: 4
注册时间: 2009-10-05 16:56
送出感谢: 0
接收感谢: 0

Re: [问题]为什么我的笔记本装了ubuntu 7.10,网卡无法正常工作?

#7

帖子 anxiaonong » 2009-10-11 22:21

我也遇到类似问题,就是安装了英文版本的ubuntu后,里面显示no network devices found.如果要在windows下该驱动选项为enable,请问怎么察看windows下的驱动选项?我是菜鸟
回复

回到 “笔记本、UMPC支持”