IBM T43双显示器的问题

笔记本/超便携移动PC软硬件相关支持,包括硬件、安装和驱动等
回复
arkxu
帖子: 54
注册时间: 2007-09-14 1:12
送出感谢: 0
接收感谢: 0

IBM T43双显示器的问题

#1

帖子 arkxu » 2007-12-16 17:00

在网上搜了很久,终于找到了一个方法是可以比较完美的在T43本本上实现双显示。一个是笔记本的lcd,一个是外接的液晶显示器。我用的是ati的开源驱动。大致的xorg.conf如下:

和显示有关的就是这些了:

代码: 全选

Section "Device"
	Identifier	"ATI Technologies Inc M22 [Mobility Radeon X300]"
	Driver		"fglrx"
	Screen 0
	Busid		"PCI:1:0:0"
	Option "backingstore" "true"
	Option "EnablePageFlip" "true"
	Option "SubPixelOrder" "none"
	Option "AccelMethod" "XAA"
	Option "RenderAccel" "true"
	Option "AGPMode" "4"
	Option "ColorTiling" "on"
	Option "DynamicClocks" "on"
	Option "mtrr" "on"
	Option "VideoOverlay" "on"
	Option "OpenGLOverlay" "off" 
EndSection

Section "Device"
	Identifier	"DeviceExt"
	Driver		"fglrx"
	Screen 1
	Busid		"PCI:1:0:0"
	Option "backingstore" "true"
	Option "EnablePageFlip" "true"
	Option "SubPixelOrder" "none"
	Option "AccelMethod" "XAA"
	Option "RenderAccel" "true"
	Option "AGPMode" "4"
	Option "ColorTiling" "on"
	Option "DynamicClocks" "on"
	Option "mtrr" "on"
	Option "VideoOverlay" "on"
	Option "OpenGLOverlay" "off" 
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
EndSection

Section "Monitor"
	Identifier	"MonitorExt"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc M22 [Mobility Radeon X300]"
	Monitor		"Generic Monitor"
	Defaultdepth	24
	SubSection "Display"
		Modes		"1400x1050"
	EndSubSection
EndSection

Section "Screen"
	Identifier "ScreenExt"
	Device "DeviceExt"
	Monitor "MonitorExt"
	DefaultDepth 24
	SubSection "Display"
		Depth 24
		Modes "1024x768"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
 	Screen "Default Screen"
	Screen "ScreenExt" RightOf "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	
	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
	Inputdevice	"Synaptics Touchpad"
EndSection
Section "Module"
	Load		"glx"
EndSection
Section "Extensions"
	Option		"Composite"	"Enable"
EndSection
Section "ServerFlags"
	Option "Xinerama" "true"
EndSection

但是现在的问题是,我的鼠标在本本的液晶里没有任何问题,但是一旦移到外接的液晶里就变成了一个不透明的方块!而且是彩色的,象花屏一样的。颜色试背景色而定。太奇怪了。现在我只能自己估计大概鼠标的头在哪儿了,因为这么大一个方块根本找不到头在哪儿。。。。

有没有人遇到相同的问题?怎么解决呢?谢谢!
arkxu
帖子: 54
注册时间: 2007-09-14 1:12
送出感谢: 0
接收感谢: 0

#2

帖子 arkxu » 2007-12-16 23:21

装了一个ati的7.11官方驱动。

搞定了!
头像
carbont
帖子: 3406
注册时间: 2007-11-22 10:20
来自: 北京
送出感谢: 0
接收感谢: 1 次

#3

帖子 carbont » 2007-12-17 1:44

怎么现在这个bbs上面老是看见自问自答的情况呢??……
头像
hatoyu
帖子: 171
注册时间: 2006-03-16 10:20
来自: http://www.adelaidecartridge.com
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 hatoyu » 2008-05-28 22:09

装了一个ati的7.11官方驱动。

在哪里下载的啊

ati网站只有 xp的
anffernee
帖子: 47
注册时间: 2008-07-01 23:07
送出感谢: 0
接收感谢: 0

#5

帖子 anffernee » 2008-08-03 21:54

同问楼上都问题啊,呵呵!
回复

回到 “笔记本、UMPC支持”