当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : IBM T43双显示器的问题
帖子发表于 : 2007-12-16 17:00 

注册: 2007-09-14 1:12
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
在网上搜了很久,终于找到了一个方法是可以比较完美的在T43本本上实现双显示。一个是笔记本的lcd,一个是外接的液晶显示器。我用的是ati的开源驱动。大致的xorg.conf如下:

和显示有关的就是这些了:
代码:
Section "Device"
   Identifier   "ATI Technologies Inc M22 [Mobility Radeon X300]"
   Driver      "fglrx"
   Screen 0
   Busid      "PCI:1:0:0"
   Option "backingstore" "true"
   Option "EnablePageFlip" "true"
   Option "SubPixelOrder" "none"
   Option "AccelMethod" "XAA"
   Option "RenderAccel" "true"
   Option "AGPMode" "4"
   Option "ColorTiling" "on"
   Option "DynamicClocks" "on"
   Option "mtrr" "on"
   Option "VideoOverlay" "on"
   Option "OpenGLOverlay" "off"
EndSection

Section "Device"
   Identifier   "DeviceExt"
   Driver      "fglrx"
   Screen 1
   Busid      "PCI:1:0:0"
   Option "backingstore" "true"
   Option "EnablePageFlip" "true"
   Option "SubPixelOrder" "none"
   Option "AccelMethod" "XAA"
   Option "RenderAccel" "true"
   Option "AGPMode" "4"
   Option "ColorTiling" "on"
   Option "DynamicClocks" "on"
   Option "mtrr" "on"
   Option "VideoOverlay" "on"
   Option "OpenGLOverlay" "off"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
EndSection

Section "Monitor"
   Identifier   "MonitorExt"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies Inc M22 [Mobility Radeon X300]"
   Monitor      "Generic Monitor"
   Defaultdepth   24
   SubSection "Display"
      Modes      "1400x1050"
   EndSubSection
EndSection

Section "Screen"
   Identifier "ScreenExt"
   Device "DeviceExt"
   Monitor "MonitorExt"
   DefaultDepth 24
   SubSection "Display"
      Depth 24
      Modes "1024x768"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
    Screen "Default Screen"
   Screen "ScreenExt" RightOf "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   
   # Uncomment if you have a wacom tablet
   #   InputDevice     "stylus"   "SendCoreEvents"
   #   InputDevice     "cursor"   "SendCoreEvents"
   #   InputDevice     "eraser"   "SendCoreEvents"
   Inputdevice   "Synaptics Touchpad"
EndSection
Section "Module"
   Load      "glx"
EndSection
Section "Extensions"
   Option      "Composite"   "Enable"
EndSection
Section "ServerFlags"
   Option "Xinerama" "true"
EndSection



但是现在的问题是,我的鼠标在本本的液晶里没有任何问题,但是一旦移到外接的液晶里就变成了一个不透明的方块!而且是彩色的,象花屏一样的。颜色试背景色而定。太奇怪了。现在我只能自己估计大概鼠标的头在哪儿了,因为这么大一个方块根本找不到头在哪儿。。。。

有没有人遇到相同的问题?怎么解决呢?谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-16 23:21 

注册: 2007-09-14 1:12
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
装了一个ati的7.11官方驱动。

搞定了!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-17 1:44 
头像

注册: 2007-11-22 10:20
帖子: 3406
地址: 北京
送出感谢: 0 次
接收感谢: 1
怎么现在这个bbs上面老是看见自问自答的情况呢??……


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-28 22:09 
头像

注册: 2006-03-16 10:20
帖子: 171
地址: http://www.adelaidecartridge.com
送出感谢: 0 次
接收感谢: 0 次
装了一个ati的7.11官方驱动。

在哪里下载的啊

ati网站只有 xp的


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-03 21:54 

注册: 2008-07-01 23:07
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
同问楼上都问题啊,呵呵!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译