当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问怎样在ubuntu10.04下安装KScope
帖子发表于 : 2010-07-23 20:16 

注册: 2010-07-23 19:53
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
各位:
大家好!小弟这两天编程要用到KScope,用命令sudo apt-get install kscope,提示说无法找到软件包。上网查了一下找到以下这篇文章:
ubuntu9.04下安装kscope1.6或1.9.4Linux系统配置 2009-05-19 13:54:59 阅读2214 评论5 字号:大中小
ubuntu9.04的源里没有kscope了,但是已经有人编译了kscope1.9.4的deb包,下载地址:

https://launchpad.net/~nizamov-shawkat/ ... 1_i386.deb

如果不习惯1.9.4版的,可以在下面链接下载1.6版的deb
http://archive.ubuntu.com/ubuntu/pool/u ... 1_i386.deb

这个依赖kde3的一些包,按照以下步骤解决
在终端下下载
wget ftp.debian.org/debian/pool/main/k/kdebase/kate_3.5.9.dfsg.1-6_i386.deb
ar x kate_3.5.9.dfsg.1-6_i386.deb
tar xzf data.tar.gz
sudo cp usr/lib/libkateinterfaces.so.0.0.0 /usr/local/lib
sudo ldconfig
libkateutils.so.0也照上面的方法拷贝过去(记住也要sudo ldconfig)。
运行kscope成功。

我按着上面的方法下载了1.9.4版的,可是安装的时候,提示说“错误: 依赖关系没有满足:libqscintilla2-3”,然后我使用命令sudo apt-get install libqscintilla2-3进行安装,可是提示说找不到libqscintilla2-3安装包,不过有一个替代libqscintilla2-5的安装包,我就下载安装了libqscintilla2-5,安装完成后,我再安装KScope1.9.4的时候还是提示说“错误: 依赖关系没有满足:libqscintilla2-3”,结果1.9.4版本的我就安不上了。然后我尝试使用1.6版的,我从网址上下了1.6版的下来,可是当我要下载KDE3.5的时候,输入命令wget ftp.debian.org/debian/pool/main/k/kdebase/kate_3.5.9.dfsg.1-6_i386.deb老是提示说失败找不到该网址。上网查了很久也没有弄清楚是什么原因,请各位牛人帮忙解决一下,谢谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译