GtkApkManager --- apk文件查看/安装器

由本社区发起的开源项目
回复
wkt
帖子: 849
注册时间: 2006-09-07 22:51
送出感谢: 0
接收感谢: 0
联系:

GtkApkManager --- apk文件查看/安装器

#1

帖子 wkt » 2014-08-17 23:52

功能特性:
关联打开.apk文件
支持按locale读取应用名称
支持查看应用图标/版本
支持安装应用(需要开启调试模式,具体开启方式:点击界面上的 "帮助" 按钮)

截图:
apkmanager3.png
3
apkmanager4.png
4

项目主页: http://git.oschina.net/wkt/gtkapkmanager
下载地址: http://xx51.net/download.do/gtkapkmanager_1.1_amd64.deb
wkt
帖子: 849
注册时间: 2006-09-07 22:51
送出感谢: 0
接收感谢: 0
联系:

Re: GtkApkManager --- apk文件查看/安装器

#2

帖子 wkt » 2014-10-21 0:17

自己消灭0回复 :em03
头像
GuoMei
帖子: 147
注册时间: 2014-08-20 3:00
系统: Haiku
送出感谢: 0
接收感谢: 2 次

Re: GtkApkManager --- apk文件查看/安装器

#3

帖子 GuoMei » 2014-10-21 0:40

liveCD

代码: 全选

ubuntu-gnome@ubuntu-gnome:~/下载$ sudo dpkg -i gtkapkmanager_1.1_amd64.deb 
Selecting previously unselected package gtkapkmanager.
(正在读取数据库 ... 系统当前共安装有 157116 个文件和目录。)
Preparing to unpack gtkapkmanager_1.1_amd64.deb ...
Unpacking gtkapkmanager (1.1) ...
dpkg: dependency problems prevent configuration of gtkapkmanager:
 gtkapkmanager 依赖于 lib32gcc1 (>= 1:4.1.1);然而:
  未安装软件包 lib32gcc1。
 gtkapkmanager 依赖于 libc6-i386 (>= 2.7);然而:
  未安装软件包 libc6-i386。

dpkg: error processing package gtkapkmanager (--install):
 依赖关系问题 - 仍未被配置
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu2) ...
Processing triggers for mime-support (3.55ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
在处理时有错误发生:
 gtkapkmanager
ubuntu-gnome@ubuntu-gnome:~/下载$ 

代码: 全选

ubuntu-gnome@ubuntu-gnome:~$ sudo gtkapkmanager %U

(gtkapkmanager:20599): GLib-GObject-WARNING **: The property GtkButton:use-stock is deprecated and shouldn't be used anymore. It will be removed in a future version.

(gtkapkmanager:20599): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
aapt: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
adb: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

(gtkapkmanager:20599): Gtk-CRITICAL **: gtk_list_store_get_path: assertion 'iter->stamp == priv->stamp' failed
aapt: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory

wkt
帖子: 849
注册时间: 2006-09-07 22:51
送出感谢: 0
接收感谢: 0
联系:

Re: GtkApkManager --- apk文件查看/安装器

#4

帖子 wkt » 2014-10-21 20:52

GuoMei 写了:liveCD

代码: 全选

ubuntu-gnome@ubuntu-gnome:~/下载$ sudo dpkg -i gtkapkmanager_1.1_amd64.deb 
Selecting previously unselected package gtkapkmanager.
(正在读取数据库 ... 系统当前共安装有 157116 个文件和目录。)
Preparing to unpack gtkapkmanager_1.1_amd64.deb ...
Unpacking gtkapkmanager (1.1) ...
dpkg: dependency problems prevent configuration of gtkapkmanager:
 gtkapkmanager 依赖于 lib32gcc1 (>= 1:4.1.1);然而:
  未安装软件包 lib32gcc1。
 gtkapkmanager 依赖于 libc6-i386 (>= 2.7);然而:
  未安装软件包 libc6-i386。

dpkg: error processing package gtkapkmanager (--install):
 依赖关系问题 - 仍未被配置
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu2) ...
Processing triggers for mime-support (3.55ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
在处理时有错误发生:
 gtkapkmanager
ubuntu-gnome@ubuntu-gnome:~/下载$ 

代码: 全选

ubuntu-gnome@ubuntu-gnome:~$ sudo gtkapkmanager %U

(gtkapkmanager:20599): GLib-GObject-WARNING **: The property GtkButton:use-stock is deprecated and shouldn't be used anymore. It will be removed in a future version.

(gtkapkmanager:20599): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
aapt: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
adb: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

(gtkapkmanager:20599): Gtk-CRITICAL **: gtk_list_store_get_path: assertion 'iter->stamp == priv->stamp' failed
aapt: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory

ubuntu是哪个版本的?若联网先试试:
sudo apt-get update ; sudo apt-get -f install
处理一下软件包依赖!
回复

回到 “开源小工具”