当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : !!!!!!!!求助:GRUB恢复问题!!!!!!!
帖子发表于 : 2008-09-13 13:26 
头像

注册: 2008-06-09 12:41
帖子: 12
地址: http://hi.baidu.com/cokinga
送出感谢: 0 次
接收感谢: 0 次
我的一个80G的硬盘,
C盘20G装VISTA,又分了10G装MAC,剩下的装ubuntu 8.04
20g为“/”根分区,200M为boot分区,1024M为swap交换分区,剩下的作为home分区。

由于重装了VISTA,grub启动菜单不见了。见网上说用live cd启动,选择“试用ubuntu”,运行终端,启用root账户,输入find /boot/grub/stage1

我输入了,但是没有任何反馈信息,而且还提示我有错误!!!!!
我又输入 find /boot 系统显示有这个目录
我再输入 find /boot/grub 系统显示没这个目录!!!

请教一下这是怎么回事?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-09-13 14:25 

注册: 2007-05-13 15:20
帖子: 333
送出感谢: 0 次
接收感谢: 0 次
基本过程;

用任意live cd进去后

mount /dev/"device of root" /mnt
mount /dev/'device of boot" /mnt/boot
mount -o bind /dev /mnt/dev
mount -o bind /proc /mnt/proc
chroot /mnt

grub-install (hd0)

exit
reboot


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-09-13 15:01 

注册: 2008-05-24 8:30
帖子: 1453
送出感谢: 2
接收感谢: 30
那个 find 应该是在 grub shell 下用的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-09-13 17:40 
头像

注册: 2008-06-09 12:41
帖子: 12
地址: http://hi.baidu.com/cokinga
送出感谢: 0 次
接收感谢: 0 次
谢谢2楼的,不过问题已经解决了。
我的BOOT分区 是单独的,所以应该是
代码:
find /grub/stage1


_________________

ˇ` 超頻Wú極限 `ˇ

Qun№:5652405


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译