双硬盘安装后grub for dos不能引导!!??

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
alphabeta
帖子: 2
注册时间: 2008-10-01 11:37
送出感谢: 0
接收感谢: 0

双硬盘安装后grub for dos不能引导!!??

#1

帖子 alphabeta » 2008-11-02 23:01

本人双硬盘,sata为主装windows,pata为辅装linux。用grub for dos引导linux。
分区如下:
hdb1,hdb2,hdb3为ntfs
hdb5 suse /boot
hdb6 ubuntu /boot
hdb7 suse /
hdb8 ubuntu /
hdb9 共用 /home
安装suse后要修改menu.lst,将hd0改为相应的hd1成功引导。
但装完ubuntu8.10后,提取出来的menu.lst竟然都以uuid代替传统路径。用livecd进入过系统ls -l /dev/disk/by-uuid查询各分区的uuid,跟引导菜单无异。但引导菜单选择ubuntu选项就是显示file not found~~,各路径(root hd1,x)都尝试过了~~是否8.10版就只能用uuid来指示路径?是不支持sata、pata混合安装,还是grub for dos不支持uuid这种方式引导?难道非要把ubuntu的grub装到mbr吗?
i126
帖子: 25
注册时间: 2008-11-04 0:02
送出感谢: 0
接收感谢: 0

Re: 双硬盘安装后grub for dos不能引导!!??

#2

帖子 i126 » 2008-11-04 15:33

我也要帮助,本人双硬盘,sata为主装windows,pata为辅装8.10,用光盘装的,重新启动后,启动选项只有xp和dos工具箱,没有ubuntu选项,怎么办?
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

Re: 双硬盘安装后grub for dos不能引导!!??

#3

帖子 ptptptptptpt » 2008-11-04 16:11

grub for dos 确实不支持uuid 命令。

不是 (root hd1,x) ,而应该是

代码: 全选

 root   (hd1,x) 
,你在试试吧
头像
thefour
帖子: 429
注册时间: 2008-03-05 12:31
来自: 示爱须唱山歌
送出感谢: 0
接收感谢: 0

Re: 双硬盘安装后grub for dos不能引导!!??

#4

帖子 thefour » 2008-11-05 3:07

刚搞好才看到这个帖 :em06
我也是双硬盘
不习惯将GRUB安装到MBR
按一贯的做法将 grub.exe grldrt 和8.10的menu.lst 复制到win的C盘下
结果就是error 15

比照一下8.10和8.04的menu.lst
将UUID的项改成root (hd1,x) 后问题解决了
六十学裁缝,晚否......
alphabeta
帖子: 2
注册时间: 2008-10-01 11:37
送出感谢: 0
接收感谢: 0

Re: 双硬盘安装后grub for dos不能引导!!??

#5

帖子 alphabeta » 2008-11-05 21:59

谢楼上的朋友,问题已解决,参考了之前的某些帖子。把内核文件vmlinuz~、initrdimg~文件复制到grub的根目录,如hd0,0即可。至于之前我并不是引导项写错,是我随便写表达错了。在boot分区里提取的menu.lst的uuid没问题,只是每次格式化都会变动,又要改回来比较麻烦。
回复

回到 “启动和引导”