当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 启动过程长达3分钟,请高手进来帮忙分析下原因。有bootchart截图。
帖子发表于 : 2008-11-05 19:19 

注册: 2008-11-05 19:03
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
今天忽然间发觉Ubuntu的启动速度很慢,每次启动条读到3分之1的时候挂起,大约过1分多钟才开始继续读条。
搞了个bootchart看了下,以为是NTP的问题,删掉重新启动还是老样子。现在把bootchart的启动分析发上来
请教一下,我实在是山穷水尽了阿!
图片


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 启动过程长达3分钟,请高手进来帮忙分析下原因。有bootchart截图。
帖子发表于 : 2008-11-06 0:54 

注册: 2008-11-05 19:03
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
终于找到罪魁祸首了~
前面睡了一觉起来又看了看bootchart的图片
凭着一个男人的直觉发现有可能是networking这块什么东西在启动的时候挂住了
于是乎搞来sysv-rc-conf工具把networking取消了
重启,果然启动速度恢复正常,才用了35秒。
后来想了想是前天在搞Vbox的桥接模式的时候network这块有修改过和添加了一些组件
估计应该是启动/etc/network/interfaces里的tap0和br0的时候挂起了
于是用sysv-rc-conf恢复了networking
把/etc/network/interfaces里的tap0和br0前面加上了#号
重启后启动速度正常
可这样以后要用到Vbox的桥接模式就比较麻烦了。。。。。。
要恢复/etc/network/interfaces里的tap0和br0重启后才能使用。
不知道大家有什么别的方法
这里附上正常启动后的bootchart图片
图片


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 启动过程长达3分钟,请高手进来帮忙分析下原因。有bootchart截图。
帖子发表于 : 2008-11-06 18:02 
头像

注册: 2008-08-31 10:09
帖子: 629
送出感谢: 2
接收感谢: 1
:em38 厉害


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 启动过程长达3分钟,请高手进来帮忙分析下原因。有bootchart截图。
帖子发表于 : 2008-11-06 18:13 
头像

注册: 2008-05-11 11:10
帖子: 1078
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
drc1234 写道:
:em38 厉害


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译