[已解决]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
duolon
帖子: 55
注册时间: 2008-11-10 19:12
送出感谢: 0
接收感谢: 3 次

[已解决]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#1

帖子 duolon » 2008-12-02 14:50

rt
xp装在c盘,FAT32
修复grub时一不小心安下了setup(hd0,0),
现在选xp后就直接跳回grub选择操作系统的界面。求救,如何解决?
上次由 duolon 在 2008-12-03 13:00,总共编辑 1 次。
LuciferStar
帖子: 146
注册时间: 2008-10-27 9:38
送出感谢: 0
接收感谢: 0

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#2

帖子 LuciferStar » 2008-12-02 15:22

GRUB选择操作系统界面按C,然后重新设置。
头像
AutoXBC
帖子: 1744
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#4

帖子 AutoXBC » 2008-12-02 15:43

C 盘的分区引导记录被 Grub 修改了,需要改回 NT 的引导。

用 loadbin 直接加载 ntldr 应该是最方便的,可以绕过分区引导记录。
http://bbs.znpc.net/archiver/?tid-4273.html
billbear
帖子: 3681
注册时间: 2008-05-03 23:42
送出感谢: 0
接收感谢: 3 次

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#5

帖子 billbear » 2008-12-02 16:50

如果能进 ubuntu 的话,你可以安装使用开源工具 ms-sys 来写微软的启动扇区。

http://ms-sys.sourceforge.net/ 下载 ms-sys-2.1.3.tgz 。

安装:进入下载 ms-sys-2.1.3.tgz 的目录,然后
sudo apt-get install build-essential
sudo apt-get install gettext
tar -xzvf ms-sys-2.1.3.tgz
cd ms-sys-2.1.3/
make
sudo make install

接下来,在终端输入如下命令
sudo ms-sys --fat32nt /dev/sda1
输入密码完成命令。
重启。
头像
AutoXBC
帖子: 1744
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#6

帖子 AutoXBC » 2008-12-02 17:14

手上有 WinPE 启动盘的话,也可以用 bootsect.exe 写启动扇区。

http://hi.baidu.com/ignorantoff/blog/it ... d40b3.html
duolon
帖子: 55
注册时间: 2008-11-10 19:12
送出感谢: 0
接收感谢: 3 次

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#7

帖子 duolon » 2008-12-03 10:46

谢谢楼上各位了。

-.-小菜我用winXP sp3正版光盘插进以后选r修复,然后fixboot fixmbr,结果变成了disk error-.-重装了已经。。。硬盘所有资料挂掉-.-
hgshlg
帖子: 222
注册时间: 2007-08-30 14:45
送出感谢: 0
接收感谢: 0

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#8

帖子 hgshlg » 2008-12-03 10:56

duolon 写了:谢谢楼上各位了。

-.-小菜我用winXP sp3正版光盘插进以后选r修复,然后fixboot fixmbr,结果变成了disk error-.-重装了已经。。。硬盘所有资料挂掉-.-
先不写东西进去,很多资料是可以用工具找回的,我曾经用dd命令把硬盘从开始的地方写了200多M的0,分区表没了,不过找回了很资料。网上有很多数据恢复的软件。
头像
AutoXBC
帖子: 1744
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#9

帖子 AutoXBC » 2008-12-03 11:46

其实 4.5.6 楼的方法都是可行的,重装是回避问题不是解决问题,以后不要这样了。
duolon
帖子: 55
注册时间: 2008-11-10 19:12
送出感谢: 0
接收感谢: 3 次

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#10

帖子 duolon » 2008-12-03 12:00

-.-昨天下午我跑到邻居家拆了个光驱回来,把windows xp sp3光盘插进去,按r,输入fixboot,fixmbr,结果,连grub引导都看不见了,硬盘启动显示disk err-.-所以才重装-.-无奈啊@_@
头像
32idea
帖子: 1248
注册时间: 2006-12-15 9:32
系统: linux
送出感谢: 2 次
接收感谢: 14 次

Re: [求救]修复grub时错写setup(hd0,0),现在开机选xp不断跳回grub。。

#11

帖子 32idea » 2008-12-03 12:00

其实就是把menu.lst里xp的启动项目改成正确的就行,论坛里有很多写好的,因为大多数人都是把xp装在c盘

其次就是用xp盘fdisk /mbr,然后用grubfordos来启动linux,

出了问题不要急着毁数据,多看看老贴,其实你遇到的问题早就有各种比较好的答案了。
回复

回到 “启动和引导”