把根分区挂载到新的分区后启动不了(解决)

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
头像
苹果虫
帖子: 185
注册时间: 2008-08-25 18:57
送出感谢: 0
接收感谢: 0

把根分区挂载到新的分区后启动不了(解决)

#1

帖子 苹果虫 » 2008-12-10 21:15

由于想换个文件系统,把原 / 备份到新的分区后,再格式化再CP回来
但挂载到新分区时无法启动,帮看看是何原因
run-init: /sbin/init: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

PS:问题找到,是我太大意,见六楼
现在已经全换成EXT4DEV了
上次由 苹果虫 在 2008-12-14 15:06,总共编辑 2 次。
ryoohki
帖子: 3249
注册时间: 2008-10-28 20:18
送出感谢: 0
接收感谢: 0

Re: 把根分区挂载到新的分区后启动不了

#2

帖子 ryoohki » 2008-12-10 22:03

/etc/fstab
有没有配过?/ 的位置要用新分区的设备路径
头像
苹果虫
帖子: 185
注册时间: 2008-08-25 18:57
送出感谢: 0
接收感谢: 0

Re: 把根分区挂载到新的分区后启动不了

#3

帖子 苹果虫 » 2008-12-10 22:25

回楼上,有
UUID=* / ext4dev relatime 0 1
头像
苹果虫
帖子: 185
注册时间: 2008-08-25 18:57
送出感谢: 0
接收感谢: 0

Re: 把根分区挂载到新的分区后启动不了

#4

帖子 苹果虫 » 2008-12-11 23:31

没人能解答?
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

Re: 把根分区挂载到新的分区后启动不了

#5

帖子 ptptptptptpt » 2008-12-11 23:41

你是怎么备份的??
头像
苹果虫
帖子: 185
注册时间: 2008-08-25 18:57
送出感谢: 0
接收感谢: 0

Re: 把根分区挂载到新的分区后启动不了

#6

帖子 苹果虫 » 2008-12-11 23:49

mkdir /reiser4/dev
mkdir /reiser4/proc
cp -a /etc /reiser4
cp -a /bin /reiser4
cp -a /var /reiser4
cp -a /usr /reiser4
cp -a /lib /reiser4
cp -a /root /reiser4
cp -a /boot /reiser4
cp -a /tmp /reiser4
cp -a /sbin /reiser4
mkdir /reiser4/sys

差不多是这样吧,我打算先转/,/home下次再用同样方法转换
还有/reiser4我挂载的是ext4dev

PS我看着别人的文章做,CP备份时漏掉lib32 lib64,所以能挂载无法启动系统
上次由 苹果虫 在 2008-12-14 15:05,总共编辑 1 次。
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

Re: 把根分区挂载到新的分区后启动不了

#7

帖子 ptptptptptpt » 2008-12-12 0:07

UUID=* / ext4dev relatime 0 1
UUID=* ??你是这么写的??
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

Re: 把根分区挂载到新的分区后启动不了

#8

帖子 ptptptptptpt » 2008-12-12 0:08

menu.lst 有没有改??
头像
苹果虫
帖子: 185
注册时间: 2008-08-25 18:57
送出感谢: 0
接收感谢: 0

Re: 把根分区挂载到新的分区后启动不了

#9

帖子 苹果虫 » 2008-12-12 0:44

ptptptptptpt 写了:
UUID=* / ext4dev relatime 0 1
UUID=* ??你是这么写的??
当然不是
menu.lst里我这样写
title Ubuntu 8.10, kernel core2,sda9
kernel /vmlinuz-2.6.27.8 root=UUID=410d2ebd-af70-4ca0-b1f5-5d7328a42404 ro ROOTFLAGS=syncio quiet splash
initrd /initrd.img-2.6.27.8

410d2ebd-af70-4ca0-b1f5-5d7328a42404是我要挂载的新EXT4DEV分区
就是无法启动,提示已经贴在一楼了,
无法挂载就无法把原/的分区格成EXT4DEV
会不会是跟initrd.img有关,因为我是重新编译的内核
头像
HuntXu
论坛版主
帖子: 5778
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: 把根分区挂载到新的分区后启动不了

#10

帖子 HuntXu » 2008-12-12 0:58

title Ubuntu 8.10, kernel core2,sda9
kernel /vmlinuz-2.6.27.8 root=UUID=410d2ebd-af70-4ca0-b1f5-5d7328a42404 ro ROOTFLAGS=syncio quiet splash
initrd /initrd.img-2.6.27.8
这里有没有root (hd*,*)的命令?
还有怎么是/vmlinuz,你的内核直接安装在/下?
HUNT Unfortunately No Talent...
头像
HuntXu
论坛版主
帖子: 5778
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: 把根分区挂载到新的分区后启动不了

#11

帖子 HuntXu » 2008-12-12 0:59

还有试试不要用root=UUID=***的方式,直接root=/dev/sda9
相信你的内核应该有把ext4编译进去的吧.
HUNT Unfortunately No Talent...
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

Re: 把根分区挂载到新的分区后启动不了

#12

帖子 ptptptptptpt » 2008-12-12 1:16

看提示应该是根分区没挂载上。

menu.lst 里怎么没有 root (hdx,x)或 uuid xxxxx 行 ??
头像
苹果虫
帖子: 185
注册时间: 2008-08-25 18:57
送出感谢: 0
接收感谢: 0

Re: 把根分区挂载到新的分区后启动不了

#13

帖子 苹果虫 » 2008-12-12 1:52

HuntXu 写了:
title Ubuntu 8.10, kernel core2,sda9
kernel /vmlinuz-2.6.27.8 root=UUID=410d2ebd-af70-4ca0-b1f5-5d7328a42404 ro ROOTFLAGS=syncio quiet splash
initrd /initrd.img-2.6.27.8
这里有没有root (hd*,*)的命令?
还有怎么是/vmlinuz,你的内核直接安装在/下?
我也不清楚,我是新手
加上(hd0,-1)无法引导
/下面有vmlinuz 和initrd.img两个连接,指向boot/vmlinuz-2.6.27-10-generic 和boot/initrd.img-2.6.27-10-generic
可这两个原文件早就删除了,我都不知为什么能启动
回复

回到 “启动和引导”