当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu安装到U盘后无法正常使用计算机
帖子发表于 : 2009-01-10 21:10 

注册: 2008-12-26 20:59
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
[size=150]我电脑里面装了Windows XP,还装了个red flag desktop 6.0,最近看到同学将linux安装到U盘里面,觉得挺好玩的,虽然没有碰到过什么要用应急盘的情况,但还是以这个很好的理由买了个8G的U盘,开始将Ubuntu安装到U盘里的路程。因为安装red flag的时候是用的是grub引导硬盘里的iso镜像,所以在安装Ubuntu也采用了同样的方法。成功引导,插入U盘,显示分区为hd1,大小什么的跟U盘相匹配,但没有看见硬盘的盘符,选择开始手动分区,没有成功,后来干脆选择自动分区,成功安装。安装好了重新引导,进入了Ubuntu!关闭系统,拔下U盘,重新开机,开机自检后显示waiting后显示erroe21就没有反应了。关闭电源,开机,仍然如此。插入U盘,进入grub,选择xp,成功进入。
现在的问题是不用U盘就进不了任何系统。请高手指教!
[/size]


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu安装到U盘后无法正常使用计算机
帖子发表于 : 2009-01-11 16:25 

注册: 2008-09-25 16:06
帖子: 100
送出感谢: 0 次
接收感谢: 0 次
因为之前已经装了一个linux系统,grub是装在硬盘上的。在装ubuntu的时候,grub从硬盘转移到了u盘上,所以导致不插u盘,系统找不到grub无法引导。你可以重新装一下grub,将它写入硬盘的mbr里。具体的重建grub的方法可以参考这里:
http://wiki.ubuntu.org.cn/UbuntuHelp:RecoveringUbuntuAfterInstallingWindows/zh#.E6.89.8B.E5.B7.A5.E6.81.A2.E5.A4.8DGRUB


最后由 hrbeu06ws 编辑于 2009-01-11 22:14,总共编辑了 1 次

页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu安装到U盘后无法正常使用计算机
帖子发表于 : 2009-01-11 19:04 

注册: 2008-05-03 23:42
帖子: 3681
送出感谢: 4
接收感谢: 6
楼上说反了吧.


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu安装到U盘后无法正常使用计算机
帖子发表于 : 2009-01-12 14:58 

注册: 2008-12-26 20:59
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
解决了!
我将red flag重新装了一下,可以引导硬盘里面的grub了,但已经无法进入red flag了!索性也在硬盘原来装了red flag的分区里面装了ubuntu,然后再插着U盘欲进入U盘里的ubuntu,才发现我的主板不支持USB启动,只有一个removeble选项,选项里面只有一个软盘,郁闷死我!
后来将硬盘里面ubuntu下的/boot/grub/menu.lst改了改,终于又能进入U盘的ubuntu了。原来的问题也解决了! :em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译