当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-27 22:25 

注册: 2009-01-09 11:30
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题,请各位写一下标准的
加载命令,我再试下,谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-27 23:03 

注册: 2009-03-23 20:03
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
你是用wubi装的吧? :em06


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-27 23:52 
头像

注册: 2008-04-26 12:41
帖子: 10974
送出感谢: 11
接收感谢: 38
wubi安装在fat分区会无法显示中文,暂时无解,等待高人 :em09
当然,有一个变通的办法,把fat转成ntfs就行了


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 9:20 

注册: 2009-01-09 11:30
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
是用wubi,我每个分区都是NTFS ,ubuntu装在D盘,C 跟E在挂载时能正常显示中文,就D盘挂载时无法显示,所有中文文件跟中文文件夹都不显示。各位有什么方法,再有就是哪个是显示中文的完整MOUNT 命令


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 10:44 
头像

注册: 2008-04-26 12:41
帖子: 10974
送出感谢: 11
接收感谢: 38
lovematrix 写道:
是用wubi,我每个分区都是NTFS ,ubuntu装在D盘,C 跟E在挂载时能正常显示中文,就D盘挂载时无法显示,所有中文文件跟中文文件夹都不显示。各位有什么方法,再有就是哪个是显示中文的完整MOUNT 命令

ubuntu所在的D盘是系统自动挂载在/host下面的,不用mount :em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 10:49 

注册: 2009-01-09 11:30
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
photor 你真热心 , :em11 表扬一个! 就你回答我次数多,确实是自动挂载,问题还是没有中文! 任何中文文件和中文目录都不显示!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 10:50 

注册: 2009-01-09 11:30
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
麻烦各位看一下,你们的显示中文目录和文件吗,还有,想一下我的有什么方法可能解决


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 11:25 
头像

注册: 2008-04-26 12:41
帖子: 10974
送出感谢: 11
接收感谢: 38
我这里确实没有问题,不知道你的是怎么回事了 :em20


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 11:27 

注册: 2009-01-09 11:30
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
罢了,吃完饭再重装! 好了再说。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 11:30 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
怎么要重装呢?这个不知合用不?我的全部显示正常,如果现在用904可能很多地方有鸡肠文
自动挂载 windows 分区执行下列命令, 编辑挂载脚本 autowinfs.

sudo gedit /usr/sbin/autowinfs

复制粘贴以下引用的内容,保存文件, 退出。

mkdir -p /windows/
rmdir /windows/* 1> /dev/null
grep -v '/windows/' /etc/fstab > /etc/fstab.swp
fdisk -l /dev/[hs]d[a-z] | grep 'NTFS' | cut -d' ' -f1 | cut -d/ -f3 | while read WDISKS
do echo "/dev/$WDISKS /windows/$WDISKS ntfs auto,user,nls=utf8,umask=0 0 0" >> /etc/fstab.swp
mkdir "/windows/$WDISKS"
done
fdisk -l /dev/[hs]d[a-z] | grep 'FAT' | cut -d' ' -f1 | cut -d/ -f3 | while read WDISKS
do echo "/dev/$WDISKS /windows/$WDISKS vfat auto,user,utf8,umask=0 0 0" >> /etc/fstab.swp
mkdir "/windows/$WDISKS"
done
mv /etc/fstab.swp /etc/fstab
mount -a
exit 0

再运行命令:

sudo chmod +x /usr/sbin/autowinfs
sudo /usr/sbin/autowinfs

就可以了,Windows分区将挂载在 /windows/ 下


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 12:59 

注册: 2009-01-09 11:30
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
carlos@carlos-desktop:~$ sudo /usr/sbin/autowinfs
rmdir: 删除 “/windows/sda1” 失败: Device or resource busy
rmdir: 删除 “/windows/sda5” 失败: Device or resource busy
rmdir: 删除 “/windows/sda6” 失败: Device or resource busy
mkdir: 无法创建目录 “/windows/sda1”: 文件已经存在
mkdir: 无法创建目录 “/windows/sda5”: 文件已经存在
mkdir: 无法创建目录 “/windows/sda6”: 文件已经存在

不过已经在/WINDOWS/下挂载成功,但D盘sda5还是没有中文! 其他两个盘没有问题,
还有其他可能吗


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-03-28 15:43 

注册: 2009-01-09 11:30
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
哪位帮忙把fstab文件复制上来看一下,谢谢


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-04-01 11:41 

注册: 2009-01-09 11:30
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
KAO! 求人不如求已,干等这么多天,高手们不知道都干什么! 就上面几个哥们出招,虽不着点,但也感谢,还是自己搞定,换了个版本,搞定!


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 问个老问题,加载ubuntu所在的分区时无法显示中文,其他分区没问题
帖子发表于 : 2009-04-01 16:53 

注册: 2008-05-03 23:42
帖子: 3681
送出感谢: 4
接收感谢: 6
lovematrix 写道:
KAO! 求人不如求已,干等这么多天,高手们不知道都干什么! 就上面几个哥们出招,虽不着点,但也感谢,还是自己搞定,换了个版本,搞定!

楼上的这么说话就有点不好了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译