当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 语言表达不好,连Google后都无法解决的小问题。。。
帖子发表于 : 2009-04-03 11:05 
头像

注册: 2008-12-07 21:19
帖子: 114
送出感谢: 0 次
接收感谢: 0 次
目前我有两块硬盘,一块是Hitachi SATA 160G,另一块是组的移动硬盘Seagate 250G 配的SSK的2.5飞鹰盒子,USB ---大硬盘指的是3.5的非移动硬盘
我在大硬盘中已安装好WindowsXP,同时集成了一个WDOS,现在从大硬盘为主引导盘的话,启动windows会有用grub编的一个F11进入wdos的启动项,停留4s,而非写在XP的boot.ini里
小硬盘则装了Ubuntu8.10,这样,如果我想用ubuntu的话,在BIOS设置下第一硬盘为USB移动硬盘,则开机直接进入Linux下的Grub,可以正常进入ubuntu,但当时不能引导不了大硬盘的XP,我上网搜索了一下,简单修改了下menu.lst,通过用map命令,可以引导XP了,可是却是直接启动了windows。

如果我想当设置USB盘为第一硬盘,grub启动后,如何编写menu.lst,让其直接启动大硬盘上的原先的启动菜单,就是可以出现"F11"这个界面?

顺便借地问个其它问题。。我的AC97音频控制芯片为 Intel 82801G(ICH7) High Definition Audio 现在在Ubuntu中,前置音频输出的耳机没有声音(前置Mic可用,音箱能听见声音),已经确认无静音情况,网上有的朋友有一个Switch标签,下面有一个Headphone,说是把那个钩加上耳机就有声音了,可是我的系统却没有。首选项里也查了一遍。
其它听歌,系统登陆现在都有声音了。就是耳机没声音。而windows下却好使


_________________
一步一个脚印,折腾无止境。
Core 2 Duo E4600, Spark BI-100 P35, Adata 2GB DDR2-800, Hitachi 160GB 3.5+Segate250GB 2.5,Ondata 9600GSO 384MB G92,Samsung T220P,Dell L100+MOC5UO
Ubuntu 9.04 x86_32 @ ext4 with English Local & Windows XP Professional 32bit.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 语言表达不好,连Google后都无法解决的小问题。。。
帖子发表于 : 2009-04-04 17:29 
头像

注册: 2008-12-07 21:19
帖子: 114
送出感谢: 0 次
接收感谢: 0 次
顶一手先。。学习ubuntu真是痛并快乐着。。。


_________________
一步一个脚印,折腾无止境。
Core 2 Duo E4600, Spark BI-100 P35, Adata 2GB DDR2-800, Hitachi 160GB 3.5+Segate250GB 2.5,Ondata 9600GSO 384MB G92,Samsung T220P,Dell L100+MOC5UO
Ubuntu 9.04 x86_32 @ ext4 with English Local & Windows XP Professional 32bit.


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 语言表达不好,连Google后都无法解决的小问题。。。
帖子发表于 : 2009-04-04 17:33 
头像

注册: 2009-03-26 2:15
帖子: 230
送出感谢: 0 次
接收感谢: 0 次
超出我知识范围了,很抱歉,我帮不上你!就帮你顶下帖子,尽我所能尽之力!不好意思哈! :em03


_________________
有朋友,没忧愁!耶!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 语言表达不好,连Google后都无法解决的小问题。。。
帖子发表于 : 2009-04-05 16:36 
头像

注册: 2008-09-07 22:50
帖子: 247
送出感谢: 0 次
接收感谢: 1
在menu.lst里加:
title Windows menu
root (hd1,0)
chainloader +1

就能出现大硬盘上的原先的启动菜单


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 语言表达不好,连Google后都无法解决的小问题。。。
帖子发表于 : 2009-04-05 16:54 
头像

注册: 2008-12-07 21:19
帖子: 114
送出感谢: 0 次
接收感谢: 0 次
ggghai 写道:
在menu.lst里加:
title Windows menu
root (hd1,0)
chainloader +1

就能出现大硬盘上的原先的启动菜单



不是这样的。。。
这么做就是我前面说的直接启动了windows,实际上阁下这么做还不能成功引导,会出错的,必须得用map进磁盘重映射 才能启动winxp


_________________
一步一个脚印,折腾无止境。
Core 2 Duo E4600, Spark BI-100 P35, Adata 2GB DDR2-800, Hitachi 160GB 3.5+Segate250GB 2.5,Ondata 9600GSO 384MB G92,Samsung T220P,Dell L100+MOC5UO
Ubuntu 9.04 x86_32 @ ext4 with English Local & Windows XP Professional 32bit.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 语言表达不好,连Google后都无法解决的小问题。。。
帖子发表于 : 2009-04-05 17:02 
头像

注册: 2008-09-07 22:50
帖子: 247
送出感谢: 0 次
接收感谢: 1
这样:
title Windows menu
map (hd0) (hd1)
map (hd1) (hd0)
root (hd0,0)
chainloader +1


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 语言表达不好,连Google后都无法解决的小问题。。。
帖子发表于 : 2009-04-05 17:05 
头像

注册: 2008-09-07 22:50
帖子: 247
送出感谢: 0 次
接收感谢: 1
关键在于chainloader,能出现大硬盘上的原先的启动菜单


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 语言表达不好,连Google后都无法解决的小问题。。。
帖子发表于 : 2009-04-05 20:05 
头像

注册: 2008-12-07 21:19
帖子: 114
送出感谢: 0 次
接收感谢: 0 次
ggghai 写道:
这样:
title Windows menu
map (hd0) (hd1)
map (hd1) (hd0)
root (hd0,0)
chainloader +1



我发贴前menu.lst就是这样写的。。是直接启动winxp,因为Hitachi硬盘原先的F11功能也是用Grub写的,而不是配置在boot.ini文件中,我发贴前就已经说明了。。


_________________
一步一个脚印,折腾无止境。
Core 2 Duo E4600, Spark BI-100 P35, Adata 2GB DDR2-800, Hitachi 160GB 3.5+Segate250GB 2.5,Ondata 9600GSO 384MB G92,Samsung T220P,Dell L100+MOC5UO
Ubuntu 9.04 x86_32 @ ext4 with English Local & Windows XP Professional 32bit.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译