当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求救,系统重启后raid失效!!
帖子发表于 : 2009-05-12 15:17 

注册: 2009-05-12 15:12
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
安装好系统后,做了raid1(没有在安装系统时做raid的)
系统装好后,使用mdadm创建raid1
在/dev/下有个md0块文件。
但我重启系统后,这个文件则没有了。。。。

root@ddns:~# ls -l /dev/md*
ls: cannot access /dev/md*: No such file or directory

恢复
root@ddns:~# mdadm -As
mdadm: /dev/md0 has been started with 2 drives.
mdadm: /dev/md1 has been started with 2 drives.
mdadm: /dev/md2 has been started with 2 drives.
mdadm: /dev/md3 has been started with 2 drives.
mdadm: /dev/md4 has been started with 2 drives.
mdadm: /dev/md5 has been started with 2 drives.
mdadm: /dev/md6 has been started with 2 drives.
mdadm: /dev/md7 has been started with 2 drives.
root@ddns:~# ls -l /dev/md*
brw-rw---- 1 root disk 9, 0 May 12 14:28 /dev/md0
brw-rw---- 1 root disk 9, 1 May 12 14:28 /dev/md1
brw-rw---- 1 root disk 9, 2 May 12 14:28 /dev/md2
brw-rw---- 1 root disk 9, 3 May 12 14:28 /dev/md3
brw-rw---- 1 root disk 9, 4 May 12 14:28 /dev/md4
brw-rw---- 1 root disk 9, 5 May 12 14:28 /dev/md5
brw-rw---- 1 root disk 9, 6 May 12 14:28 /dev/md6
brw-rw---- 1 root disk 9, 7 May 12 14:28 /dev/md7


为什么我重启系统后,我就找不到块设备的信息呢???


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求救,系统重启后raid失效!!
帖子发表于 : 2009-05-12 16:06 

注册: 2009-05-12 15:12
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我自己找到了。
原因:我使用的软raid使用的mdadm 命令是源码编译。
后来我使用
apt-get install mdadm

之后,重启系统,一切ok


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译