当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu服务器版和windows XP双系统启动问题
帖子发表于 : 2009-06-17 20:56 

注册: 2009-06-16 14:08
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
这两天闲来无事,下载了一个Ubuntu9.04服务器版打算练PHP。我用的是双硬盘双系统。一个是串口的40G硬盘装的是windows XP。另一个是并口的80G硬盘打算用来装Ubuntu服务器版。装Ubuntu的时候一切正常,能认出我已经装了另外一个系统。也正常的装上了GRUB。问题是重启后直接就进入GRUB>的命令提示符下,服务器版的root用户是默认禁用的,不知道如何设置了。 :em20


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu服务器版和windows XP双系统启动问题
帖子发表于 : 2009-06-17 21:49 
头像

注册: 2008-02-17 23:47
帖子: 22106
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 81
没有ERRO信息?
你怎么装的?怎么分区?
如果boot没有单独分区,就在grub提示符下输入
代码:
find /boot/grub/stage1

否则就用
代码:
find /grub/stage1

看看有什么显示

检查menu.lst有没有错。
另外太大的硬盘应该把/boot放在靠前的分区

有些主板,比如我的,IDE接口只有master可以引导系统,SATA也是只有1、2号接口可以引导
而且有一次我把原来的80pin接线换成40pin的,同样的连接方式,就是无法引导


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu服务器版和windows XP双系统启动问题
帖子发表于 : 2009-06-17 21:57 

注册: 2009-06-16 14:08
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
输入root(hd0,1)提示错误为Error 27: Unrecognized command
我用find /boot/grub/stage1
输出的是hd0,1
其他怎么做啊


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu服务器版和windows XP双系统启动问题
帖子发表于 : 2009-06-17 21:58 

注册: 2009-06-16 14:08
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
hd0装的是Ubuntu 而且hd0就分了一个ext3一个swap
hd1装的是XP


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu服务器版和windows XP双系统启动问题
帖子发表于 : 2009-06-19 19:52 

注册: 2007-09-18 8:45
帖子: 734
送出感谢: 1
接收感谢: 1
感觉你安装ubuntu的时候,xp的那个硬盘是hd0,ubuntu的硬盘是hd1。你重新启动后,好象两个硬盘在bios里的顺序倒过来了。

另外,root空格(hd0,1),注意格式的正确性


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译