当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 8:54 

注册: 2009-07-23 9:04
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
系统简介,我在移动硬盘上已经安装了 ubuntu9.0.4

测试五台电脑,发现有两台启动不成功,一台式机出现 Error 17,另外一台带有linux的机子,直接启动了硬盘上的linux,而没有从我的移动硬盘启动。。。

1。个人理解这两台启动不成功的原因,在于启动时,移动硬盘没有成为hd0,而是hd1,所以出现启动失败的问题,应该是BIOS设计的问题,不知道我这样理解对不对。。。希望达人给个解个疑?

2。如果是以上原因引起的,不知道是不是能在gurb时,让 gurb从 hd0,hd1这样轮着查询多硬盘,以达到启动正常 ,不知道我这个想法能不能成立,grub是不是有这样的功能和代码?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 9:12 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
第一种是不能正确挂载磁盘,不要用hd0, hd1,改用uuid试试
第三种应该是电脑不能识别移动盘的格式


_________________
Grub2 基础教程


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 11:10 

注册: 2009-07-23 9:04
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
smallapple 写道:
第一种是不能正确挂载磁盘,不要用hd0, hd1,改用uuid试试
第三种应该是电脑不能识别移动盘的格式


用的是ubuntu默认的设置,就是那个uuid!

两台机子在bios里都能发现移动硬盘的启动项,就是不能正确引导。。。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 11:16 
头像

注册: 2006-10-25 18:10
帖子: 2677
地址: 长沙
送出感谢: 0 次
接收感谢: 0 次
shao801119 写道:
smallapple 写道:
第一种是不能正确挂载磁盘,不要用hd0, hd1,改用uuid试试
第三种应该是电脑不能识别移动盘的格式


用的是ubuntu默认的设置,就是那个uuid!

两台机子在bios里都能发现移动硬盘的启动项,就是不能正确引导。。。

在启动时选择,而不是在 BIOS 里面设置。


_________________
你是自由的。别人也是。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 12:35 

注册: 2009-07-23 9:04
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
yiding_he 写道:
shao801119 写道:
smallapple 写道:
第一种是不能正确挂载磁盘,不要用hd0, hd1,改用uuid试试
第三种应该是电脑不能识别移动盘的格式


用的是ubuntu默认的设置,就是那个uuid!

两台机子在bios里都能发现移动硬盘的启动项,就是不能正确引导。。。

在启动时选择,而不是在 BIOS 里面设置。


有些BIOS里要对启动硬盘更改,才能看到移动硬盘的启动项。。。不能启动的那个台式机就是这样的BIOS,但是出现了error17,那证明能找到移动硬盘,不知道具体是什么原因。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 12:46 
头像

注册: 2006-02-25 17:09
帖子: 1606
地址: 西安
送出感谢: 23
接收感谢: 1
我的经历,在移动硬盘安装GNU/Linux时选择Grub安装在GNU/Linux分区(我的GNU/Linux安装在第一个分区)。
连接到其它电脑时,在BIOS中选择第一启动设备为移动设备。
到目前为此还没有出现过不能启动的状况。

记得在一台Sony的电脑上,不光要在BIOS中选择第一启动设备为移动设备,还要选择启用移动设备。


_________________
早起的鸟儿有虫吃
早起的虫儿被鸟吃

http://aerowolf.blog.sohu.com/
亲,点一下免费获得Dropbox空间!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 15:30 

注册: 2009-07-23 9:04
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
aerowolf 写道:
我的经历,在移动硬盘安装GNU/Linux时选择Grub安装在GNU/Linux分区(我的GNU/Linux安装在第一个分区)。
连接到其它电脑时,在BIOS中选择第一启动设备为移动设备。
到目前为此还没有出现过不能启动的状况。

记得在一台Sony的电脑上,不光要在BIOS中选择第一启动设备为移动设备,还要选择启用移动设备。


这个是什么选择,不是很明白,请达人给解释一下。。。

我ubuntu也是安装在第一个分区里。有些电脑能正常启动,有些不能,BIOS里也设置过。。有些机子选硬盘启动,然后选择移动硬盘。。。有些选USB-HDD模式启动,也有些直接就能选择移动硬盘启动。要看BIOS。。一般我是这样做的。。。

有些机子上还是不行,能认得到我的移动硬盘,但是就会出现在我在楼顶描述的那种情况。。。不知道具体是什么 原因引起的,是不是通过修改GRUB,才能兼容更多的机子。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 15:57 
头像

注册: 2006-02-25 17:09
帖子: 1606
地址: 西安
送出感谢: 23
接收感谢: 1
我移动硬盘上的Xubuntu自安装好之后,没有修改过grub。
这种现象的确存在:
引用:
记得在一台Sony的电脑上,不光要在BIOS中选择第一启动设备为移动设备,还要选择启用移动设备。


_________________
早起的鸟儿有虫吃
早起的虫儿被鸟吃

http://aerowolf.blog.sohu.com/
亲,点一下免费获得Dropbox空间!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 新手,关于移动硬盘启动的问题!!
帖子发表于 : 2009-07-26 22:49 

注册: 2009-07-23 9:04
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
aerowolf 写道:
我移动硬盘上的Xubuntu自安装好之后,没有修改过grub。
这种现象的确存在:
引用:
记得在一台Sony的电脑上,不光要在BIOS中选择第一启动设备为移动设备,还要选择启用移动设备。


下午开始搞 9.10的ubuntu了,准备用grub2试试,,,


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译