当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 重装XP后,Ubuntu启动问题,非grub问题
帖子发表于 : 2009-10-12 9:52 

注册: 2009-10-08 20:21
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我在网上和本网站搜索过。的确没我的情况介绍。才发一个帖子。请老鸟们帮助我。谢谢。

我不太了解grub是什么,是不是启动时候那个
1.window xp
2.Dos工具箱
3.Ubuntu 9.04

这样一个?这3个不是在boot.ini里面的么,这个应该是windows的启动吧。好像我家里的电脑启动是这样的,硬盘上安装的。

公司的不是,启动后是个菜单,好多选项,不完整记得如此:
Ubuntu 9.04 Normal...
.....
Other Operation System
WindowsXP

这样的界面是grub么?

如果第二个是grub,那我就是grub的问题。

但是我按网上所写的,用liveCD启动后,Alt+F2,输入gnome-terminal
grub update
root(hd1,0)
这里就返回一串英文了。我在win下发贴,原文不记得了。好像是 ..... Command ....之类的。提示命令有问题?
我有2块硬盘的,我按网上方法find也无法找到。说命令无法用。

请教一下,能不能谁写个脚本,或是程序,我在liveCD中,运行一下就恢复啊。

因为我按网上方法,恢复了grub后,就是那个下载了grub4dos-0.4.4,然后复制到根目录下,覆盖原来的文件,并添加了
c:\GRLDR=Grub
到boot.ini
文件。

启动后,有这一项了。进入后,没有检测到Linux哦。是不是我有2个硬盘,hd0启动,但是Linux装在hd1,所以无法检测呢?


可能说的有点多。是想尽可能的减少误解吧我的意思表达清楚。谁要是知道,请指点我一下。谢谢了!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 重装XP后,Ubuntu启动问题,非grub问题
帖子发表于 : 2009-10-12 11:51 

注册: 2009-10-08 20:21
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我重启看了内容为:
Unrecognized command


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 重装XP后,Ubuntu启动问题,非grub问题
帖子发表于 : 2009-10-14 14:00 

注册: 2009-10-08 20:21
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
自己解决了。
原来是root后面要写个空格。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译