xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
shenglan_fzu
帖子: 8
注册时间: 2009-08-27 2:02
送出感谢: 0
接收感谢: 0

xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#1

帖子 shenglan_fzu » 2010-02-06 2:54

Device Boot Start End Blocks Id System
/dev/sda1 * 1 1912 15358108+ 7 HPFS/NTFS
/dev/sda2 1913 14593 101860132+ f W95 Ext'd (LBA)
/dev/sda5 1913 5736 30716248+ 7 HPFS/NTFS
/dev/sda6 5737 9560 30716248+ 7 HPFS/NTFS
/dev/sda7 9561 13318 30186103+ 7 HPFS/NTFS
/dev/sda8 13319 13467 1196811 82 Linux swap / Solaris
/dev/sda9 13468 14593 9044563+ 83 Linux
xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动,
用xp光盘启动在Press any key to cd... 安任意键后(有先出现一排字,在其他电脑上一样)然后就进入黑屏,没有进入蓝屏(setup==)
请教高手,请给一个详细一点的解决办法
shenglan_fzu
帖子: 8
注册时间: 2009-08-27 2:02
送出感谢: 0
接收感谢: 0

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#2

帖子 shenglan_fzu » 2010-02-06 3:01

在第7部的时候,选高级里的sd1,以为是把引导文件建在C盘,可以从C盘启动,有帖子说在第7步时没选就不能启动xp
shenglan_fzu
帖子: 8
注册时间: 2009-08-27 2:02
送出感谢: 0
接收感谢: 0

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#3

帖子 shenglan_fzu » 2010-02-06 10:23

求助:还要提供什么信息吗?
shenglan_fzu
帖子: 8
注册时间: 2009-08-27 2:02
送出感谢: 0
接收感谢: 0

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#4

帖子 shenglan_fzu » 2010-02-06 10:35

用xp系统盘到Setup is inspecting your computer's hardware configuration...
就没反应了
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#5

帖子 smallapple » 2010-02-06 10:38

在第7部的时候,选高级里的sd1,以为是把引导文件建在C盘,可以从C盘启动,有帖子说在第7步时没选就不能启动xp
应该是 sda1 吧?把sda1 的引导扇区数据 破坏了。

先把grub装回mbr

代码: 全选

sudo grub
grub>find /boot/grub/stage1
没意外的话应该是 (hd0,8)
grub>root (hd0,8)
grub>setup (hd0)
grub>quit
exit
再尝试用grub4dos下面的 bootlace.com试试能否修改sda1的扇区数据,把 bootlace.com解压出来放在用户目录下

代码: 全选

sudo ./bootlace.com --floppy --ntfs /dev/sda1
再把 /sda1下的 ntldr 复制出来改名为grldr后再放回 /sda1 试试。
shenglan_fzu
帖子: 8
注册时间: 2009-08-27 2:02
送出感谢: 0
接收感谢: 0

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#6

帖子 shenglan_fzu » 2010-02-06 14:19

按上面的方法到exit这步显示以下内容,
grub> root (hd0,8)
grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/e2fs_stage1_5" exists... yes
Running "embed /boot/grub/e2fs_stage1_5 (hd0)"... 17 sectors are embedded.
succeeded
Running "install /boot/grub/stage1 (hd0) (hd0)1+17 p (hd0,8)/boot/grub/stage2
/boot/grub/menu.lst"... succeeded
Done.

grub> find /boot/grub/stage1
(hd0,8)

grub>
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#7

帖子 onshoestring » 2010-02-06 14:59

再尝试用grub4dos下面的 bootlace.com试试能否修改sda1的扇区数据,把 bootlace.com解压出来放在用户目录下
sudo ./bootlace.com --floppy --ntfs /dev/sda1
再把 /sda1下的 ntldr 复制出来改名为grldr后再放回 /sda1 试试。
上面你照做了么?
还要记得改menu.lst。
sudo /boot/grub/menu.lst。
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#8

帖子 onshoestring » 2010-02-06 14:59

再尝试用grub4dos下面的 bootlace.com试试能否修改sda1的扇区数据,把 bootlace.com解压出来放在用户目录下
sudo ./bootlace.com --floppy --ntfs /dev/sda1
再把 /sda1下的 ntldr 复制出来改名为grldr后再放回 /sda1 试试。
上面你照做了么?
还要记得改menu.lst。
sudo /boot/grub/menu.lst。
shenglan_fzu
帖子: 8
注册时间: 2009-08-27 2:02
送出感谢: 0
接收感谢: 0

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#9

帖子 shenglan_fzu » 2010-02-06 15:12

bootlace.com解压出来放在用户目录下
放不进去怎么办?
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#10

帖子 smallapple » 2010-02-06 18:32

shenglan_fzu 写了:bootlace.com解压出来放在用户目录下
放不进去怎么办?
你自己用户目录,怎么会放不进去?
放错地了吧?
你是怎么做的?
shenglan_fzu
帖子: 8
注册时间: 2009-08-27 2:02
送出感谢: 0
接收感谢: 0

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#11

帖子 shenglan_fzu » 2010-02-07 0:18

现在两个系统都进不了了,
try(fd0):invalid or null error:cannot find grldr in all drives.press ctr+alt。。。。。。。。
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: xp下装完9.04后不能找到c盘,不能进入xp,也不能用光驱启动

#12

帖子 onshoestring » 2010-02-07 0:32

shenglan_fzu 写了:现在两个系统都进不了了,
try(fd0):invalid or null error:cannot find grldr in all drives.press ctr+alt。。。。。。。。
这个现象是你把pbr改了,忘了改小苹果说的:
再把 /sda1下的 ntldr 复制出来改名为grldr后再放回 /sda1 试试。
找个winpe,进系统把小苹果说的做了,这样就能进win了。

如果ubuntu也进不去还说明你grub没装对地方,装到win分区的pbr了。
先把grub装回mbr
代码:
sudo grub
grub>find /boot/grub/stage1
没意外的话应该是 (hd0,8)
grub>root (hd0,8)
grub>setup (hd0)
grub>quit
exit
livecd修复grub1,把小苹果说的上面这段也照做。
回复

回到 “启动和引导”