一装上10.04,winxp就进入不了(紧急求助)

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
duduxia007
帖子: 7
注册时间: 2010-04-01 22:19
送出感谢: 0
接收感谢: 0

一装上10.04,winxp就进入不了(紧急求助)

#1

帖子 duduxia007 » 2010-05-05 6:28

那天在10.04刚放出来,就把9.10删了,重装了10.04
可是装上之后原来的XP就进入不了了。以前和9.10相处很好的啊。现在只能启动ubuntu,不能启动XP

引导之后,选择xp
然后就停在启动条那里不动了
再重启,就是一直提示 “缺少system32/hal.dll不能启动”
真是奇怪了

C盘boot.ini文件没问题,那个System32/hal.dll也并不缺少。


求达人指点迷津,我都折腾了一天了!555
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 一装上10.04,winxp就进入不了(紧急求助)

#2

帖子 smallapple » 2010-05-05 6:38

这个应该是 boot.ini 中的 Partition 号与实际分区对不上,再检查下boot.ini
duduxia007
帖子: 7
注册时间: 2010-04-01 22:19
送出感谢: 0
接收感谢: 0

Re: 一装上10.04,winxp就进入不了(紧急求助)

#3

帖子 duduxia007 » 2010-05-05 7:23

[boot loader]

timeout=2

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer

C:\Avldr.bin=Enter Ghost11

我的xp的确是装在第一分区啊 :
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-21-generic
Found initrd image: /boot/initrd.img-2.6.32-21-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
done

谢谢!
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 一装上10.04,winxp就进入不了(紧急求助)

#4

帖子 smallapple » 2010-05-05 7:36

sudo fdisk -l
看看活动主分区对不对
duduxia007
帖子: 7
注册时间: 2010-04-01 22:19
送出感谢: 0
接收感谢: 0

Re: 一装上10.04,winxp就进入不了(紧急求助)

#5

帖子 duduxia007 » 2010-05-05 7:55

smallapple 写了:sudo fdisk -l
看看活动主分区对不对
Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd72fd72f

Device Boot Start End Blocks Id System
/dev/sda1 * 1 1305 10482381 7 HPFS/NTFS
/dev/sda2 1306 3795 19999744 83 Linux
/dev/sda3 3796 14594 86736897 5 Extended
/dev/sda5 3796 4287 3951616 82 Linux swap / Solaris
/dev/sda6 4288 14594 82784256 83 Linux

这个有什么异常么?
duduxia007
帖子: 7
注册时间: 2010-04-01 22:19
送出感谢: 0
接收感谢: 0

Re: 一装上10.04,winxp就进入不了(紧急求助)

#6

帖子 duduxia007 » 2010-05-05 7:59

smallapple, 神勇广大的小苹果,告诉我是怎么一回事事吧。谢谢
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 一装上10.04,winxp就进入不了(紧急求助)

#7

帖子 smallapple » 2010-05-05 8:16

奇怪,没问题。
选 winxp 马上按 F8看安全模式能进不?或者把 grub.cfg 上的那个xp菜单下的 search --fs-uuid ..... 和 drivemap ....这两句注释掉试试
duduxia007
帖子: 7
注册时间: 2010-04-01 22:19
送出感谢: 0
接收感谢: 0

Re: 一装上10.04,winxp就进入不了(紧急求助)

#8

帖子 duduxia007 » 2010-05-05 8:42

smallapple 写了:奇怪,没问题。
选 winxp 马上按 F8看安全模式能进不?或者把 grub.cfg 上的那个xp菜单下的 search --fs-uuid ..... 和 drivemap ....这两句注释掉试试
还是没用,真伤心。

就是到了xp启动条那里,就不读硬盘了。

为此我曾把xp与ubuntu都先后重装了一遍
不装ubuntu时,xp正常启动
一装上ubuntu,就出这个毛病

郁闷啊~~~~
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 一装上10.04,winxp就进入不了(紧急求助)

#9

帖子 smallapple » 2010-05-05 8:48

在现在基础上重装 xp,不要重装ubuntu,安装xp后用grub4dos引导 ubuntu试试,估计是xp不认grub的mbr。
头像
becklong
帖子: 6
注册时间: 2009-11-13 10:13
送出感谢: 0
接收感谢: 0

Re: 一装上10.04,winxp就进入不了(紧急求助)

#10

帖子 becklong » 2010-05-05 10:49

我现在一进xp机箱就报警。
回复

回到 “启动和引导”