Grub2损坏

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
tempestglen
帖子: 137
注册时间: 2009-07-16 23:09
送出感谢: 0
接收感谢: 0

Grub2损坏

#1

帖子 tempestglen » 2010-05-10 11:48

之前是9.04和xp共存,今天全新安装10.04(Amd64),安装过程中格式化除了/home的所有其他ubuntu分区,完成之后进入10.04没问题,运行了 sudo update-grub,重启,grub菜单显示10.04和xp,进入xp没问题,可是从xp退出来(重启或关机),电脑完成bios自检后,就不停的自检, 貌似是grub坏了,我今天重装了2次 10.04,都是这样,要命啊。

安装10.04的时候,usb接口连接手机和无线上网卡,过程中有一次手机都被搞重启了。
zjlwg
帖子: 50
注册时间: 2009-02-28 18:04
送出感谢: 0
接收感谢: 0

Re: Grub2损坏

#2

帖子 zjlwg » 2010-05-10 14:12

没看明白,bios不停自检那是主板的事情,还没到硬盘那步,关grub2啥事?估计你插的设备太多引起的吧.
头像
黄美姬
论坛版主
帖子: 8428
注册时间: 2009-10-08 11:15
来自: 大城市铁岭
送出感谢: 0
接收感谢: 1 次

Re: Grub2损坏

#3

帖子 黄美姬 » 2010-05-10 14:16

grub装到手机上了 :em04 :em04
用livecd修复grub
我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal- ... ts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal- ... tx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/
tempestglen
帖子: 137
注册时间: 2009-07-16 23:09
送出感谢: 0
接收感谢: 0

Re: Grub2损坏

#4

帖子 tempestglen » 2010-05-10 15:38

黄美姬 写了:grub装到手机上了 :em04 :em04
用livecd修复grub
:em20
tempestglen
帖子: 137
注册时间: 2009-07-16 23:09
送出感谢: 0
接收感谢: 0

Re: Grub2损坏

#5

帖子 tempestglen » 2010-05-10 17:44

zjlwg 写了:没看明白,bios不停自检那是主板的事情,还没到硬盘那步,关grub2啥事?估计你插的设备太多引起的吧.
就是grub2的事情 .因为cpu 内存,硬盘全都自检通过了 ,就 等grub2的界面出现,可 是迟迟不出现 ,于是电脑又回去自检.

现在 的情况 是可以反复使用 10.04,grub2工作也正常 ,可是一旦进入windows, 再从 windows退出来重起 ,grub2就完蛋了 ,只好 用 livecd修复 grub2,可是 再一次进入windows再退出 ,grub2又完蛋了 ,

从网上 都是搜到 grub的用法,而 grub2的资料 比教少 ,例如在 livecd里 ,输入sudo grub.提示sudo: grub: command not found

是不是grub没有 安 装 而 安装 了 grub2 啊.

现在真是后悔安10.04 在单位,难到以后 每天 开机想进 windows工作就必需用 livecd修复 一下 grub2? 疯了 啊

分区如下 ."*"符号应在 sda1(windows C:)还是 sda8(/boot)?

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf9fff9ff

Device Boot Start End Blocks Id System
/dev/sda1 * 1 3825 30724281 c W95 FAT32 (LBA)
/dev/sda2 3826 38914 281845513 f W95 Ext'd (LBA)
/dev/sda5 3826 14831 88405663+ 7 HPFS/NTFS
/dev/sda6 14832 25837 88405663+ 7 HPFS/NTFS
/dev/sda7 25838 29485 29296640 83 Linux
/dev/sda8 29485 29516 248832 83 Linux
/dev/sda9 29516 34379 39061504 83 Linux
/dev/sda10 34379 36810 19529728 83 Linux
/dev/sda11 36811 38269 11717632 83 Linux
/dev/sda12 38269 38914 5174272 82 Linux swap / Solaris
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

Re: Grub2损坏

#6

帖子 ptptptptptpt » 2010-05-10 18:07

tempestglen 写了:可是从xp退出来(重启或关机),电脑完成bios自检后,就不停的自检, 貌似是grub坏了,
拍个照片传上来吧
zjlwg
帖子: 50
注册时间: 2009-02-28 18:04
送出感谢: 0
接收感谢: 0

Re: Grub2损坏

#7

帖子 zjlwg » 2010-05-12 9:00

难道是sda1分区是fat32的原因,都nt内核了还在用9x内核的文件系统啊.试下转换到ntfs看看.
tempestglen
帖子: 137
注册时间: 2009-07-16 23:09
送出感谢: 0
接收感谢: 0

Re: Grub2损坏

#8

帖子 tempestglen » 2010-05-22 21:03

zjlwg 写了:难道是sda1分区是fat32的原因,都nt内核了还在用9x内核的文件系统啊.试下转换到ntfs看看.
多谢,我会去尝试一下。

现在我用mbrfix命令修复了引导区,然后使用grub for dos,双系统成功了,不用grub2了。
cliff-david
帖子: 45
注册时间: 2008-02-23 23:53
送出感谢: 0
接收感谢: 0
联系:

Re: Grub2损坏

#9

帖子 cliff-david » 2010-06-06 14:39

回复

回到 “启动和引导”