当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 【双硬盘】【引导单独分区】依照帖子修复grub引导后无法进入,依旧求助
帖子发表于 : 2010-05-15 0:04 
头像

注册: 2008-11-22 12:19
帖子: 145
送出感谢: 1
接收感谢: 0 次
独立安装的ubuntu 不是wubi,有两块硬盘,引导独立分区,WIN7。
我用的是 http://forum.ubuntu.org.cn/viewtopic.php?f=139&t=246275 的方法安装grub
结果出现了 http://forum.ubuntu.org.cn/viewtopic.php?f=139&t=239870 的问题:
(直接复制过来的,版本号不一样)
代码:
GUN GRUB version 1.97~beta4

[Minimal BASH-like line editing is suported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device/file completions.]

sh:grub >


估计主要是我没用wubi,这是不是wubi专用的方法?还有就是引导单独分区,以及两块硬盘,ubuntu在第二块
-------------------------------
现在用了4L的方法
代码:
set root=(hd1)
search -f /boot/grub/core.img
set root=(hdxx) ------------上面的返回值
linux /boot/grub/core.img
boot

引导
search的返回值有两个,(1,5)(1,7)一个是引导分区一个是主分区。
不管用哪一个用了

代码:
linux /boot/grub/core.img

以后
都显示:“cannot get C/H/S values”
替换成
代码:
linux /grub/core.img

也不行
谢谢


PS:wiki里面的内容要更新了吧


最后由 tioover 编辑于 2010-05-28 22:59,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 修复grub引导后无法进入。求助
帖子发表于 : 2010-05-15 0:35 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
你安装的是老版本吧。。。新版本的Ubuntu1004LTS用的是Grub1.98,另外那个hd的X,Y值,要根据你的/分区的具体值代入的啊。。。 :em09
viewtopic.php?f=139&t=225669&p=1448778#p1448778#苹果法师smallapple的哥伦布2代经典基础教程和故障修复,有PDF教程可下载。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 修复grub引导后无法进入。求助
帖子发表于 : 2010-05-15 10:36 
头像

注册: 2008-11-22 12:19
帖子: 145
送出感谢: 1
接收感谢: 0 次
啊不,我用的就是新版本,为了方便直接copy过来的…………
那个XY我的确代入的


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 修复grub引导后无法进入。求助
帖子发表于 : 2010-05-15 11:52 
头像

注册: 2009-09-06 5:53
帖子: 4666
送出感谢: 6
接收感谢: 110
代码:
set root=(hd1)
search -f /boot/grub/core.img
set root=(hdxx) ------------上面的返回值
linux /boot/grub/core.img
boot

ctrl+x

我自己不是双硬盘,不知道这样行不行,你试试。


_________________
电子书下载:
鸟哥的Linux私房菜 基础学习篇 第三版 pdf
鸟哥的Linux私房菜 服务器架设篇 第三版 pdf


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 修复grub引导后无法进入,依旧求助
帖子发表于 : 2010-05-28 22:54 
头像

注册: 2008-11-22 12:19
帖子: 145
送出感谢: 1
接收感谢: 0 次
搜索的返回值有两个,
不管用哪一个用了
代码:
linux /boot/grub/core.img
以后
都显示:“cannot get C/H/S values”


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译