当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 启动菜单没有了,请问如何设置启动菜单?
帖子发表于 : 2010-05-15 8:01 

注册: 2010-05-15 7:54
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
有两块硬盘,硬盘 0 上安装了一直使用的 Windows,拔掉 0 的电源线后,在硬盘 1 上安装了 LinuxMint 8,重新接上 0 的电源,启动后发现自动创建了 Grub 引导菜单,里面包含 Windows 启动项,就这么用了一阵。

后来在没有拔掉硬盘 0 电源的情况下,通过 Live 版桌面上的 Install Linux Mint 9 安装了一次,再重启就无法引导到任何系统了。

回忆之前的做法,重新在硬盘 0 断开的情况下,安装 Linux Mint,启动后有提示,选择修复,之后自动重启,也只能进入到 Linux 里面,无法找到 Windows 的启动项。(在没断开硬盘 0 的时候,安装 Linux Mint 的时候,是能认出上面 Windows 系统的)

请问应该如何操作,可以建立一个启动菜单,选择从那个系统启动?或者告诉一下搜索的时候应该搜索什么关键字,谢谢。

补充

在终端里面运行这个命令,
代码:
sudo update-grub

引导菜单出来了,里面有 Windows 的选项,可是选择的时候引导不起来。

于是我再次重启,在 Windows 被选择时按 e,引导的位置是正确的,这个是不是说明对应 Windows 所在硬盘 0 的引导彻底坏了?

我把安装有 Linux 的硬盘 1 断开,用 Windows 光盘引导,发现引导不起来,提示 grub 找不到设备:XXXXXX-XXXXX-XXXXXX

现在想在单独的那块硬盘上安装都不能,请问如何解决?

结贴
1. 光盘也引导不起来的问题,实在是个低级错误……CMOS 里面把光驱禁用了,由于在 LinuxMint 里面能挂载上光驱,所以一直没有意识到这个问题。
2. Windows 引导记录没有,通过 DiskGen 重新激活主分区,之后修复 MBR,解决。


最后由 runningwaterpro 编辑于 2010-05-15 23:51,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 启动菜单没有了,请问如何设置启动菜单?
帖子发表于 : 2010-05-15 10:25 

注册: 2006-11-08 16:33
帖子: 286
送出感谢: 0 次
接收感谢: 0 次
关键字里要有grub2

试试sudo update-grub2


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 启动菜单没有了,请问如何设置启动菜单?
帖子发表于 : 2010-05-15 15:27 

注册: 2010-05-15 7:54
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
changys04 写道:
关键字里要有grub2

试试sudo update-grub2


谢谢,在终端里面运行这个命令,
代码:
sudo update-grub

引导菜单出来了,里面有 Windows 的选项,可是选择的时候引导不起来。

于是我再次重启,在 Windows 被选择时按 e,引导的位置是正确的,这个是不是说明对应 Windows 所在硬盘 0 的引导彻底坏了?

我把安装有 Linux 的硬盘 1 断开,用 Windows 光盘引导,发现引导不起来,提示 grub 找不到设备:XXXXXX-XXXXX-XXXXXX

现在想在单独的那块硬盘上安装都不能,请问如何解决?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 启动菜单没有了,请问如何设置启动菜单?
帖子发表于 : 2010-05-15 23:14 

注册: 2006-11-08 16:33
帖子: 286
送出感谢: 0 次
接收感谢: 0 次
我没有双硬盘的经验...

你确定引导的位置是正确的?你的grub.cfg文件内容是什么?

”现在想在单独的那块硬盘上安装都不能,请问如何解决?“你想在哪块硬盘安装什么?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 启动菜单没有了,请问如何设置启动菜单?
帖子发表于 : 2010-05-15 23:49 

注册: 2010-05-15 7:54
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
谢谢二位的帮助,问题解决了。

1. 光盘也引导不起来的问题,实在是个低级错误……CMOS 里面把光驱禁用了,由于在 LinuxMint 里面能挂载上光驱,所以一直没有意识到这个问题。
2. Windows 引导记录没有,通过 DiskGen 重新激活主分区,之后修复 MBR,解决。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译