当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问为什么我的grub2就是找不到xp的启动项呢?
帖子发表于 : 2010-07-15 9:35 
头像

注册: 2008-09-07 14:47
帖子: 194
送出感谢: 0 次
接收感谢: 0 次
用sudo grub-mkconfig -o /boot/grub/grub.cfg命令后返回的结果:
代码:
graham@Gan-UBT:~$ sudo grub-mkconfig -o /boot/grub/grub.cfg
Generating grub.cfg ...
Found background image: Wallpaper.png
Found linux image: /boot/vmlinuz-2.6.32-23-generic
Found initrd image: /boot/initrd.img-2.6.32-23-generic
Found linux image: /boot/vmlinuz-2.6.32-22-generic
Found initrd image: /boot/initrd.img-2.6.32-22-generic
Found memtest86+ image: /boot/memtest86+.bin
ERROR: pdc: wrong # of devices in RAID set "pdc_cjheccejee" [1/2] on /dev/sda
ERROR: pdc: wrong # of devices in RAID set "pdc_cjheccejee" [1/2] on /dev/sda
done

请问这两个ERROR是什么引起的?要怎么解决?
顺便贴上分区情况:
代码:
graham@Gan-UBT:~$ df -lh
文件系统            容量  已用 可用 已用% 挂载点
/dev/sda8             9.2G  4.5G  4.3G  52% /
none                 1003M  280K 1002M   1% /dev
none                 1007M  196K 1007M   1% /dev/shm
none                 1007M  332K 1007M   1% /var/run
none                 1007M     0 1007M   0% /var/lock
none                 1007M     0 1007M   0% /lib/init/rw
/dev/sda1              21G   17G  3.3G  84% /media/[C]
/dev/sda5              31G   28G  2.2G  93% /media/[D]
/dev/sda6              36G   31G  4.7G  87% /media/[E]
/dev/sda7              45G   34G   11G  77% /media/[F]
/dev/sda10            9.2G  515M  8.2G   6% /home

graham@Gan-UBT:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x51035103

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        2611    20972826    7  HPFS/NTFS
/dev/sda2            2612       19458   135317160    f  W95 Ext'd (LBA)
/dev/sda5            2612        6528    31463271    7  HPFS/NTFS
/dev/sda6            6529       11097    36700461    7  HPFS/NTFS
/dev/sda7           11098       16846    46178811    7  HPFS/NTFS
/dev/sda8           16847       18062     9764864   83  Linux
/dev/sda9           18062       18245     1464320   82  Linux swap / Solaris
/dev/sda10          18245       19458     9742336   83  Linux

graham@Gan-UBT:~$ sudo fdisk -lu

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x51035103

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63    41945714    20972826    7  HPFS/NTFS
/dev/sda2        41945776   312580095   135317160    f  W95 Ext'd (LBA)
/dev/sda5        41945778   104872319    31463271    7  HPFS/NTFS
/dev/sda6       104872383   178273304    36700461    7  HPFS/NTFS
/dev/sda7       178273368   270630989    46178811    7  HPFS/NTFS
/dev/sda8       270632960   290162687     9764864   83  Linux
/dev/sda9       290164736   293093375     1464320   82  Linux swap / Solaris
/dev/sda10      293095424   312580095     9742336   83  Linux


_________________
卸载未使用的内核——sudo aptitude purge ~ilinux-image-.*\(\!`uname -r`\)
型号:联想Y450A-TSI(E)白色
处理器: Core 2 Duo T6600 2.2GHz
内存:DDR III 4G
硬盘:WD 320G
显卡:GeForce GT 240M
显示器:14' LED 1366x768


最后由 grahamgan 编辑于 2010-07-15 9:43,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请问为什么我的grub2就是找不到xp的启动项呢?
帖子发表于 : 2010-07-15 9:37 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
传说中的raid?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请问为什么我的grub2就是找不到xp的启动项呢?
帖子发表于 : 2010-07-15 9:42 
头像

注册: 2008-09-07 14:47
帖子: 194
送出感谢: 0 次
接收感谢: 0 次
可我电脑里根本没做RAID啊…… :em06


_________________
卸载未使用的内核——sudo aptitude purge ~ilinux-image-.*\(\!`uname -r`\)
型号:联想Y450A-TSI(E)白色
处理器: Core 2 Duo T6600 2.2GHz
内存:DDR III 4G
硬盘:WD 320G
显卡:GeForce GT 240M
显示器:14' LED 1366x768


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请问为什么我的grub2就是找不到xp的启动项呢?
帖子发表于 : 2010-07-16 22:19 

注册: 2010-07-14 19:37
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
sudo whereis gaoshou


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译