求助新机器安装不了10.10了

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
jjlydnsjg
帖子: 31
注册时间: 2008-10-26 17:35
送出感谢: 0
接收感谢: 0

求助新机器安装不了10.10了

#1

帖子 jjlydnsjg » 2010-11-02 21:25

好久没玩了,,现在看到有10。10版出来手头刚好有台机器,想全新安装。以前好多次在硬盘上直接安装过ubuntu系统。
可这次怎么装都不行。可能都忘了。。。大家来帮帮我。。。

现在是这样的硬盘分为三个区, 10。10考在了最后一个分区。。。。

三个区全是NTFS的。。。我按照

这样做将 grldr , grldr.mbr , grub.exe 三个文件复制到 C 盘根目录下 ,找到 vmlinuz 、 initrd.lz 复制到 C 盘
并且编了下menu.lst 文件,内容为:
title Install Ubuntu
root (hd0,5)
kernel (hd0,5)/vmlinuz boot=casper iso-scan/filename=/ubuntu-10.10-dvd-i386 ro quiet splash locale=zh_CN.UTF-8
initrd (hd0,5)/initrd.lz

新建一个boot.ini 。 内容如下:

[boot loader]
[operating systems]
c:\grldr.mbr="ubuntu"


重启后提示 NTLDR is missing
请大家帮帮忙倒底问题出在了哪里。。。???
一江东水向东流,时间一去不在有.
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 求助新机器安装不了10.10了

#2

帖子 onshoestring » 2010-11-02 21:49

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
如果硬盘是xp,那boot.ini有问题。
jjlydnsjg
帖子: 31
注册时间: 2008-10-26 17:35
送出感谢: 0
接收感谢: 0

Re: 求助新机器安装不了10.10了

#3

帖子 jjlydnsjg » 2010-11-03 10:39

我晕啊。。。是新安装啊。。。
硬盘里没有任何系统的。。。直接用ISO安装。。。
一江东水向东流,时间一去不在有.
shmily623
帖子: 64
注册时间: 2009-07-02 19:11
送出感谢: 0
接收感谢: 0

Re: 求助新机器安装不了10.10了

#4

帖子 shmily623 » 2010-11-03 11:01

menu.lst有问题,vmlinuz 、 initrd.lz在C盘,应该把hd0,5改成hd0,0
ohyeahfine
帖子: 2
注册时间: 2010-10-21 16:05
送出感谢: 0
接收感谢: 0

Re: 求助新机器安装不了10.10了

#5

帖子 ohyeahfine » 2010-11-03 11:05

搞了个笔记本不敢乱玩。。。郁闷
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 求助新机器安装不了10.10了

#6

帖子 onshoestring » 2010-11-03 11:33

全新安装用光盘或u盘安装方便。
mbr-pbr-ntldr(boot.ini),没有win,没办法用boot.ini方法安装。
可以把grub4dos写入mbr(bootlace,grubinst),在c盘放grldr,menu.lst试试。
全新安装全用ntfs分区是什么意思也搞不懂。
回复

回到 “启动和引导”