HDMI audio问题

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
forbelieve
帖子: 9
注册时间: 2010-09-29 9:25
送出感谢: 0
接收感谢: 0

HDMI audio问题

#1

帖子 forbelieve » 2010-11-15 9:45

求助:我有一台 Intel D525+NM10+NVIDIA GT218 的上网本,板载 USB声卡,目前安装 Ubuntu10.10 ,发现USB声卡在播放音乐时有输出,但HDMI audio无声音输出,后来通过安装NVIDIA 驱动,在Teminal下面使用 mplayer -ao alsa:device=hw=0.7 x.mp3 ,这个方式命令能在HDMI audio听到声音了,使用其它播放器播放音乐,HDMI 又没有声音输出,不知道该怎样设置将HDMI audio设置成默认的声音输出通道。
希望有高人指点!

谢谢!
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: HDMI audio问题

#2

帖子 leeaman » 2010-11-15 9:47

板载USB声卡?
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
forbelieve
帖子: 9
注册时间: 2010-09-29 9:25
送出感谢: 0
接收感谢: 0

Re: HDMI audio问题

#3

帖子 forbelieve » 2010-11-15 10:40

有没有哪位高手弄过这个问题啊,弄了几天都没有弄出来啊。急啊~~~!
ryoohki
帖子: 3249
注册时间: 2008-10-28 20:18
送出感谢: 0
接收感谢: 0

Re: HDMI audio问题

#4

帖子 ryoohki » 2010-11-15 11:10

其它播放器中的设置中把音频输出设备也改成 alsa:device=hw=0.7
forbelieve
帖子: 9
注册时间: 2010-09-29 9:25
送出感谢: 0
接收感谢: 0

Re: HDMI audio问题

#5

帖子 forbelieve » 2010-11-15 13:36

系统自带的播放器都无法设置成,alsa:device=hw=0.7,网上这方面的资料太少了,都 没有一个好的解决方法,哎。。。。!
forbelieve
帖子: 9
注册时间: 2010-09-29 9:25
送出感谢: 0
接收感谢: 0

Re: HDMI audio问题

#6

帖子 forbelieve » 2010-11-15 13:40

在网上有搜集到修改一些配置文件,如通过以下方式修改 .asoundrc这个文件将默认的音频输出通道设置成hdmi audio,但实际测试以后仍然是不能实现:Modify your ~/.asoundrc
pcm.dmixer {
type dmix
ipc_key 1024
ipc_key_add_uid false
ipc_perm 0660
slave {
pcm "hw:0,7"
rate 48000
channels 2
period_time 0
period_size 1024
buffer_time 0
buffer_size 4096
}
}
pcm.!default {
type plug
slave.pcm "dmixer"
}


盼高人指点啊!
forbelieve
帖子: 9
注册时间: 2010-09-29 9:25
送出感谢: 0
接收感谢: 0

Re: HDMI audio问题

#7

帖子 forbelieve » 2010-11-19 8:53

有没有哪位高手会弄啊?
ryoohki
帖子: 3249
注册时间: 2008-10-28 20:18
送出感谢: 0
接收感谢: 0

Re: HDMI audio问题

#8

帖子 ryoohki » 2010-11-20 1:57

Screenshot.png
Screenshot-多媒体系统选择器.png
回复

回到 “启动和引导”