grub没有写入mbr,启动项中没有debian

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
头像
aqlinf
帖子: 295
注册时间: 2009-10-09 16:21
送出感谢: 0
接收感谢: 0

grub没有写入mbr,启动项中没有debian

#1

帖子 aqlinf » 2010-12-12 5:13

我在安装debian时选择不将grub写入mbr中,而是写入(hd0,6),也就是debian的安装目录,结果重启后只有xp的选项,没有debian,难道不写入mbr就不能启动吗?求解。
头像
我就是我2
帖子: 1215
注册时间: 2008-12-13 10:55
来自: the Earth
送出感谢: 1 次
接收感谢: 3 次
联系:

Re: grub没有写入mbr,启动项中没有debian

#2

帖子 我就是我2 » 2010-12-12 7:20

也不是。mbr没写入的话就没覆盖原来的mbr
那么grub就用不了。可以通过grub4dos来启动debian.
苏东坡问佛印道:“人人皆念观世音菩萨,观世音菩萨念谁?”
佛印答道:“念观世音菩萨。”
苏东坡诧异:“为何亦念观世音菩萨?”
曰:“求人不如求己。”


dropbox 誰好奇,誰來點
勞碌一生又如何,虛度一生又如何,你過得開心嗎?人活著就要開心嘛!
头像
aqlinf
帖子: 295
注册时间: 2009-10-09 16:21
送出感谢: 0
接收感谢: 0

Re: grub没有写入mbr,启动项中没有debian

#3

帖子 aqlinf » 2010-12-12 9:32

我就是我2 写了:也不是。mbr没写入的话就没覆盖原来的mbr
那么grub就用不了。可以通过grub4dos来启动debian.
我用grub4dos启动,结果进了busybox。

代码: 全选

title debian
root(hd0,6)
kernel (hd0,6)/vmlinuz clock=pit nosmp noapic nolapic
initrd (hd0,6)/initrd.img 
boot
132811
帖子: 194
注册时间: 2010-04-20 21:19
系统: ArchLinux
来自: My gtalk:a132811@
送出感谢: 3 次
接收感谢: 1 次
联系:

Re: grub没有写入mbr,启动项中没有debian

#4

帖子 132811 » 2010-12-12 14:47

代码: 全选

title debian
root(hd0,6)
kernel (hd0,6)/vmlinuz root=/dev/sda7 clock=pit nosmp noapic nolapic #你应该加入root吧?
initrd (hd0,6)/initrd.img 
boot
看样子你的BOOT是单独分的区??
也可以试试这个:

代码: 全选

title /grub/core.img
root (hd0,6) #改成你的boot分区
kernel /grub/core.img

title locate your core.img
find --set-root /grub/core.img #相当于grub2 中的search --set -f /grub/core.img
kernel /grub/core.img
http://hilojack.sinaapp.com
i3 M370(2.4G)/500G/8G/OpenGL:Gallium 0.4 on nvidia 3100M
头像
aqlinf
帖子: 295
注册时间: 2009-10-09 16:21
送出感谢: 0
接收感谢: 0

Re: grub没有写入mbr,启动项中没有debian

#5

帖子 aqlinf » 2010-12-12 14:52

132811 写了:

代码: 全选

title debian
root(hd0,6)
kernel (hd0,6)/vmlinuz root=/dev/sda7 clock=pit nosmp noapic nolapic #你应该加入root吧?
initrd (hd0,6)/initrd.img 
boot
看样子你的BOOT是单独分的区??
也可以试试这个:

代码: 全选

title /grub/core.img
root (hd0,6) #改成你的boot分区
kernel /grub/core.img

title locate your core.img
find --set-root /grub/core.img #相当于grub2 中的search --set -f /grub/core.img
kernel /grub/core.img

多谢,也许这个真可以
头像
aqlinf
帖子: 295
注册时间: 2009-10-09 16:21
送出感谢: 0
接收感谢: 0

Re: grub没有写入mbr,启动项中没有debian

#6

帖子 aqlinf » 2010-12-12 19:00

安装test版的debian,不需要noapic,安装一切正常,只是无法正常启动,进入busybox,显示:

代码: 全选

BusyBox v1.17.1(Debian 1:1.17.1-8) built-in shell(ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off 
(initramfs)
头像
aqlinf
帖子: 295
注册时间: 2009-10-09 16:21
送出感谢: 0
接收感谢: 0

Re: grub没有写入mbr,启动项中没有debian

#7

帖子 aqlinf » 2010-12-12 19:02

132811 写了:

代码: 全选

title debian
root(hd0,6)
kernel (hd0,6)/vmlinuz root=/dev/sda7 clock=pit nosmp noapic nolapic #你应该加入root吧?
initrd (hd0,6)/initrd.img 
boot
看样子你的BOOT是单独分的区??
也可以试试这个:

代码: 全选

title /grub/core.img
root (hd0,6) #改成你的boot分区
kernel /grub/core.img

title locate your core.img
find --set-root /grub/core.img #相当于grub2 中的search --set -f /grub/core.img
kernel /grub/core.img

我修改了下,在grub4dos下这样引导:

代码: 全选

root (hd0,6)  -->/boot分区
kernel /vmlinuz-2.6.32-5-686
initrd /initrd.img-2.6.32-5-686
boot
引导正常,就是进入busybox了。
头像
aqlinf
帖子: 295
注册时间: 2009-10-09 16:21
送出感谢: 0
接收感谢: 0

Re: grub没有写入mbr,启动项中没有debian

#8

帖子 aqlinf » 2010-12-12 19:12

132811 写了:

代码: 全选

title debian
root(hd0,6)
kernel (hd0,6)/vmlinuz root=/dev/sda7 clock=pit nosmp noapic nolapic #你应该加入root吧?
initrd (hd0,6)/initrd.img 
boot
看样子你的BOOT是单独分的区??
也可以试试这个:

代码: 全选

title /grub/core.img
root (hd0,6) #改成你的boot分区
kernel /grub/core.img

title locate your core.img
find --set-root /grub/core.img #相当于grub2 中的search --set -f /grub/core.img
kernel /grub/core.img

多亏你这段代码,grub成功引导,成功进入系统,看来我那样引导是不行的。人生总是在你绝望之际突然惊喜 :em11
seapsy
帖子: 11
注册时间: 2007-09-20 10:02
送出感谢: 0
接收感谢: 0

Re: grub没有写入mbr,启动项中没有debian

#9

帖子 seapsy » 2012-02-29 20:38

132811 写了:

代码: 全选

title debian
[code]title /grub/core.img
root (hd0,6) #改成你的boot分区
kernel /grub/core.img

title locate your core.img
find --set-root /grub/core.img #相当于grub2 中的search --set -f /grub/core.img
kernel /grub/core.img
使用这个代码,成功进入到了debian
非常感谢
顺便说一下,我的是在WIN下硬盘安装debian6,不写入MBR
其中BOOT装在sda7,即(hd0,6),GRUB也是安排在这里,
回复

回到 “启动和引导”