windows 7和ubuntu双系统引导问题

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
回复
accessun
帖子: 20
注册时间: 2011-02-24 1:22
送出感谢: 0
接收感谢: 0

windows 7和ubuntu双系统引导问题

#1

帖子 accessun » 2011-03-15 12:20

windows 7和ubuntu双系统引导悲剧地出问题了。
开机后出现
“no module name found
Aborted. Press any key to exit.”
然后随便按了一个键后出现
“Reboot and select proper device
or insert boot media in selected boot device and press a key.”
之后再按键就又重复上面的语句了。。。

我用ubuntu的dvd修复了grub,
grub的菜单正常地出现了,
进入ubuntu,再重启,发现没有问题了,
但是每次进入windows再重启就又出现问题了,
我猜是每次windows启动后破坏了grub的文件,
怎么办呀?望高手解决。。。
头像
月下叹逍遥
论坛版主
帖子: 33994
注册时间: 2010-10-07 14:23
系统: Archdows10
来自: 某系某星某洲某国某省某市
送出感谢: 8 次
接收感谢: 63 次
联系:

Re: windows 7和ubuntu双系统引导问题

#2

帖子 月下叹逍遥 » 2011-03-15 12:24

进入Ubuntu升级过Grub吗?
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙
accessun
帖子: 20
注册时间: 2011-02-24 1:22
送出感谢: 0
接收感谢: 0

Re: windows 7和ubuntu双系统引导问题

#3

帖子 accessun » 2011-03-15 12:50

月下叹逍遥 写了:进入Ubuntu升级过Grub吗?
升级过。。。
oohyoou
帖子: 51
注册时间: 2010-05-27 17:01
送出感谢: 0
接收感谢: 0

Re: windows 7和ubuntu双系统引导问题

#4

帖子 oohyoou » 2011-03-15 12:57

wubi装的?
头像
月下叹逍遥
论坛版主
帖子: 33994
注册时间: 2010-10-07 14:23
系统: Archdows10
来自: 某系某星某洲某国某省某市
送出感谢: 8 次
接收感谢: 63 次
联系:

Re: windows 7和ubuntu双系统引导问题

#5

帖子 月下叹逍遥 » 2011-03-15 12:59

等熊大出面解释……
心似浮云常自在,意如流水任东西。
此事背后一定有个天大的咪咪
广告:
1、走过路过,不要错过,dropbox网盘2.25G大放送
py大法好,退C保平安
java多妖孽,VB本异端
日诵一千遍,快活似神仙
accessun
帖子: 20
注册时间: 2011-02-24 1:22
送出感谢: 0
接收感谢: 0

Re: windows 7和ubuntu双系统引导问题

#6

帖子 accessun » 2011-03-15 13:06

oohyoou 写了:wubi装的?
不是用wubi装的,是在windows下手动划出的分区上安装的。。。
billbear
帖子: 3681
注册时间: 2008-05-03 23:42
送出感谢: 0
接收感谢: 3 次

Re: windows 7和ubuntu双系统引导问题

#7

帖子 billbear » 2011-03-18 12:45

如果每次进windows后grub就被破坏,基本上windows里有某些坏家伙.
Colin 正在搜集这些坏家伙的名单,你可以上报你的样本:
http://www.chiark.greenend.org.uk/ucgi/ ... table.html
目前多数情况是adobe干的,你有没有什么adobe的东西装在 windows里?
Colin 摸清这些名单以后会在11.04新的 grub 里避开被这些家伙占用的扇区来修正这个问题.不过他第一次的代码有点问题,会一头撞上sda1,现在已经修好了:
viewtopic.php?f=77&t=320404
accessun
帖子: 20
注册时间: 2011-02-24 1:22
送出感谢: 0
接收感谢: 0

Re: windows 7和ubuntu双系统引导问题

#8

帖子 accessun » 2011-03-18 19:32

billbear 写了:如果每次进windows后grub就被破坏,基本上windows里有某些坏家伙.
Colin 正在搜集这些坏家伙的名单,你可以上报你的样本:
http://www.chiark.greenend.org.uk/ucgi/ ... table.html
目前多数情况是adobe干的,你有没有什么adobe的东西装在 windows里?
Colin 摸清这些名单以后会在11.04新的 grub 里避开被这些家伙占用的扇区来修正这个问题.不过他第一次的代码有点问题,会一头撞上sda1,现在已经修好了:
viewtopic.php?f=77&t=320404
谢谢楼上的回复,我在国外的ubuntu论坛上找到答案了。
我确实安装了Adobe的Acrobat 9.0,但是应该并不是Adobe的事。
我的电脑的品牌是DELL,在DELL的机器里通常会附带有DELL自己的数据安全软件,并且会在硬盘中创建一个DELLUTILITY分区。
这个分区会在每次计算机启动时对MBR动手脚,使GRUB不能正常工作。

解决方法是:
1、用Ubuntu的DVD重新安装GRUB,从而利用GRUB进入Windows
2、在Windows下卸载DELL DataSafe Online和DELL DataSafe Local Backup
3、以管理员身份运行cmd,在cmd中输入(下面代码的目的是打开“计算机管理”)
%windir%\system32\compmgmt.msc /s
选择“存储”>“磁盘管理”,将DELLUTILITY分区格式化
4、重启计算机,再次利用DVD修复GRUB
然后GRUB就恢复正常了,两个系统就都可以正常进入了。

但是按照这样做,Windows 7 自带的系统备份却不能正常工作了,这个我不知道怎么弄。。。
billbear
帖子: 3681
注册时间: 2008-05-03 23:42
送出感谢: 0
接收感谢: 3 次

Re: windows 7和ubuntu双系统引导问题

#9

帖子 billbear » 2011-03-19 11:42

没错,DELL DataSafe 也是被报告过写 boot track 的软件之一。移除它就可以了,并没有必要移除 DELL UTILITY 分区。而且 11.04 beta 之后的 grub 将会很好地与之共存。
回复

回到 “启动和引导”