当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求解:Ubuntu11.04正式版里,Firefox 4安装Flash插件,提示卸载一大堆软件包……
帖子发表于 : 2011-04-30 17:05 

注册: 2011-04-30 16:59
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
Ubuntu11.04正式版,Firefox 4安装Flash插件,提示卸载一大堆软件包……

果断求高手帮忙……我不想把那些软件都删除了啊。特别是那个NetworkManager :em06

代码:
chenyoca@Thinkpad:~$ sudo apt-get install flashplugin-installer
[sudo] password for chenyoca:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 flashplugin-installer : 依赖: libnss3-1d (>= 3.12.0~beta3) 但是它将不会被安装
                         依赖: libnspr4-0d (>= 4.7.1~beta2) 但是它将不会被安装
E: 破损的软件包
chenyoca@Thinkpad:~$ sudo apt-get install libnss3-1d libnspr4-0d flashplugin-installer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  libts-0.0-0 libmodplug1 libwildmidi0 libzbar0 libflite1 libdc1394-22
  libsoundtouch1c2 ttf-dejavu-extra libdca0 libopenspc0 java-common libfftw3-3
  libass4 libdirectfb-1.2-9 libmusicbrainz4c2a libenca0 libgif4 tzdata-java
  libgme0 freepats libkate1 libcdaudio1 libmimic0 tsconf libcelt0-0 librtmp0
  libmpcdec6 libofa0 libmms0 libiptcdata0
使用'apt-get autoremove'来卸载它们
建议安装的软件包:
  xulrunner-1.9 firefox-3.0 konqueror-nsplugins ttf-bitstream-vera ttf-dejavu
  ttf-xfree86-nonfree xfs
下列软件包将被【卸载】:
  empathy evolution evolution-data-server evolution-exchange
  evolution-indicator evolution-plugins evolution-webcal geoclue
  geoclue-ubuntu-geoip gnome-applets gnome-control-center gnome-panel
  indicator-applet indicator-applet-appmenu indicator-applet-complete
  indicator-applet-session indicator-datetime libcamel1.2-19 libebackend1.2-0
  libebook1.2-10 libecal1.2-8 libedata-book1.2-8 libedata-cal1.2-10
  libedataserver1.2-14 libedataserverui1.2-11 libegroupwise1.2-13 libevolution
  libnm-glib-vpn1 libnm-glib2 libnm-util1 libnspr4 libnss3 libpurple0
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-emailmerge libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-math
  libreoffice-style-human libreoffice-writer nautilus-sendto-empathy
  network-manager network-manager-gnome network-manager-pptp
  network-manager-pptp-gnome python-uno telepathy-haze ubuntu-desktop
  ubuntuone-client-gnome
下列【新】软件包将被安装:
  flashplugin-installer libnspr4-0d libnss3-1d
升级了 0 个软件包,新安装了 3 个软件包,要卸载 55 个软件包,有 0 个软件包未被升级。
需要下载 1,282 kB 的软件包。
解压缩后将会空出 277 MB 的空间。
您希望继续执行吗?[Y/n]n^Cchenyoca@Thinkpad:~$ clear

chenyoca@Thinkpad:~$ sudo apt-get install libnss3-1d libnspr4-0d flashplugin-installer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  libts-0.0-0 libmodplug1 libwildmidi0 libzbar0 libflite1 libdc1394-22
  libsoundtouch1c2 ttf-dejavu-extra libdca0 libopenspc0 java-common libfftw3-3
  libass4 libdirectfb-1.2-9 libmusicbrainz4c2a libenca0 libgif4 tzdata-java
  libgme0 freepats libkate1 libcdaudio1 libmimic0 tsconf libcelt0-0 librtmp0
  libmpcdec6 libofa0 libmms0 libiptcdata0
使用'apt-get autoremove'来卸载它们
建议安装的软件包:
  xulrunner-1.9 firefox-3.0 konqueror-nsplugins ttf-bitstream-vera ttf-dejavu
  ttf-xfree86-nonfree xfs
下列软件包将被【卸载】:
  empathy evolution evolution-data-server evolution-exchange
  evolution-indicator evolution-plugins evolution-webcal geoclue
  geoclue-ubuntu-geoip gnome-applets gnome-control-center gnome-panel
  indicator-applet indicator-applet-appmenu indicator-applet-complete
  indicator-applet-session indicator-datetime libcamel1.2-19 libebackend1.2-0
  libebook1.2-10 libecal1.2-8 libedata-book1.2-8 libedata-cal1.2-10
  libedataserver1.2-14 libedataserverui1.2-11 libegroupwise1.2-13 libevolution
  libnm-glib-vpn1 libnm-glib2 libnm-util1 libnspr4 libnss3 libpurple0
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-emailmerge libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-math
  libreoffice-style-human libreoffice-writer nautilus-sendto-empathy
  network-manager network-manager-gnome network-manager-pptp
  network-manager-pptp-gnome python-uno telepathy-haze ubuntu-desktop
  ubuntuone-client-gnome
下列【新】软件包将被安装:
  flashplugin-installer libnspr4-0d libnss3-1d
升级了 0 个软件包,新安装了 3 个软件包,要卸载 55 个软件包,有 0 个软件包未被升级。
需要下载 1,282 kB 的软件包。
解压缩后将会空出 277 MB 的空间。
您希望继续执行吗?[Y/n]n
中止执行。
chenyoca@Thinkpad:~$


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求解:Ubuntu11.04正式版里,Firefox 4安装Flash插件,提示卸载一大堆软件包……
帖子发表于 : 2011-04-30 18:03 

注册: 2011-04-30 7:21
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
下载一个 .deb的flash plugin包,安装即可,我也刚学,折腾了半天,才把这个插件装上 :em06


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求解:Ubuntu11.04正式版里,Firefox 4安装Flash插件,提示卸载一大堆软件包……
帖子发表于 : 2011-05-01 18:19 

注册: 2011-05-01 18:17
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
ff4不是不支持flash的吗?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译