这绝不是bug——关于开机出现等待60秒的提示的解决方案

启动讨论 grub/grub2/syslinux/grub4dos/Lilo
头像
zhw2101024
帖子: 1849
注册时间: 2009-03-28 16:10
系统: Arch debian win7
送出感谢: 9 次
接收感谢: 70 次
联系:

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#31

帖子 zhw2101024 » 2012-09-21 9:27

tusooa 写了:额。笨兔似乎早放弃了/etc/init.d了。
网络这一条还是要用到init.d,这里是ubuntu官方文档中关于server版网络配置的文档,里面最后一个就是用的init.d。没找到service对应的命令,如果有的话还请告知
shyness
帖子: 4
注册时间: 2010-10-26 22:33
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#32

帖子 shyness » 2012-09-22 20:17

我的ubuntu也是这样 而且 无限网卡驱动还不能使用
头像
sadboys2
帖子: 4
注册时间: 2011-08-29 17:19
系统: Ununtu 12.04
送出感谢: 0
接收感谢: 1 次

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#33

帖子 sadboys2 » 2012-09-28 13:45

第一次遇到的时候还真是慌了一下~~~~
修改好后开机感觉好多了~~ :em09
qiangweicc
帖子: 3
注册时间: 2012-09-28 14:13
系统: 12.04
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#34

帖子 qiangweicc » 2012-09-29 15:38

值得学习 :em11
349611904
帖子: 1
注册时间: 2012-10-08 18:59
系统: win7
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#35

帖子 349611904 » 2012-10-08 20:30

看看 谢谢分享 试下
fengback
帖子: 1
注册时间: 2012-02-16 22:32
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#37

帖子 fengback » 2012-10-23 16:25

谢谢拉[
yucejun
帖子: 6
注册时间: 2011-02-12 9:56
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#38

帖子 yucejun » 2012-12-11 17:14

可以用,但还是有点慢。可能是其他地方慢吧
xixuedafa
帖子: 8
注册时间: 2012-11-11 0:14
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#39

帖子 xixuedafa » 2012-12-17 21:51

好帖 :em11
goatok
帖子: 40
注册时间: 2008-03-31 23:26
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#40

帖子 goatok » 2013-01-07 20:51

学到些东西,感谢LZ和大家的热情讨论。
qu710458643
帖子: 3
注册时间: 2013-01-06 23:19
系统: win7 linux ubuntu
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#41

帖子 qu710458643 » 2013-01-08 17:45

楼主辛苦了 前来学习!!
dhqdqk
帖子: 49
注册时间: 2011-07-28 22:17
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#42

帖子 dhqdqk » 2013-02-02 16:18

可我这的有三处sleep,不知道区别。
# failsafe

description "Failsafe Boot Delay"
author "Clint Byrum <clint@ubuntu.com>"

start on filesystem and net-device-up IFACE=lo
stop on static-network-up or starting rc-sysinit

emits failsafe-boot

console output

script
# Determine if plymouth is available
if [ -x /bin/plymouth ] && /bin/plymouth --ping ; then
PLYMOUTH=/bin/plymouth
else
PLYMOUTH=":"
fi

# The point here is to wait for 2 minutes before forcibly booting
# the system. Anything that is in an "or" condition with 'started
# failsafe' in rc-sysinit deserves consideration for mentioning in
# these messages. currently only static-network-up counts for that.

sleep 20

# Plymouth errors should not stop the script because we *must* reach
# the end of this script to avoid letting the system spin forever
# waiting on it to start.
$PLYMOUTH message --text="Waiting for network configuration..." || :
sleep 40

$PLYMOUTH message --text="Waiting up to 60 more seconds for network configuration..." || :
sleep 59
$PLYMOUTH message --text="Booting system without full network configuration..." || :

# give user 1 second to see this message since plymouth will go
# away as soon as failsafe starts.
sleep 1
exec initctl emit --no-wait failsafe-boot
end script

post-start exec logger -t 'failsafe' -p daemon.warning "Failsafe of 120 seconds reached."


主要问题:并无grub提示等待,然后是读条界面:先是紫色背景,感觉时间要15s吧才能出现ubuntu的读条画面,又过一段时间20s吧才到登录界面,反正开机时间长;今天新装的12.04
头像
zhw2101024
帖子: 1849
注册时间: 2009-03-28 16:10
系统: Arch debian win7
送出感谢: 9 次
接收感谢: 70 次
联系:

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#43

帖子 zhw2101024 » 2013-02-03 11:12

dhqdqk 写了:可我这的有三处sleep,不知道区别。
# failsafe

description "Failsafe Boot Delay"
author "Clint Byrum <clint@ubuntu.com>"

start on filesystem and net-device-up IFACE=lo
stop on static-network-up or starting rc-sysinit

emits failsafe-boot

console output

script
# Determine if plymouth is available
if [ -x /bin/plymouth ] && /bin/plymouth --ping ; then
PLYMOUTH=/bin/plymouth
else
PLYMOUTH=":"
fi

# The point here is to wait for 2 minutes before forcibly booting
# the system. Anything that is in an "or" condition with 'started
# failsafe' in rc-sysinit deserves consideration for mentioning in
# these messages. currently only static-network-up counts for that.

sleep 20

# Plymouth errors should not stop the script because we *must* reach
# the end of this script to avoid letting the system spin forever
# waiting on it to start.
$PLYMOUTH message --text="Waiting for network configuration..." || :
sleep 40

$PLYMOUTH message --text="Waiting up to 60 more seconds for network configuration..." || :
sleep 59
$PLYMOUTH message --text="Booting system without full network configuration..." || :

# give user 1 second to see this message since plymouth will go
# away as soon as failsafe starts.
sleep 1
exec initctl emit --no-wait failsafe-boot
end script

post-start exec logger -t 'failsafe' -p daemon.warning "Failsafe of 120 seconds reached."


主要问题:并无grub提示等待,然后是读条界面:先是紫色背景,感觉时间要15s吧才能出现ubuntu的读条画面,又过一段时间20s吧才到登录界面,反正开机时间长;今天新装的12.04
sleep就是等待的意思。我觉得问题不在sleep,ubuntu的功能实在是太全了,所以开机肯定需要一些时间的。如果你想10秒内开机或者诸如此类的,抱歉我帮不了你,因为我没有这样的需要。我只能说换个发行版吧
头像
aerowolf
帖子: 1750
注册时间: 2006-02-25 17:09
来自: 西安
送出感谢: 34 次
接收感谢: 4 次

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#44

帖子 aerowolf » 2013-03-11 23:38

感谢楼主分享!
我去试一下,我的U也装在移动硬盘中,启动得好几分钟呀,而且越来越慢!
早起的鸟儿有虫吃
早起的虫儿被鸟吃

http://aerowolf.blog.sohu.com/
亲,点一下免费获得Dropbox空间!
jydu1980
帖子: 11
注册时间: 2013-03-20 14:49
系统: ubuntu 12.10
送出感谢: 0
接收感谢: 0

Re: 这绝不是bug——关于开机出现等待60秒的提示的解决方案

#45

帖子 jydu1980 » 2013-03-31 16:19

感谢了!!又学习了一个!
回复

回到 “启动和引导”