当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : EFI引导Ubuntu要如何是好
帖子发表于 : 2013-03-24 17:13 

注册: 2013-03-24 16:54
帖子: 4
系统: Mac Windows Linux X2
送出感谢: 0 次
接收感谢: 0 次
先跟大家说清楚我的情况啊:
1.采用EFI,三块硬盘都是GPT分区(1块128G M4,两块1T黑盘没Raid)
2.装了win8和win7用win7的BCD引导(不是色块的那个引导器),MSR分区在镁光M4上
3.现在装Ubuntu,装在1T硬盘的上,Grub被自动选择在SSD上面
4.安装成功后无法引导,重启Grub Rescue,Error:no such device :xxxxxx
5.看到Ubuntu官方有个关于EFI启动的问题解决方案(参照:https://help.ubuntu.com/community/UEFI)里面有:If the PC does not load Ubuntu (but instead loads Windows, for example, as in Bug #1050940), or if the Windows entry in the GRUB 2 menu does not boot Windows (see Bug #1024383), boot your PC using the Live CD/DVD or Live USB and choose "Try Ubuntu" once again. When the live session has loaded, run Boot-Repair (see link for details). When Boot-Repair loads, click on the "Recommended repair" button. Then reboot the pc.
我按照他说的运行了Boot-Repair之后重启画面变了,成GNU GRUB Version xxxxxx 换行grub>
依旧是Grub修复模式,看到网上好些人的遭遇我猜想是Grub找不到他的菜单了
说到这我再加一个背景:Ubuntu分区的时候我发现了Ubuntu把我的两块1T硬盘合并成了2T,可是我并没有Raid,而且同样的分区在出现了两遍,在安装程序里面相当混乱,搞得我头都大了,在Gparted里面就分区识别正常,但也认为有一块2T的硬盘
小弟只是为了做服务器搞个个人的Wordpress,没想到用EFI这么麻烦,以前用MBR的时候哪有这么多事...
请问各位大哥我该怎么去搞这个Grub?谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: EFI引导Ubuntu要如何是好
帖子发表于 : 2013-03-24 17:14 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
禁止。使用legacy模式。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 : Re: EFI引导Ubuntu要如何是好
帖子发表于 : 2013-03-24 17:39 

注册: 2013-03-24 16:54
帖子: 4
系统: Mac Windows Linux X2
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
禁止。使用legacy模式。

可我两个系统都是EFI的,不用EFI意味着我两个系统都要重装啊,工程量太大了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: EFI引导Ubuntu要如何是好
帖子发表于 : 2013-03-24 18:27 
头像

注册: 2009-07-01 16:34
帖子: 387
送出感谢: 2
接收感谢: 8
三个硬盘单独装系统,
以后切换会方便得多,
我两个硬盘也是这么做的,
一个装Win7,
一个装ubuntu,
用的EFI分区引导


页首
 用户资料  
 
5 楼 
 文章标题 : Re: EFI引导Ubuntu要如何是好
帖子发表于 : 2013-03-24 18:39 

注册: 2013-03-24 16:54
帖子: 4
系统: Mac Windows Linux X2
送出感谢: 0 次
接收感谢: 0 次
442449076 写道:
三个硬盘单独装系统,
以后切换会方便得多,
我两个硬盘也是这么做的,
一个装Win7,
一个装ubuntu,
用的EFI分区引导

现有条件不允许我重新安装系统啊


页首
 用户资料  
 
6 楼 
 文章标题 : Re: EFI引导Ubuntu要如何是好
帖子发表于 : 2013-03-24 20:12 
头像

注册: 2009-01-19 15:09
帖子: 1982
送出感谢: 4
接收感谢: 8
现在linux的EFI很不成熟。我安装几次了,只要在第一分区 分个EFI就行了。
都能正常启动。但我好几次,这样装好后,进不了BIOS。
把主板电池取下放电后,然后EFI,启动就没有了。
主板上原来有个叫Ubuntu的选项,不见了。
想尽一切办法,都找不回,启动也是进入grub rescue状态。
且用常用的非EFI方式不能修复。
幸亏我有个32位系统的启动菜单还能引导进去,卸载了EFI的所有启动项,重装grub-pc等软件后。把grub重装到该硬盘后,才能正常引导 。
我现在是怕了EFI了,几次失败不敢再试。
应该是EFI启动方式往主板写入了什么东西而导致主板不能进入BIOS。 :em20


_________________
坚守在linux的天堂!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译