当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 26 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 向arch高手求救
帖子发表于 : 2008-04-26 15:44 
头像

注册: 2007-08-05 12:16
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
error: could not prepare transaction
error: failed to commit transaction (conflicting files)
/opt/kde/share/apps/akregator/about/akregator.css exists in both 'kdepim' and 'kdemod-ui-kdemod'
/opt/kde/share/apps/akregator/about/main.html exists in both 'kdepim' and 'kdemod-ui-kdemod'
/opt/kde/share/apps/kmail/about/kmail.css exists in both 'kdepim' and 'kdemod-ui-kdemod'
/opt/kde/share/apps/kmail/about/main.html exists in both 'kdepim' and 'kdemod-ui-kdemod'
Errors occurred, no packages were upgraded.

这是一段错误反馈
我下载好kdemod了,但在安装时却出现以上内容
kdemod装不了,怎么回事啊,我狗狗的半天,没有答案,向高手求救。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-26 18:08 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
把这几个文件删掉或者改个名字。
这几个文件同时存在在两个以上的pac包里,导致了这个错误。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-27 17:16 
头像

注册: 2007-08-05 12:16
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
TheThirdGhost 写道:
把这几个文件删掉或者改个名字。
这几个文件同时存在在两个以上的pac包里,导致了这个错误。


按你方法搞定了  谢谢


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-01 12:37 
头像

注册: 2007-08-05 12:16
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
TheThirdGhost 写道:
把这几个文件删掉或者改个名字。
这几个文件同时存在在两个以上的pac包里,导致了这个错误。


又出现新问题了,上次按你的方法是解决了,但前提条件是,我先装了kdebase后再装kdemod之后,按你的方法是解决问题了。
可是现在的情况是,我没装kdebase,直接装的kdemod,我按你的方法想删除重复的文件,可是系统提示没有该文件,我也查看要删除的文件的路径,跟本就不存在该文件夹及路径,怎么回事啊?望高手指点
[/img]


附件:
.JPG
.JPG [ 489.17 KiB | 被浏览 1623 次 ]

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-01 16:43 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
嗯,你删掉了原来的kdelib?这个是kdepim的包和新的kdemod里kdepim的包冲突,你是在上次删了那几个文件以后又删了kdepim?试试看touch一下那几个文件有没有用。
比如 touch /opt/kde/share/apps/kmail/about/main.html


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-01 17:59 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
安装kdemod就不要安装普通的kde的库.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-01 22:43 

注册: 2007-05-13 10:59
帖子: 164
送出感谢: 0 次
接收感谢: 0 次
kdemod就是个独立的kde环境。
装了它就没必要装arch官方的任何的关于kde的东西。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-02 11:45 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
还有用pacman -f试试。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-02 12:48 
头像

注册: 2007-08-05 12:16
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
lyz_new 写道:
kdemod就是个独立的kde环境。
装了它就没必要装arch官方的任何的关于kde的东西。


那我如何去选择那些独立的kde环境呢?而不要别的官方的任何的关于kde的东西?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-03 10:24 
头像

注册: 2007-08-05 12:16
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
后来我这样解决的
我先安装了kdepim包(又附加安装了N多包),安装后装kdemod,又出现类似上面的话,然后按2楼的方法删除文件, 成功,再安装kdemod,就可以了
怪事,有人给个解释么?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-05-03 20:16 
头像

注册: 2006-07-23 16:25
帖子: 1592
地址: 南京
送出感谢: 0 次
接收感谢: 0 次
pacman -f 难道没用?


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-05-03 21:33 
头像

注册: 2006-06-01 19:10
帖子: 58
地址: China
送出感谢: 0 次
接收感谢: 0 次
可以的,用 pacman -Sf kdemod


_________________
ShareItem.org,记录着我学习 Linux 的点滴

AMD Athlon 64 X2 3800+
2G DDR2 667
nvidia 8600gt
Arch + kdemod 4.1


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-05-03 21:44 
头像

注册: 2007-10-29 22:12
帖子: 5353
地址: 江苏南京
系统: OSX 10.9 + Ub 1304
送出感谢: 0 次
接收感谢: 5
还是那句话,如果用kdemod就不要用官方kde的任何东西,一律用kdemod的替换


_________________
佛经说,人有八苦: 生、老、病、死、求不得、怨憎、爱别离、五阴盛 故我苦!
圣经说,人有七罪: 饕餮、贪婪、懒惰、淫欲、傲慢、嫉妒和暴怒  故我有罪!

我这篇帖子里面没有任何攻击我们伟大的中华人民共和国政府和任劳任怨的人民公仆(和本论坛高素质的版主)的文字和含义;

特此声明!

有些事,我们明知道是错的,也要去坚持,因为不甘心;有些人,我们明知道是爱的,也要去放弃,因为没结局;有时候,我们明知道没路了,却还在前行,因为习惯了。

欢迎来我的新浪微博@me


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-05-04 9:29 
头像

注册: 2007-08-05 12:16
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
TheThirdGhost 写道:
pacman -f 难道没用?


试了 但没用


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-05-04 9:29 
头像

注册: 2007-08-05 12:16
帖子: 113
送出感谢: 0 次
接收感谢: 0 次
suzebi 写道:
可以的,用 pacman -Sf kdemod


试过了 没用
我特地去看了官方文档 上面的命令基本都试了一遍


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 26 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译