[问题]arch 的配置求助

回复
huatai
帖子: 38
注册时间: 2008-08-23 21:57
送出感谢: 0
接收感谢: 0

[问题]arch 的配置求助

#1

帖子 huatai » 2008-08-27 20:28

arch装完后界面不稳定老闪,想把xorg.conf贴出来请教一下,可是进入gnome界面终端下xorg.con怎末用鼠标复制阿?
头像
qiang_liu8183
论坛版主
帖子: 10672
注册时间: 2006-09-10 22:36
来自: 北京
送出感谢: 1 次
接收感谢: 6 次

#2

帖子 qiang_liu8183 » 2008-08-27 21:02

鼠标选中,中建粘贴
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲
rgaobj
帖子: 209
注册时间: 2007-11-15 7:47
送出感谢: 0
接收感谢: 0

#3

帖子 rgaobj » 2008-08-27 21:40

不用贴了,首先确认你的显卡驱动装好没有,"# pacman -Ss xf86-video"找到适合你的驱动,然后"# pacman -S $driver-name"安装,然后"# vi /etc/X11/xorg.conf",找到类似以下内容,

Section "Monitor"
#DisplaySize 300 190 # mm
Identifier "Monitor0"
VendorName "AUO"
ModelName "1344"
HorizSync 60.0 - 100.0
VertRefresh 60.0 - 100.0

看看有没有HorizSync和VertRefresh两个参数(垂直和水平刷新率),如没有自己添加上,然后给出你显示器的区间,液晶屏的话不低于60就不会闪动了。
huatai
帖子: 38
注册时间: 2008-08-23 21:57
送出感谢: 0
接收感谢: 0

#4

帖子 huatai » 2008-08-27 22:03

我的是ati3450的显卡,pacman -S ati装的显卡驱动,hwd -xa声称的xorg.conf,垂直和水平刷新率按说明设定。台式显示器,刷新律从60-85都调整过,就是两个问题无法解决:1界面不稳定老闪,2 颜色过浅。请高人指点!
rgaobj
帖子: 209
注册时间: 2007-11-15 7:47
送出感谢: 0
接收感谢: 0

#5

帖子 rgaobj » 2008-08-27 22:45

闪动就是刷新率的问题,你不用指定一个唯一值,例如你可以设定为“75-100”,台显75就肯定不闪了。

颜色是色深的问题,在xorg.conf里找到

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 32
Modes "1280x800"
EndSubSection
EndSection

注意“Depth 32”,这里指定是就是色深,把8到16的那些段删掉,留下24或者32的,“Modes”指定的是分辨率。
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#6

帖子 jarryson » 2008-08-29 1:33

pacman -S ati
有这个命令?

pacman -S catalyst安装闭源驱动,xorg.conf驱动改为fglrx应该没有任何问题了

闪是说刷新率上不去还是画面波动之类的?颜色问题调整gamma值。不过一般是完全不需要的

wiki里面非常详细了
头像
qiang_liu8183
论坛版主
帖子: 10672
注册时间: 2006-09-10 22:36
来自: 北京
送出感谢: 1 次
接收感谢: 6 次

#7

帖子 qiang_liu8183 » 2008-08-29 1:39

jarryson 写了:pacman -S ati
有这个命令?

pacman -S catalyst安装闭源驱动,xorg.conf驱动改为fglrx应该没有任何问题了

闪是说刷新率上不去还是画面波动之类的?颜色问题调整gamma值。不过一般是完全不需要的

wiki里面非常详细了
jarryson也到处流浪了,知道sir什么时候恢复吗?
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#8

帖子 jarryson » 2008-08-29 1:58

这我还真不知道。哎。
huatai
帖子: 38
注册时间: 2008-08-23 21:57
送出感谢: 0
接收感谢: 0

#9

帖子 huatai » 2008-08-29 14:00

pacman -S catalyst安装闭源驱动,?需要编译么?
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#10

帖子 jarryson » 2008-08-29 16:39

你试试看不就知道了?会替换libgl。驱动安装非常非常简单
头像
lll9p
帖子: 1806
注册时间: 2007-07-18 18:56
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 lll9p » 2008-08-29 19:37

是官方的内核,安装闭源驱动不需要编译
rhwood
帖子: 148
注册时间: 2005-08-01 20:45
来自: Shanghai&Beijing
送出感谢: 0
接收感谢: 0

#12

帖子 rhwood » 2008-08-30 10:45

我一般是

代码: 全选

Xorg -configure
然后把生成的配置文件复制到/etc/X11就可以了。
回复

回到 “Arch发行版”