谁来帮我?

回复
头像
yangfuu
帖子: 82
注册时间: 2006-11-07 21:39
送出感谢: 0
接收感谢: 0
联系:

谁来帮我?

#1

帖子 yangfuu » 2008-11-05 17:30

[root@wei yanfuu]# pacman -Syu
:: 正在同步软件包数据库...
core 已经是最新版本
extra 已经是最新版本
community 已经是最新版本
testing 已经是最新版本
:: 正在进行全系统更新...
正在解决依赖关系...
正在查找内部冲突...

目标 (144): alsa-lib-1.0.17a-2 glib2-2.18.2-1 libpng-1.2.33-1
libcups-1.3.9-1 pango-1.22.2-1 gtk2-2.14.4-1 libxml2-2.6.32-5
orbit2-2.14.16-1 libbonobo-2.24.0-1 at-spi-1.24.0-2
。。。。。。

全部下载大小: 0.00 MB
全部安装大小: 1201.17 MB

进行安装吗? [Y/n] y
正在检查软件包完整性...
(144/144) 正在检查文件冲突 [#####################] 100%
错误:无法准备处理
错误:无法交付处理(有冲突的文件)
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/Kbuild
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/a.out-core.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/a.out.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/acpi.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/agp.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/alternative-asm.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/alternative.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/apic.h
。。。。。。

发生错误,没有软件包被更新。
dieluanhua
帖子: 51
注册时间: 2007-12-03 15:07
送出感谢: 0
接收感谢: 0

Re: 谁来帮我?

#2

帖子 dieluanhua » 2008-11-06 15:51

先pacman -Sf klibc
然后pacman -Syu
pearly
帖子: 45
注册时间: 2006-12-01 7:10
送出感谢: 0
接收感谢: 0

Re: 谁来帮我?

#3

帖子 pearly » 2008-11-06 20:08

yangfuu 写了:[root@wei yanfuu]# pacman -Syu
:: 正在同步软件包数据库...
core 已经是最新版本
extra 已经是最新版本
community 已经是最新版本
testing 已经是最新版本
:: 正在进行全系统更新...
正在解决依赖关系...
正在查找内部冲突...

目标 (144): alsa-lib-1.0.17a-2 glib2-2.18.2-1 libpng-1.2.33-1
libcups-1.3.9-1 pango-1.22.2-1 gtk2-2.14.4-1 libxml2-2.6.32-5
orbit2-2.14.16-1 libbonobo-2.24.0-1 at-spi-1.24.0-2
。。。。。。

全部下载大小: 0.00 MB
全部安装大小: 1201.17 MB

进行安装吗? [Y/n] y
正在检查软件包完整性...
(144/144) 正在检查文件冲突 [#####################] 100%
错误:无法准备处理
错误:无法交付处理(有冲突的文件)
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/Kbuild
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/a.out-core.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/a.out.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/acpi.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/agp.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/alternative-asm.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/alternative.h
klibc: 文件系统中已存在 /usr/lib/klibc/include/asm/apic.h
。。。。。。

发生错误,没有软件包被更新。
# rm /usr/lib/klibc/include/asm (这个目录只是个链接)
# pacman -Syu
回复

回到 “Arch发行版”