当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : arch安装NVIDIA时与libgl发生冲突,无法安装,怎么解决?
帖子发表于 : 2009-02-07 2:57 

注册: 2008-11-06 22:50
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
arch安装NVIDIA时与libgl发生冲突,无法安装,怎么解决?

[02:36:51][root@MMZC:~]# pacman -S nvidia
正在解决依赖关系...
正在查找内部冲突...
:: nvidia-utils 与 libgl 有冲突。删除 libgl? [Y/n] y
错误:无法准备事务处理 (无法满足依赖关系)
:: ati-dri: 要求 libgl>=7.2
:: intel-dri: 要求 libgl>=7.2
:: xf86-video-mach64: 要求 libgl>=7.2
:: xf86-video-mga: 要求 libgl>=7.2
:: xf86-video-r128: 要求 libgl>=7.2
:: xf86-video-savage: 要求 libgl>=7.2
:: xf86-video-sis: 要求 libgl>=7.2
:: xf86-video-tdfx: 要求 libgl>=7.2
:: xf86-video-trident: 要求 libgl>=7.2
[02:40:12][root@MMZC:~]# pacman -R libgl
正在检查依赖关系...
错误:无法准备事务处理 (无法满足依赖关系)
:: ati-dri: 要求 libgl>=7.2
:: capseo: 要求 libgl
:: intel-dri: 要求 libgl>=7.2
:: mesa: 要求 libgl
:: mplayer: 要求 libgl
:: pigment: 要求 libgl
:: xf86-video-mach64: 要求 libgl>=7.2
:: xf86-video-mga: 要求 libgl>=7.2
:: xf86-video-r128: 要求 libgl>=7.2
:: xf86-video-savage: 要求 libgl>=7.2
:: xf86-video-sis: 要求 libgl>=7.2
:: xf86-video-tdfx: 要求 libgl>=7.2
:: xf86-video-trident: 要求 libgl>=7.2
:: xorg-server: 要求 libgl

这个不让删除,这样驱动就安不上了,怎么处理呢?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: arch安装NVIDIA时与libgl发生冲突,无法安装,怎么解决?
帖子发表于 : 2009-02-07 7:03 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
pacman -Rd libgl


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译