当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-23 22:02 
头像

注册: 2008-01-10 14:03
帖子: 223
送出感谢: 0 次
接收感谢: 0 次
今天运行pacman -Su升级后发生了如下的情况:
引用:
:: Starting full system upgrade...
:: Replace amarok-base with extra/amarok? [Y/n] y
:: Replace amarok-engine-xine with extra/amarok? [Y/n] y
resolving dependencies...
looking for inter-conflicts...
:: xorg-server conflicts with catalyst-utils. Remove catalyst-utils? [Y/n] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xorg-server: conflicts with catalyst-utils


当然,如果第三项选择Y的话是这样的:
引用:
:: Starting full system upgrade...
:: Replace amarok-base with extra/amarok? [Y/n] y
:: Replace amarok-engine-xine with extra/amarok? [Y/n] y
resolving dependencies...
ylooking for inter-conflicts...
:: xorg-server conflicts with catalyst-utils. Remove catalyst-utils? [Y/n] y
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xorg-server: conflicts with catalyst-utils


看来我是无法升级了?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-24 19:20 
头像

注册: 2009-01-06 15:18
帖子: 480
送出感谢: 0 次
接收感谢: 0 次
用开源驱动好点


_________________
感谢您的支持! www.tonegoo.com


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-24 19:30 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
源里面没有catalyst了,是不是很久没有更新了?

你可以使用AUR里面的catalyst。支持2.6.29内核和xorg-server 1.6

不过你的显卡必须HD显卡以上。9.4驱动已经不支持R500以下了


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-24 23:28 
头像

注册: 2008-01-10 14:03
帖子: 223
送出感谢: 0 次
接收感谢: 0 次
我的显卡是xpress 1100系列的,似乎最新的catalyst不支持。

用闭源的驱动显示效果还好,不想换了,万一碰上什么问题都不好整。

看来系统得停留在这种状态下了--直到更换硬件~~


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-25 3:58 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
开源驱动2D性能绝对比闭源驱动好,不过3D不如,不过你用linux玩游戏么?如果是compiz的话,换了会更流畅


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-25 21:08 
头像

注册: 2008-01-10 14:03
帖子: 223
送出感谢: 0 次
接收感谢: 0 次
jarryson 写道:
开源驱动2D性能绝对比闭源驱动好,不过3D不如,不过你用linux玩游戏么?如果是compiz的话,换了会更流畅


我只用linux使用DOSBOX玩过DOS下面的几款经典游戏,其余的倒没怎么玩,真要玩大型的3D游戏还是转到Windows下面比较好(反正一般也不怎么玩游戏)。compiz根本就不想用,弄那么多华丽的效果,占用资源也大,除了炫一点没有其余作用,还不如gnome-do实用。如果真的喜欢那些的话我就选择MAC了。

开源驱动性能怎么样我不清楚,因为当初装ARCH的时候第一次选择的是开源驱动,结果怎么都无法启动X,所以换成了闭源的catalyst才好,也不知道现在这个问题解决了没有。如果没有的话我把CATALYST卸载了,然后又装不上闭源驱动,那不是玩完了?

还是稳定点比较好,用不着为了不着边际的性能折腾自己。

恩,下定决心了:现在系统不更新,除了个别软件全新安装外,一切保持原样----直到更换电脑。

PS:下次一定选择nvida的显卡,ati的害死人。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-26 22:07 

注册: 2007-11-08 20:58
帖子: 56
送出感谢: 1
接收感谢: 0 次
:em36 我也是被amd逼着用开源驱动的,内核到2.6.29,xorg-server到1.6后AMD的闭源驱动就不支持我的显卡了。
自我用linux来一直都是用闭源驱动的,这次升级困惑我好长段时间,不只是驱动的问题,是好多软件也都还没来得急支持。
现在算是过度到开源驱动里了,发现在开源驱动其实也不比闭源的差。


附件:
Screenshot.png
Screenshot.png [ 537.04 KiB | 被浏览 1011 次 ]

页首
 用户资料  
 
8 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-27 21:07 

注册: 2007-01-13 15:30
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
jarryson 写道:
开源驱动2D性能绝对比闭源驱动好,不过3D不如,不过你用linux玩游戏么?如果是compiz的话,换了会更流畅


开源驱动2D性能绝对比闭源驱动好?你说的是哪个驱动,xf86-video-ati(Radeon)还是xf86-video-radeonhd,话可不能说得绝对,或者你能否给出别的数据?

去年底,phoronix上对开源驱动和官方驱动作过对比,在ATI Radeon X1800XT这款显卡上,xf86-video-ati (Radeon)的2D性能不如catalyst。

引用:
While the Catalyst Linux driver is frequently criticized as being slow when it comes to the 2D performance, the Catalyst 8.12 driver with the ATI Radeon X1800XT graphics card had actually better performance than the open-source xf86-video-ati driver in 17 of the 28 tests performed using the Phoronix Test Suite. Though in some of the tests where the open-source ATI stack was faster, the Catalyst Linux driver was substantially slower (by up to five times or more in some of the tests).


http://www.phoronix.com/scan.php?page=a ... n_2d&num=1

xf86-video-radeonhd和catalyst在2D性能上也做了比较,可惜显卡不是同一款,用的是ATI Radeon HD 4850 (RV770),羸的是xf86-video-radeonhd。

http://www.phoronix.com/scan.php?page=a ... n_2d&num=1


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-04-29 21:47 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
不好意思,确实不同的显卡会有不同的效果。

如果在我的X700上比较,绝对开源驱动2D性能比较好,compiz流畅以外,gtkperf测试也高出不少。

而且我看过phoronix的测试,上面也确实catalyst的性能比较好,不过我当然说的是完全支持的卡,象x1800这样的,3D也不过是实验性质的,刚刚支持不久,性能不如很正常。

而且我感觉是直接使用老的radeon驱动来增加新显卡的支持,性能应该不如重新写的。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [求助]ARCH升级XORG和CATALYST冲突
帖子发表于 : 2009-05-30 10:30 

注册: 2009-01-17 17:28
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
:em04 pacman -Rd xxxxx 手动卸了


:em25

ps:

:em28
忘说了 rd xorg-server S utils S catalyst


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译