当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]firefox-amule关联成功了的进来看看,指出到底哪里有问题(已经解决,见一楼和十楼)
帖子发表于 : 2009-05-08 9:58 
头像

注册: 2008-02-03 18:53
帖子: 665
送出感谢: 0 次
接收感谢: 1
1.关闭firefox
2.根据`/.mozilla/firefox/下profiles.ini的内容,找到目前有效的 xxxx.default目录,我的为sawx49t0.default
3.编辑 `/.mozilla/firefox/sawx49t0.default下的prefs.js ,加入如下内容(加前搜索ed2k,有ed2k的行全删)


代码:
user_pref("network.protocol-handler.app.ed2k", "/usr/bin/ed2k");
user_pref("network.protocol-handler.expose.ed2k", false);
user_pref("network.protocol-handler.external.ed2k", true);


4.启动firefox,编辑--首选项---应用程序 ---ed2k---使用其它----浏览到/usr/bin/ed2k

我已经做到图中的步骤,离成功就差一步,到这一步后,点ed2k连接就是点不开,请教。


附件:
pic.jpg
pic.jpg [ 84.76 KiB | 被浏览 3600 次 ]



最后由 spectater 编辑于 2009-07-24 10:11,总共编辑了 2 次
页首
 用户资料  
 
2 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-05-08 10:05 
头像

注册: 2008-02-03 18:53
帖子: 665
送出感谢: 0 次
接收感谢: 1
我在ubuntu 和 arch 都可以做到图中的那一步, /usr/bin/ed2k可以浏览到,应不缺组件,但就是点不开ed2k 的连接


页首
 用户资料  
 
3 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-05-08 11:05 

注册: 2007-05-29 10:53
帖子: 53
送出感谢: 0 次
接收感谢: 0 次
我的也是这样,基本上放弃了
我的是Amd64


页首
 用户资料  
 
4 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-05-20 23:02 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
我已经放弃了……


页首
 用户资料  
 
5 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-05-20 23:04 
头像

注册: 2009-03-10 13:04
帖子: 7803
送出感谢: 1
接收感谢: 0 次
ChloeRei 写道:
我已经放弃了……

metoo


_________________
广告位招租


页首
 用户资料  
 
6 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-05-21 7:08 

注册: 2007-01-04 13:06
帖子: 81
送出感谢: 0 次
接收感谢: 0 次
打开一Firefox ,在地址区输入 about:config

版本为 3。0 以下的配置

按mouse 的右键,选New 然后选Boolen, 在 Preference Name空位输入
network.protocol-handler.external.ed2k ;其之值 ( Value) 为 true
现在再按一次 Mouse 右键,选 New然后选 String , 在 Preference Name空位输入
network.protocol-handler.app.ed2k,而 /usr/bin/ed2k 作为其值( Value)

版本为 3。0 或 3。0 以上的配置

按mouse 的右键,选New 然后选Boolen, 在 Preference Name空位输入
network.protocol-handler.expose.ed2k , 其值 ( Value)为false
在以后,首次从网页选取一下载项会要求你选程序ed2k的路经,选 /usr/bin/ed2k.

在Opera中的配置

打开一Opera,选工具(Tools) ->配置 ( Preferences) -> 程序 (Programms) -> Add...
在 "Protocol" 一栏输入 ed2k
在 "Open with another application" 一栏输入 /usr/bin/ed2k


页首
 用户资料  
 
7 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-05-21 7:11 

注册: 2008-11-27 13:03
帖子: 171
送出感谢: 0 次
接收感谢: 0 次
主楼的raleigh主题用的不错,不妨用高天,兼容的。


_________________
明后满清和X4学运都是日本卖淫惹得祸。毁中华文明可谓是路人皆知阿。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-07-03 11:02 
头像

注册: 2008-02-03 18:53
帖子: 665
送出感谢: 0 次
接收感谢: 1
fencrow 写道:
打开一Firefox ,在地址区输入 about:config

版本为 3。0 以下的配置

按mouse 的右键,选New 然后选Boolen, 在 Preference Name空位输入
network.protocol-handler.external.ed2k ;其之值 ( Value) 为 true
现在再按一次 Mouse 右键,选 New然后选 String , 在 Preference Name空位输入
network.protocol-handler.app.ed2k,而 /usr/bin/ed2k 作为其值( Value)

版本为 3。0 或 3。0 以上的配置

按mouse 的右键,选New 然后选Boolen, 在 Preference Name空位输入
network.protocol-handler.expose.ed2k , 其值 ( Value)为false
在以后,首次从网页选取一下载项会要求你选程序ed2k的路经,选 /usr/bin/ed2k.

在Opera中的配置

打开一Opera,选工具(Tools) ->配置 ( Preferences) -> 程序 (Programms) -> Add...
在 "Protocol" 一栏输入 ed2k
在 "Open with another application" 一栏输入 /usr/bin/ed2k


这方法和一楼是一样的,一楼直接改配制文件,更直接。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-07-05 21:00 

注册: 2009-03-04 13:01
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
1.安装aMule utils

sudo apt-get install amule-utils
(Debian/Ubuntu下如果不安装amule-utils,下面Firefox的设置就不起作用了)

2.Firefox 中设置关联

2-1. about:config
2-2.新建Boolean类型,输入network.protocol-handler.external.ed2k,值为true
2-3.新建String类型,输入network.protocol-handler.app.ed2k,值为/usr/bin/ed2k
2-4.新建Boolean类型,输入network.protocol-handler.expose.ed2k,值为false


页首
 用户资料  
 
10 楼 
 文章标题 : Re: firefox-amule关联成功了的进来看看,指出到底哪里有问题(高手不要进,进来就不要泼凉水!)
帖子发表于 : 2009-07-24 10:08 
头像

注册: 2008-02-03 18:53
帖子: 665
送出感谢: 0 次
接收感谢: 1
一直没管, 只是pacman -Syu, 最近发现可以自动下载了,莫名其妙,

证明一楼的方法与网上盛传的方法(6楼,9楼)具有同等效力


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [已解决]firefox-amule关联成功了的进来看看,指出到底哪里有问题(已经解决,见一楼和十楼)
帖子发表于 : 2009-07-24 20:00 

注册: 2006-12-03 23:00
帖子: 277
送出感谢: 0 次
接收感谢: 0 次
我也刚处理了类似的问题,firefox+amulecmd,记在这里:
http://eidolon.javaeye.com/blog/432083


_________________
好吧,听某人的建议,修改下签名。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [已解决]firefox-amule关联成功了的进来看看,指出到底哪里有问题(已经解决,见一楼和十楼)
帖子发表于 : 2009-11-08 11:28 

注册: 2009-11-08 11:24
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
今天刚解决了类似的问题。

如果在Ubuntu上安装的是ubuntu repository中的firefox,下面的配置项似乎无法保存:

pref("network.protocol-handler.expose.ed2k", false);

但是发现了一个包,装上就管用了:

amule-gnome-support


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [已解决]firefox-amule关联成功了的进来看看,指出到底哪里有问题(已经解决,见一楼和十楼)
帖子发表于 : 2009-12-11 16:07 

注册: 2006-12-23 17:45
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
12 楼 方法有效
:em11


页首
 用户资料  
 
14 楼 
 文章标题 : Re: [已解决]firefox-amule关联成功了的进来看看,指出到底哪里有问题(已经解决,见一楼和十楼)
帖子发表于 : 2009-12-12 23:17 
头像

注册: 2008-11-29 22:56
帖子: 578
地址: Guangdong Pharmaceutical University
送出感谢: 0 次
接收感谢: 0 次
Arch怎么没有amule-dlp-gnome-support? :em20 :em20


_________________
猪圈里的猪想着去解放全世界


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译