当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 升级了系统,无法进X。
帖子发表于 : 2009-07-02 17:20 

注册: 2008-06-09 15:40
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
在升级的时候有升级X-server目前 X Server版本是 1.6.1.901 (1.6.2 RC 1)内核是2.6.30,显卡是GeForce4 mx 4000,
Xorg.0.log的内容如下:
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.6.1.901 (1.6.2 RC 1)
Release Date: 2009-5-8
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30-ARCH i686
Current Operating System: Linux mj 2.6.30-ARCH #1 SMP PREEMPT Fri Jun 19 21:25:17 UTC 2009 i686
Build Date: 28 June 2009 11:20:52AM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 2 16:33:41 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "AutoAddDevices" "False"
(**) Not automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
/usr/share/fonts/misc,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/TTF,
/usr/share/fonts/Type1,
/usr/share/fonts/misc,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/TTF,
/usr/share/fonts/Type1,
built-ins
(**) ModulePath set to "/usr/lib/xorg/modules"
(**) Extension "Composite" is enabled
(II) Loader magic: 0x640
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0:1:0:0) 10de:0185:10de:0156 nVidia Corporation NV18 [GeForce4 MX 4000] rev 193, Mem @ 0xdc000000/16777216, 0xd0000000/134217728, BIOS @ 0x????????/131072
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "extmod"
(II) Reloading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 1.6.0, module version = 1.4.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 4.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.6.0, module version = 1.3.2
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 4.0
(II) NVIDIA dlloader X Driver 96.43.11 Mon Feb 23 15:32:04 PST 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
根据E文的提示,是不是要重装显卡的驱动?GeForce4 mx 4000的linux下的驱动好像不支持上述版本的X-server.
重装显卡驱动提示:ERROR:Unable to build the NVIDIA kernel module.
该怎么办?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-02 17:59 

注册: 2008-06-09 15:40
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
是不是要等nvidia更新驱动?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-03 6:17 

注册: 2009-06-30 3:27
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
估计是没启动 hal .
我今天重装了arch, 找不到 libreadline.so.5 了,何解.我一晚上没睡啊!
sh:error while loading shared libraresLlibreadline.so.5 :cannot open shared object file:no such file or directory....


BuG? :em20


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-03 6:17 

注册: 2009-06-30 3:27
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
估计是没启动 hal .
我今天重装了arch, 找不到 libreadline.so.5 了,何解.我一晚上没睡啊!
sh:error while loading shared libraresLlibreadline.so.5 :cannot open shared object file:no such file or directory....


BuG? :em20


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-03 6:19 

注册: 2009-06-30 3:27
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
一激动就发了两次, 今天的linuxsir怎么不能发贴了?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-03 10:37 

注册: 2008-06-09 15:40
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
你用的ISO是?
我在装2008.06的时候也出现类似的情况。最后还是重装了一遍才好的。
具体情况也不清楚。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-03 10:41 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
基本就是显卡驱动了。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-03 10:50 

注册: 2008-06-09 15:40
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
那是要等NVIDIA更新驱动了?有没有其他驱动可用的?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-04 5:40 

注册: 2009-06-30 3:27
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
看来我的arch注定是没有X了,换了个2009.2 和 2009.5都不行,难道只能ftp安装?
pacman 的时候我倒是见到了 libreadline.so.6.0 !有那位大虾有什么高招吗


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-04 5:42 

注册: 2009-06-30 3:27
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
用mesa驱动看看!
把/etc/X11/xorg.conf修改了


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-04 6:00 
头像

注册: 2006-02-28 3:11
帖子: 2470
送出感谢: 0 次
接收感谢: 0 次
我的烂intel的显卡, 早就不能直接的进去了。

试试用默认的twm,若是能进去, 再启动别的WM。 我这就是这么解决的


_________________
一梦三年,
松风依旧,
萝月何曾老.


灵幽听微, 谁观玉颜?
灼灼春华, 绿叶含丹.


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-05 19:10 

注册: 2008-01-13 1:17
帖子: 355
送出感谢: 0 次
接收感谢: 0 次
引用:
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX


你是如何安装驱动的啊.glx为啥会是X.Org的?

正确的应该是下面的字样.
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"

重新pacman -S nvidia-96xx 或 pacman -S nvidia-173xx
(GF4应该只能用96xx)


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-05 20:12 

注册: 2009-06-30 3:27
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我的问题总算有着落了。 今天在老外一网上看到L:arkham wrote:
1) Boot an Arch live
2) Mount your arch partition on /mnt
3) Run pacman -r /mnt -Syu
:em11


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-05 20:29 
头像

注册: 2008-12-09 12:44
帖子: 3864
地址: 北京
送出感谢: 0 次
接收感谢: 2
那些代码我不懂,不过我感觉最好使用开源驱动,如果使用官方驱动,有时会出现升级后无法进入X的现象。

如果非要使用官方驱动达到更好的效果,那就最好在升级一些系统比较关键的部分时,先把官方驱动卸载,重启,再升级,然后再重装官方驱动。

个人看法,仅供参考。


_________________
Pity is the bomp!
活着就是折腾!生命不息,折腾不止!
看这帮家伙在干什么?@pityonline/u
Dropbox+Vps+PC 跑起来了!这是邀请链接


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 升级了系统,无法进X。
帖子发表于 : 2009-07-06 0:59 

注册: 2008-01-13 1:17
帖子: 355
送出感谢: 0 次
接收感谢: 0 次
pityonline 写道:
那些代码我不懂,不过我感觉最好使用开源驱动,如果使用官方驱动,有时会出现升级后无法进入X的现象。


nvidia正好相反.最好使用官方驱动.

"最好使用开源驱动" 这句话只对其它显卡有效.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译