当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 挂载分区的问题
帖子发表于 : 2009-08-03 11:03 

注册: 2009-07-13 21:54
帖子: 543
送出感谢: 10
接收感谢: 8
环境: 用的xfce4,安装了thunar-volman
症状: sudo mount 了ntfs分区到/media/后,结果当前用户( 非root) 无权进入,permission denied,晕,连里面有啥都看不到
已做的:已经把当前用户加了storage组,还按照wiki_hal,创建20-ntfs-config-write-policy.fdi以打开ntfs写入支持,修改Policykit.conf以改变挂载权限(已把当前用户加入)
效果: 无效
sb help!


_________________
南无阿弥陀佛


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 挂载分区的问题
帖子发表于 : 2009-08-03 11:11 
头像

注册: 2008-02-17 23:47
帖子: 22108
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 82
嘿嘿,我开始也这样,后来发现两个办法
1. 用fstab挂载,defaults后面加上uid=<用户名>就可以
2. 用mount挂载后,sudo chown <用户名> <挂载目录名>


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 挂载分区的问题
帖子发表于 : 2009-08-03 11:16 

注册: 2009-07-13 21:54
帖子: 543
送出感谢: 10
接收感谢: 8
呵呵,够速度
谢谢楼上,试试


_________________
南无阿弥陀佛


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 挂载分区的问题
帖子发表于 : 2009-08-03 19:53 
头像

注册: 2008-02-12 19:47
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
我是用fstab挂的,但NTFS分区中文部分乱码(为啥不是全部。。。晕)。挂载参数增加cp936或nft8均无效。。。locale查看了下,全是gb10830,我记得在rc.conf里设的是zh_CN.UTF-8啊,不知为啥和locale里的不一样。。。这块很乱,谁来讲讲啊,谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 挂载分区的问题
帖子发表于 : 2009-08-03 22:11 
头像

注册: 2008-02-17 23:47
帖子: 22108
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 82
你的locale是18030,就应该把参数搞成18030啊


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 挂载分区的问题
帖子发表于 : 2009-08-03 23:20 
头像

注册: 2008-02-12 19:47
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
原来是GDM登录时误选了GB18030。。。改回UTF8后一切OK。。。这次折腾ARCH真费了不少劲,用了这种一切都要自已来的系统,想想ubuntu和fedora在易用性方面是下了功夫啊 :em04


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 挂载分区的问题
帖子发表于 : 2009-08-05 11:12 

注册: 2009-07-13 21:54
帖子: 543
送出感谢: 10
接收感谢: 8
看来还是该按wiki做全,参照wiki处理CJK字符问题的解决方法,
新建/sbin/mount.ntfs-3g --> 加执行权限 --> ln -s /sbin/mount.ntfs-3g /sbin/mont.ntfs

这样ntfs的写入权限就打开了,但挂载权限还没有,可能修改Policykit.conf的时候哪里做错了??


_________________
南无阿弥陀佛


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 挂载分区的问题
帖子发表于 : 2009-08-05 11:50 
头像

注册: 2008-02-12 19:47
帖子: 262
送出感谢: 0 次
接收感谢: 0 次
直接在fstab里挂载就没问题了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译