当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-23 22:53 

注册: 2007-05-12 21:14
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
[home@myhost ~]$ sudo yaourt -S gst-plugins-pps-git
==> WARNING: Building unsupported package as root is dangerous.
Please run yaourt as a non-privileged user.
==> Resuming previous build

==> Downloading gst-plugins-pps-git PKGBUILD from AUR...
tar: 记录大小 = 6 块

Comment by: MaJia321 on Fri, 28 Aug 2009 12:54:41 +0000
May libpps & codecs be added to depends lines ?

Comment by: imagelife on Fri, 28 Aug 2009 13:12:36 +0000
well,I will add libpps to depends,but the codecs didn't need ,because it's totem plugin.
if you need codecs,please install totem codecs.

Comment by: sfbi on Fri, 28 Aug 2009 16:08:42 +0000
It fails here in 64-bit version. Any solutions?
checking whether pps libraris is available... no
checking whether pps 32bit libraris is available... no
configure: error: 'couldn't find pps libraries.
make: aurpage comments PKGBUILD PKGBUILD~ No targets specified and no makefile found. Stop.
==> ERROR: Build Failed.
Aborting...
Error: Makepkg was unable to build gst-plugins-pps-git package.

Comment by: imagelife on Sat, 05 Sep 2009 15:54:36 +0000
作者已经将该软件gst-plugins-pps分成3个了,使用的童鞋需要安装一下软件才能使用。
gst-plugins-pps-git http://aur.archlinux.org/packages.php?ID=29660
libppswrapper-git http://aur.archlinux.org/packages.php?ID=29885
totem-pps-git http://aur.archlinux.org/packages.php?ID=29886
额,我感觉是打包是麻烦些了。等软件稳定后,再传stable的版本到aur里面吧。


First Submitted: Fri, 28 Aug 2009 07:28:30 +0000
gst-plugins-pps-git 20090920-1 : PPStream plugin for gstreamer
( Unsupported package: Potentally dangerous ! )
==> Edit the PKGBUILD (highly recommended for security reasons) ? [Y/n]("A" to abort)
==> ----------------------------------------------
==>n


==> gst-plugins-pps-git dependencies:
- gstreamer0.10 (already installed)
- gstreamer0.10-base-plugins (already installed)
- libppswrapper-git (already installed)
- git (already installed)
==> Continue the building of gst-plugins-pps-git ? [Y/n]
==> ----------------------------------------------
==>y


==> Install or build missing dependencies for gst-plugins-pps-git:
==> Building and installing package
==> Yaourt has detected previous gst-plugins-pps-git build. Do you want to use it (faster) ? [Y/n]
==> ----------------------------------------------
==>y

cp: 略过目录"./comments"

==> gst-plugins-pps-git dependencies:
- gstreamer0.10 (already installed)
- gstreamer0.10-base-plugins (already installed)
- libppswrapper-git (already installed)
- git (already installed)
==> 正在确认最新的 git 修正...
-> 找到版本:20090923
==> 正在创建软件包:gst-plugins-pps-git 20090923-1 i686 (2009年 09月 23日 星期三 22:53:05 CST)
==> 正在检查运行时依赖关系...
==> 正在检查编译时依赖关系...
==> 获取源代码...
==> 解压缩源码...
==> 正在删除现有的 pkg/ 目录...
==> 正在开始 build()...
==> Connecting to GIT server...
Already up-to-date.
==> GIT checkout done or server timeout
==> Starting make...
+ Setting up common submodule
Submodule 'common' (git://anongit.freedesktop.org/gstreamer/common) registered for path 'common'
Initialized empty Git repository in /var/abs/local/yaourtbuild/gst-plugins-pps-git/src/gst-plugins-pps-build/common/.git/
remote: Counting objects: 2530, done.
remote: Compressing objects: 100% (1025/1025), done.
remote: Total 2530 (delta 1684), reused 2233 (delta 1497)
Receiving objects: 100% (2530/2530), 384.97 KiB | 233 KiB/s, done.
Resolving deltas: 100% (1684/1684), done.
Submodule path 'common': checked out '709b55890b5fc1354fa867f9280e332a15cc2bf9'
+ check for build tools
checking for autoconf >= 2.52 ... found 2.64, ok.
checking for automake >= 1.7 ... found 1.11, ok.
checking for autopoint >= 0.17 ... found 0.17, ok.
checking for libtoolize >= 1.5.0 ... found 2.2.6, ok.
checking for pkg-config >= 0.8.0 ... found 0.23, ok.
+ checking for autogen.sh options
This autogen script will automatically run ./configure as:
./configure --enable-maintainer-mode --enable-gtk-doc --enable-plugin-docs
To pass any additional options, please specify them on the ./autogen.sh
command line.
patching file po/Makefile.in.in
Hunk #1 succeeded at 15 with fuzz 2 (offset 4 lines).
+ running autopoint --force ...
autopoint: *** cvs program not found
autopoint: *** Stop.

autopoint --force failed
/var/abs/local/yaourtbuild/gst-plugins-pps-git/./PKGBUILD: line 38: ./configure: 没有那个文件或目录
make: *** 没有指明目标并且找不到 makefile。 停止。
==> 错误: 创建失败。
正在放弃...
Error: Makepkg was unable to build gst-plugins-pps-git package.


之前有成功安装过一次,后来因为音画不同步把TOTEM和插件都删掉了,这两天重新安装就一直出现这个错误,请大家帮我看看是出了什么问题。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-24 7:23 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
即然你是sudo ,如果上次成功的那一次也是sudo , 那原来编译成功的pkg包应都还在,直接找出来装上就是了

我昨天执行了一次,git没有问题了
代码:
yaourt -S libppswrapper-git gst-plugins-pps-git totem-pps-git libpps gst-plugins-sopcast-git totem-sopcast-git




我不是说你编译不成功和下面的操作有关,仔细看提示,有时候很容易忽略:
linxinjie 写道:


==> Install or build missing dependencies for gst-plugins-pps-git:
==> Building and installing package
==> Yaourt has detected previous gst-plugins-pps-git build. Do you want to use it (faster) ? [Y/n]
==> ----------------------------------------------
==>y


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-24 7:58 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
如果原来是sudo yaourt , /var/abs/local/yaourtbuild下可以找到以前的二进制pkg安装包的,直接装上就是了。

我不喜欢sudo , 每次安装之前,在/temp/下也可找到。


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-24 8:39 

注册: 2007-05-12 21:14
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
我上次成功安装是没有用sudo的,后来重新安装没用sudo不成功,才用sudo的


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-24 10:05 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
linxinjie 写道:
我上次成功安装是没有用sudo的,后来重新安装没用sudo不成功,才用sudo的


如果不行,也可以试下非git 的aur . aur中有现成的。

毕竟git的实在是太新了。


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-24 21:24 

注册: 2007-05-12 21:14
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
skyx 写道:
linxinjie 写道:
我上次成功安装是没有用sudo的,后来重新安装没用sudo不成功,才用sudo的


如果不行,也可以试下非git 的aur . aur中有现成的。

毕竟git的实在是太新了。

谢谢你,我用这个方法装好了。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-24 21:27 

注册: 2007-05-12 21:14
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
但是播放的时候怎么总是会音画不一致呢????????


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-25 10:41 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
linxinjie 写道:
但是播放的时候怎么总是会音画不一致呢????????


sopcast在totem上是有这个问题, 这应是totem的问题

mplayer 没这个问题:

代码:
sp-sc sop://broker.sopcast.com:3912/6004 3908 8908 > /dev/null &


代码:
mplayer http://localhost:8908/tv.asf


代码:
totem http://localhost:8908/tv.asf


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-25 21:01 

注册: 2007-05-12 21:14
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
好像使用Totem-xine也不会有音画不同步的问题,可惜插件不支持Totem-xine。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 安装不了sopcast,pps插件,请大家帮我看看
帖子发表于 : 2009-09-26 7:52 

注册: 2007-05-12 21:14
帖子: 63
送出感谢: 0 次
接收感谢: 0 次
mms竟然也不能播放提示错误:此电影的回放需要 Microsoft 媒体服务协议(MMS)源 插件,但该插件尚未安装。这是什么意思?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译